The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of MongoDB: denial of service via Index Name

Synthesis of the vulnerability 

An authenticated attacker can use an empty Index Name in MongoDB, in order to trigger a denial of service.
Vulnerable products: MongoDB Server.
Severity of this weakness: 2/4.
Creation date: 30/03/2015.
Références of this bulletin: CVE-2015-2705, FG-VD-15-018, VIGILANCE-VUL-16494.

Description of the vulnerability 

The MongoDB product implements a database supporting indexes.

However, if the name of an index is empty in "createIndexes", a fatal error occurs in the src/mongo/db/catalog/index_catalog.cpp file.

An authenticated attacker can therefore use an empty Index Name in MongoDB, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat alert impacts software or systems such as MongoDB Server.

Our Vigil@nce team determined that the severity of this weakness announce is medium.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this computer weakness bulletin.

Solutions for this threat 

MongoDB: version 3.0.1.
The version 3.0.1 is fixed:
  http://www.mongodb.org/downloads
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an application vulnerability alert. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.