The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Mozilla NSS: buffer overflow via Cryptographic Primitives

Synthesis of the vulnerability 

An attacker can trigger a buffer overflow via Cryptographic Primitives of Mozilla NSS, in order to trigger a denial of service, and possibly to run code.
Vulnerable products: Debian, NSS, openSUSE Leap, RHEL, RSA Authentication Manager, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this weakness: 3/4.
Creation date: 31/12/2019.
Références of this bulletin: CVE-2019-17006, DLA-2058-1, DLA-2388-1, DSA-2020-066, DSA-2020-067, DSA-4726-1, openSUSE-SU-2020:0008-1, openSUSE-SU-2020:0854-1, RHSA-2020:3280-01, RHSA-2020:4076-01, SUSE-SU-2019:3395-1, SUSE-SU-2020:14418-1, SUSE-SU-2020:1677-1, SUSE-SU-2020:1839-1, USN-4231-1, VIGILANCE-VUL-31248.

Description of the vulnerability 

An attacker can trigger a buffer overflow via Cryptographic Primitives of Mozilla NSS, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability impacts software or systems such as Debian, NSS, openSUSE Leap, RHEL, RSA Authentication Manager, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this weakness bulletin is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this weakness.

Solutions for this threat 

Mozilla NSS: version 3.46.
The version 3.46 is fixed:
  https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS

Debian 10: new nss packages.
New packages are available:
  Debian 10: nss 2:3.42.1-1+deb10u3

Debian 8: new nss packages.
New packages are available:
  Debian 8: nss 2:3.26-1+debu8u10

Debian 9: new nss packages.
New packages are available:
  Debian 9: nss 2:3.26.2-1.1+deb9u2

openSUSE Leap 15.1: new mozilla-nspr packages (13/01/2020).
New packages are available:
  openSUSE Leap 15.1: mozilla-nspr 4.23-lp151.2.6.1, mozilla-nss 3.47.1-lp151.2.9.1

openSUSE Leap 15.1: new mozilla-nspr packages (24/06/2020).
New packages are available:
  openSUSE Leap 15.1: mozilla-nspr 4.25-lp151.2.9.1, mozilla-nss 3.53-lp151.2.23.1

RHEL 7.9: new nss/nspr packages.
New packages are available:
  RHEL 7.9: nspr 4.25.0-2.el7_9, nss 3.53.1-3.el7_9

RHEL 8.2: new nss/nspr packages.
New packages are available:
  RHEL 8.2: nspr 4.25.0-2.el8_2, nss 3.53.1-11.el8_2

RSA Authentication Manager: version 8.4 P11.
The version 8.4 P11 is fixed:
  https://www.dell.com/support/

SUSE LE 11 SP4: new mozilla-nspr/mozilla-nss packages.
New packages are available:
  SUSE LE 11 SP4: mozilla-nspr 4.25-29.12.2, mozilla-nss 3.53.1-38.23.1

SUSE LE 12: new mozilla-nspr/mozilla-nss packages.
New packages are available:
  SUSE LE 12 SP2: mozilla-nspr 4.25-19.15.1, mozilla-nss 3.53.1-58.48.1
  SUSE LE 12 SP3: mozilla-nspr 4.25-19.15.1, mozilla-nss 3.53.1-58.48.1
  SUSE LE 12 SP4: mozilla-nspr 4.25-19.15.1, mozilla-nss 3.53.1-58.48.1
  SUSE LE 12 SP5: mozilla-nspr 4.25-19.15.1, mozilla-nss 3.53.1-58.48.1

SUSE LE 15: new mozilla-nspr / mozilla-nss packages.
New packages are available:
  SUSE LE 15 RTM: mozilla-nspr 4.25-3.12.1, mozilla-nss 3.53-3.40.1
  SUSE LE 15 SP1: mozilla-nspr 4.25-3.12.1, mozilla-nss 3.53-3.40.1
  SUSE LE 15 SP2: mozilla-nspr 4.25-3.12.1, mozilla-nss 3.53-3.40.1

SUSE LE 15: new mozilla-nspr, mozilla-nss packages.
New packages are available:
  SUSE LE 15 RTM: mozilla-nspr 4.23-3.9.1, mozilla-nss 3.47.1-3.22.1
  SUSE LE 15 SP1: mozilla-nspr 4.23-3.9.1, mozilla-nss 3.47.1-3.22.1

Ubuntu: new libnss3 packages.
New packages are available:
  Ubuntu 19.10: libnss3 2:3.45-1ubuntu2.2
  Ubuntu 19.04: libnss3 2:3.42-1ubuntu2.5
  Ubuntu 18.04 LTS: libnss3 2:3.35-2ubuntu2.7
  Ubuntu 16.04 LTS: libnss3 2:3.28.4-0ubuntu0.16.04.10
  Ubuntu 14.04 ESM: libnss3 2:3.28.4-0ubuntu0.14.04.5+esm4
  Ubuntu 12.04 ESM: libnss3 2:3.28.4-0ubuntu0.12.04.7
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computers vulnerabilities announces. The Vigil@nce vulnerability database contains several thousand vulnerabilities.