The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Node.js fstream: privilege escalation via File Overwrite

Synthesis of the vulnerability 

An attacker can bypass restrictions via File Overwrite of Node.js fstream, in order to escalate his privileges.
Impacted systems: Nodejs Modules ~ not comprehensive, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 2/4.
Creation date: 15/05/2019.
Références of this alert: CVE-2019-13173, NPM-886, openSUSE-SU-2019:1846-1, openSUSE-SU-2019:1907-1, SUSE-SU-2019:2055-1, SUSE-SU-2019:2078-1, SUSE-SU-2019:2081-1, SUSE-SU-2019:2099-1, SUSE-SU-2019:2181-1, SUSE-SU-2020:0059-1, USN-4123-1, VIGILANCE-VUL-29315.

Description of the vulnerability 

An attacker can bypass restrictions via File Overwrite of Node.js fstream, in order to escalate his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness bulletin impacts software or systems such as Nodejs Modules ~ not comprehensive, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer weakness is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this vulnerability announce.

Solutions for this threat 

Node.js fstream: version 1.0.12.
The version 1.0.12 is fixed:
  https://www.npmjs.com/package/fstream

openSUSE Leap 15.1: new nodejs10 packages.
New packages are available:
  openSUSE Leap 15.1: nodejs10 10.16.0-lp151.2.3.1

openSUSE Leap: new nodejs8 packages.
New packages are available:
  openSUSE Leap 15.0: nodejs8 8.15.1-lp150.2.16.1
  openSUSE Leap 15.1: nodejs8 8.15.1-lp151.2.3.1

SUSE LE 12: new nodejs10 packages.
New packages are available:
  SUSE LE 12 RTM-SP5: nodejs10 10.16.0-1.9.1

SUSE LE 12: new nodejs12 packages.
New packages are available:
  SUSE LE 12 RTM-SP5: nodejs12 12.13.0-1.3.1

SUSE LE 12: new nodejs4 packages.
New packages are available:
  SUSE LE 12 RTM-SP5: nodejs4 4.9.1-15.23.1

SUSE LE 12: new nodejs6 packages.
New packages are available:
  SUSE LE 12 RTM-SP5: nodejs6 6.17.0-11.27.1

SUSE LE 15: new nodejs10 packages.
New packages are available:
  SUSE LE 15 RTM: nodejs10 10.16.0-1.9.1
  SUSE LE 15 SP1: nodejs10 10.16.0-1.9.1

SUSE LE 15: new nodejs8 packages.
New packages are available:
  SUSE LE 15 RTM: nodejs8 8.15.1-3.17.1
  SUSE LE 15 SP1: nodejs8 8.15.1-3.17.1

Ubuntu: new node-fstream packages.
New packages are available:
  Ubuntu 19.04: node-fstream 1.0.10-1ubuntu0.19.04.2
  Ubuntu 18.04 LTS: node-fstream 1.0.10-1ubuntu0.18.04.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a system vulnerability announce. The technology watch team tracks security threats targeting the computer system.