The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of OpenCV: denial of service via cv-HOGDescriptor-getDescriptorSize

Synthesis of the vulnerability 

An attacker can trigger a fatal error via cv::HOGDescriptor::getDescriptorSize() of OpenCV, in order to trigger a denial of service.
Vulnerable products: openSUSE Leap, SLES.
Severity of this weakness: 1/4.
Creation date: 06/12/2019.
Références of this bulletin: CVE-2019-15939, openSUSE-SU-2019:2671-1, SUSE-SU-2019:3192-1, SUSE-SU-2019:3192-2, VIGILANCE-VUL-31080.

Description of the vulnerability 

An attacker can trigger a fatal error via cv::HOGDescriptor::getDescriptorSize() of OpenCV, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness impacts software or systems such as openSUSE Leap, SLES.

Our Vigil@nce team determined that the severity of this vulnerability announce is low.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this threat bulletin.

Solutions for this threat 

openSUSE Leap 15.1: new opencv packages.
New packages are available:
  openSUSE Leap 15.1: opencv 3.3.1-lp151.6.3.1

SUSE LE 15: new opencv packages.
New packages are available:
  SUSE LE 15 RTM: opencv 3.3.1-6.6.1
  SUSE LE 15 SP1: opencv 3.3.1-6.6.1

SUSE LE 15 SP1-2: new opencv packages.
New packages are available:
  SUSE LE 15 SP2: opencv 3.3.1-6.6.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computers vulnerabilities watch. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.