The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of OpenLDAP: assertion error via Certificate List Syntax

Synthesis of the vulnerability 

An attacker can force an assertion error via Certificate List Syntax of OpenLDAP, in order to trigger a denial of service.
Impacted software: Mac OS X, Debian, OpenLDAP, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this computer vulnerability: 2/4.
Creation date: 17/11/2020.
Références of this announce: CVE-2020-25709, DLA-2481-1, DSA-4792-1, HT212147, openSUSE-SU-2021:0102-1, openSUSE-SU-2021:0107-1, SUSE-SU-2021:0128-1, SUSE-SU-2021:0129-1, SUSE-SU-2021:0142-1, USN-4634-1, USN-4634-2, VIGILANCE-VUL-33910.

Description of the vulnerability 

An attacker can force an assertion error via Certificate List Syntax of OpenLDAP, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security threat impacts software or systems such as Mac OS X, Debian, OpenLDAP, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer weakness note is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this computer threat alert.

Solutions for this threat 

OpenLDAP: patch for Certificate List Syntax.
A patch is indicated in information sources.

Apple macOS: version 10.14.6 Security Update 2021-001.
The version 10.14.6 Security Update 2021-001 is fixed:
  https://support.apple.com/

Apple macOS: version 10.15.7 Security Update 2021-001.
The version 10.15.7 Security Update 2021-001 is fixed:
  https://support.apple.com/

Apple macOS: version 11.2.
The version 11.2 is fixed:
  https://support.apple.com/

Debian 10: new openldap packages.
New packages are available:
  Debian 10: openldap 2.4.47+dfsg-3+deb10u4

Debian 9: new openldap packages.
New packages are available:
  Debian 9: openldap 2.4.44+dfsg-5+deb9u6

openSUSE Leap 15.1: new openldap2 packages.
New packages are available:
  openSUSE Leap 15.1: openldap2 2.4.46-lp151.10.24.1

openSUSE Leap 15.2: new openldap2 packages.
New packages are available:
  openSUSE Leap 15.2: openldap2 2.4.46-lp152.14.15.1

SUSE LE 12 SP2-5: new openldap2 packages.
New packages are available:
  SUSE LE 12 SP2: compat-libldap 2_3-0-2.3.37-18.24.26.1
  SUSE LE 12 SP3: compat-libldap 2_3-0-2.3.37-18.24.26.1
  SUSE LE 12 SP4: compat-libldap 2_3-0-2.3.37-18.24.26.1
  SUSE LE 12 SP5: compat-libldap 2_3-0-2.3.37-18.24.26.1

SUSE LE 12 SP5: new openldap2 packages.
New packages are available:
  SUSE LE 12 SP5: openldap2 2.4.41-18.80.1

SUSE LE 15 SP2: new openldap2 packages.
New packages are available:
  SUSE LE 15 SP2: openldap2 2.4.46-9.45.1

Ubuntu: new slapd packages.
New packages are available:
  Ubuntu 20.10: slapd 2.4.53+dfsg-1ubuntu1.2
  Ubuntu 20.04 LTS: slapd 2.4.49+dfsg-2ubuntu1.5
  Ubuntu 18.04 LTS: slapd 2.4.45+dfsg-1ubuntu1.8
  Ubuntu 16.04 LTS: slapd 2.4.42+dfsg-2ubuntu3.11
  Ubuntu 14.04 ESM: slapd 2.4.31-1+nmu2ubuntu8.5+esm4
  Ubuntu 12.04 ESM: slapd 2.4.28-1.1ubuntu4.12
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an application vulnerability bulletin. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.