The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.

cybersecurity vulnerability CVE-2019-13057

OpenLDAP: privilege escalation via rootDN

Synthesis of the vulnerability

An attacker can bypass restrictions via rootDN of OpenLDAP, in order to escalate his privileges.
Severity of this announce: 1/4.
Creation date: 29/07/2019.
Références of this computer vulnerability: 9038, CVE-2019-13057, DLA-1891-1, openSUSE-SU-2019:2157-1, openSUSE-SU-2019:2176-1, SUSE-SU-2019:2390-1, SUSE-SU-2019:2395-1, USN-4078-1, USN-4078-2, VIGILANCE-VUL-29899.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

An attacker can bypass restrictions via rootDN of OpenLDAP, in order to escalate his privileges.
Full Vigil@nce bulletin... (Free trial)

This vulnerability impacts software or systems such as Debian, OpenLDAP, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this security announce is low.

The trust level is of type confirmed by the editor, with an origin of privileged account.

An attacker with a expert ability can exploit this computer vulnerability note.

Solutions for this threat

OpenLDAP: version 2.4.48.
The version 2.4.48 is fixed:
  http://www.openldap.org/software/download/
  ftp://ftp.openldap.org/pub/OpenLDAP/MIRRORS

Debian 8: new openldap packages.
New packages are available:
  Debian 8: openldap 2.4.40+dfsg-1+deb8u5

openSUSE Leap 15.1: new openldap2 packages.
New packages are available:
  openSUSE Leap 15.1: openldap2 2.4.46-lp151.10.3.1
  openSUSE Leap 15.0: openldap2 2.4.46-lp150.13.1

SUSE LE 12 SP4: new openldap2 packages.
New packages are available:
  SUSE LE 12 SP4: openldap2 2.4.41-18.63.1

SUSE LE 15: new openldap2 packages.
New packages are available:
  SUSE LE 15 RTM: openldap2 2.4.46-9.19.2
  SUSE LE 15 SP1: openldap2 2.4.46-9.19.2

Ubuntu: new slapd packages.
New packages are available:
  Ubuntu 19.04: slapd 2.4.47+dfsg-3ubuntu2.1
  Ubuntu 18.04 LTS: slapd 2.4.45+dfsg-1ubuntu1.3
  Ubuntu 16.04 LTS: slapd 2.4.42+dfsg-2ubuntu3.6
  Ubuntu 14.04 ESM: slapd 2.4.31-1+nmu2ubuntu8.5+esm1
  Ubuntu 12.04 ESM: slapd 2.4.28-1.1ubuntu4.9

Wind River Linux: version 10.18.44.12.
The version 10.18.44.12 is fixed:
  https://support2.windriver.com/
Full Vigil@nce bulletin... (Free trial)

Computer vulnerabilities tracking service

Vigil@nce provides a computers vulnerabilities alert. Each administrator can customize the list of products for which he wants to receive vulnerability alerts. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system. The technology watch team tracks security threats targeting the computer system.