The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of OpenSSH: three vulnerabilities

Synthesis of the vulnerability 

An authenticated attacker can use several vulnerabilities of OpenSSH.
Impacted products: Blue Coat CAS, DCFM Enterprise, FabricOS, Brocade Network Advisor, Brocade vTM, Debian, VNX Operating Environment, VNX Series, BIG-IP Hardware, TMOS, Fedora, FreeBSD, AIX, Juniper EX-Series, Juniper J-Series, Junos OS, Junos Space, NSM Central Manager, NSMXpress, SRX-Series, McAfee Email Gateway, OpenBSD, OpenSSH, pfSense, RHEL, SUSE Linux Enterprise Desktop, SLES.
Severity of this bulletin: 2/4.
Number of vulnerabilities in this bulletin: 3.
Creation date: 12/08/2015.
Revisions dates: 03/09/2015, 27/01/2017.
Références of this threat: BFS-SA-2015-002, BSA-2015-009, BSA-2019-764, BSA-2019-766, CERTFR-2017-AVI-012, CERTFR-2017-AVI-022, CERTFR-2019-AVI-325, CVE-2015-6563, CVE-2015-6564, CVE-2015-6565, DLA-1500-1, DLA-1500-2, DSA-2019-197, FEDORA-2015-13520, FreeBSD-SA-15:22.openssh, JSA10774, JSA10840, JSA10940, K17263, RHSA-2015:2088-06, RHSA-2016:0741-01, SA104, SB10177, SB10178, SOL17263, SUSE-SU-2015:1581-1, SYMSA1337, VIGILANCE-VUL-17643.

Description of the vulnerability 

Several vulnerabilities were announced in OpenSSH.

A local attacker can write a message (or ANSI sequences) on the tty of other users, because the tty is world-writable. It is also possible to use the TIOCSTI ioctl, in order to inject shell commands. [severity:2/4; CVE-2015-6565]

On OpenSSH Portable, a local attacker can use PAM and compromise the pre-authentication process, in order to impersonate other users. [severity:2/4; BFS-SA-2015-002, CVE-2015-6563]

On OpenSSH Portable, an attacker can compromise the pre-authentication process and force the usage of a freed memory area in PAM support, in order to trigger a denial of service, and possibly to run code. [severity:2/4; BFS-SA-2015-002, CVE-2015-6564]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security vulnerability impacts software or systems such as Blue Coat CAS, DCFM Enterprise, FabricOS, Brocade Network Advisor, Brocade vTM, Debian, VNX Operating Environment, VNX Series, BIG-IP Hardware, TMOS, Fedora, FreeBSD, AIX, Juniper EX-Series, Juniper J-Series, Junos OS, Junos Space, NSM Central Manager, NSMXpress, SRX-Series, McAfee Email Gateway, OpenBSD, OpenSSH, pfSense, RHEL, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this computer weakness bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of user account.

This bulletin is about 3 vulnerabilities.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this security note.

Solutions for this threat 

OpenSSH: version 7.0.
The version 7.0 is fixed:
  http://www.openssh.com/

AIX: patch for OpenSSH.
A patch is available:
  ftp://aix.software.ibm.com/aix/efixes/security/openssh_fix6.tar

Blue Coat Content Analysis System: fixed versions for OpenSSH.
Fixed versions are indicated in information sources.

Blue Coat Content Analysis System: version 1.3.6.1 for OpenSSH.
The version 1.3.6.1 fixes CVE-2014-2532/CVE-2014-2653 only.

Brocade Fabric OS: versions 7.4.2, v7.4.1d and v8.1.0.
Versions 7.4.2, v7.4.1d and v8.1.0 are fixed:
  https://www.broadcom.com/

Brocade: fixed versions for Java, OpenSSL, OpenSSH, BIND.
Fixed versions are indicated in information sources.

Debian 8: new openssh packages.
New packages are available:
  Debian 8: openssh 1:6.7p1-5+deb8u7

Dell EMC VNXe: version MR4 Service Pack 5.
The version MR4 Service Pack 5 is fixed:
  https://www.dell.com/support/

F5 BIG-IP: fixed versions for OpenSSH.
Fixed versions are indicated in information sources.

Fedora 22: new openssh packages.
New packages are available:
  Fedora 22: openssh 6.9p1-5.fc22

FreeBSD: patch for OpenSSH.
A patch is available:
  https://security.FreeBSD.org/patches/SA-15:22/openssh.patch

ITeFix Copssh: version 5.3.0.
The version 5.3.0 is fixed:
  https://www.itefix.net/software

Juniper NSM Appliance: patch for Upgrade Package v3.
A patch is available:
  http://www.juniper.net/support/downloads/?p=nsm#sw

Junos OS: fixed versions for OpenSSH.
Fixed versions are indicated in information sources.

Junos Space Security Director and Log Collector: version 17.2R1.
The version 17.2R1 is fixed.

McAfee Email Gateway: version 7.6.405h1165239.
The version 7.6.405h1165239 is fixed:
  http://www.mcafee.com/us/downloads/downloads.aspx

OpenBSD: patch for sshd TTY world-writable.
A patch is available:
  http://ftp.openbsd.org/pub/OpenBSD/patches/5.7/common/014_sshd.patch.sig

pfSense: version 2.2.5.
The version 2.2.5 is fixed:
  https://pfsense.org/download/

RHEL 6: new openssh packages.
New packages are available:
  RHEL 6: openssh 5.3p1-117.el6

RHEL 7: new openssh packages.
New packages are available:
  RHEL 7: openssh 6.6.1p1-22.el7

SUSE LE 11 SP3: new openssh packages.
New packages are available:
  SUSE LE 11 SP3: openssh 6.2p2-0.21.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides system vulnerability alerts. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.