The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of OpenSSL 1.0.2: read-write access via SSLv2 Rollback Protection Bypass

Synthesis of the vulnerability 

An attacker can bypass access restrictions via SSLv2 Rollback Protection Bypass of OpenSSL 1.0.2, in order to read or alter data.
Vulnerable products: OpenSSL.
Severity of this weakness: 1/4.
Creation date: 16/02/2021.
Références of this bulletin: CERTFR-2021-AVI-124, CVE-2021-23839, VIGILANCE-VUL-34596.

Description of the vulnerability 

An attacker can bypass access restrictions via SSLv2 Rollback Protection Bypass of OpenSSL 1.0.2, in order to read or alter data.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity note impacts software or systems such as OpenSSL.

Our Vigil@nce team determined that the severity of this computer weakness announce is low.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this cybersecurity vulnerability.

Solutions for this threat 

OpenSSL: version 1.0.2y.
The version 1.0.2y is fixed:
  https://www.openssl.org/support/contracts.html#premium
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides cybersecurity patches. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.