The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of OpenSSL: information disclosure via Montgomery Squaring rsaz_512_sqr Overflow

Synthesis of the vulnerability 

An attacker can bypass access restrictions to data via Montgomery Squaring rsaz_512_sqr() Overflow of OpenSSL, in order to obtain sensitive information.
Vulnerable systems: ProxySG par Blue Coat, Broadcom Content Analysis, ProxySG by Symantec, Debian, Unisphere EMC, Rational ClearCase, Juniper EX-Series, Juniper J-Series, Junos OS, MX-Series, PTX-Series, QFX-Series, SRX-Series, OpenSSL, openSUSE Leap, Solaris, Puppet, RSA Authentication Manager, SIMATIC, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu, WinSCP, X2GoClient.
Severity of this threat: 1/4.
Creation date: 09/12/2019.
Références of this weakness: 6228808, CERTFR-2019-AVI-611, CVE-2019-1551, DSA-2020-062, DSA-2020-112, DSA-4594-1, JSA11025, openSUSE-SU-2020:0062-1, SSA:2019-354-01, SSB-439005, SUSE-SU-2020:0002-1, SUSE-SU-2020:0028-1, SUSE-SU-2020:0064-1, SUSE-SU-2020:0069-1, SUSE-SU-2020:0099-1, SUSE-SU-2020:0474-1, SYMSA1768, USN-4376-1, VIGILANCE-VUL-31088.

Description of the vulnerability 

An attacker can bypass access restrictions to data via Montgomery Squaring rsaz_512_sqr() Overflow of OpenSSL, in order to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat bulletin impacts software or systems such as ProxySG par Blue Coat, Broadcom Content Analysis, ProxySG by Symantec, Debian, Unisphere EMC, Rational ClearCase, Juniper EX-Series, Juniper J-Series, Junos OS, MX-Series, PTX-Series, QFX-Series, SRX-Series, OpenSSL, openSUSE Leap, Solaris, Puppet, RSA Authentication Manager, SIMATIC, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu, WinSCP, X2GoClient.

Our Vigil@nce team determined that the severity of this computer threat bulletin is low.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this computer threat.

Solutions for this threat 

OpenSSL: version 1.1.1e.
The version 1.1.1e is fixed:
  https://www.openssl.org/source/

OpenSSL: version 1.0.2u.
The version 1.0.2u is fixed:
  https://www.openssl.org/source/

OpenSSL: patch for Montgomery Squaring rsaz_512_sqr Overflow.
A patch is available:
  https://github.com/openssl/openssl/pull/10575/commits
  1.0.2: https://github.com/openssl/openssl/commit/f1c5eea8a
  1.1.1: https://github.com/openssl/openssl/commit/419102400

ACOS: fixed versions for OpenSSL Montgomery Squaring.
Fixed versions are indicated in information sources.

Broadcom Content Analysis, ProxySG: solution for OpenSSL.
The solution is indicated in information sources.

Debian 9: new openssl1.0 packages.
New packages are available:
  Debian 9: openssl1.0 1.0.2u-1~deb9u1

Dell EMC Unisphere for PowerMax: solution.
The solution is indicated in information sources.

IBM Rational ClearCase: patch for OpenSSL.
A patch is available:
  https://www.ibm.com/support/

Junos OS: fixed versions for OpenSSL.
Fixed versions are indicated in information sources.

openSUSE Leap 15.1: new openssl-1_1 packages.
New packages are available:
  openSUSE Leap 15.1: openssl-1_1 1.1.0i-lp151.8.6.1

Oracle Solaris: patch for third party software of April 2020 v2.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

Puppet: fixed versions for OpenSSL.
Fixed versions are indicated in information sources.

RSA Authentication Manager: version 8.4 Patch 12.
The version 8.4 Patch 12 is fixed:
  https://www.dell.com/support/

SIMATIC S7-1500 CPU 1518: workaround for GNU/Linux Vulnerabilities.
A workaround is indicated in the information source.

Slackware: new openssl packages.
New packages are available:
  Slackware 14.2: openssl 1.0.2u-*-1_slack14.2

SUSE LE 12: new openssl-1_0_0 packages.
New packages are available:
  SUSE LE 12 SP4: openssl-1_0_0 1.0.2p-3.14.1
  SUSE LE 12 SP5: openssl-1_0_0 1.0.2p-3.14.1

SUSE LE 12 SP2/3: new openssl packages.
New packages are available:
  SUSE LE 12 SP2: openssl 1.0.2j-60.60.1
  SUSE LE 12 SP3: openssl 1.0.2j-60.60.1

SUSE LE 12 SP4/5: new openssl-1_1 packages.
New packages are available:
  SUSE LE 12 SP4: openssl-1_1 1.1.1d-2.20.1
  SUSE LE 12 SP5: openssl-1_1 1.1.1d-2.20.1

SUSE LE 15: new openssl-1_0_0 packages.
New packages are available:
  SUSE LE 15 RTM: openssl-1_0_0 1.0.2p-3.25.1
  SUSE LE 15 SP1: openssl-1_0_0 1.0.2p-3.25.1

SUSE LE 15 RTM: new openssl-1_1 packages.
New packages are available:
  SUSE LE 15 RTM: openssl-1_1 1.1.0i-4.27.1

SUSE LE 15 SP1: new openssl-1_1 packages.
New packages are available:
  SUSE LE 15 SP1: openssl-1_1 1.1.0i-14.6.1

Ubuntu: new OpenSSL packages.
New packages are available:
  Ubuntu 19.10: libssl1.1 1.1.1c-1ubuntu4.1
  Ubuntu 18.04 LTS: libssl1.1 1.1.1-1ubuntu2.1~18.04.6
  Ubuntu 16.04 LTS: libssl1.0.0 1.0.2g-1ubuntu4.16

Wind River Linux: version 10.17.41.19.
The version 10.17.41.19 is fixed.

Wind River Linux: version 10.19.45.3.
The version 10.19.45.3 is fixed:
  https://support2.windriver.com/

WinSCP: version 5.17.3.
The version 5.17.3 is fixed:
  https://winscp.net/eng/download.php

X2Go Client for Windows: version 4.1.2.2-2020.02.13.
The version 4.1.2.2-2020.02.13 is fixed:
  http://wiki.x2go.org/doku.php/doc:release-notes-mswin:x2goclient-4.1.2.2
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides networks vulnerabilities bulletins. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.