The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Oracle Java, OpenJDK: vulnerabilities of October 2020

Synthesis of the vulnerability 

Several vulnerabilities were announced in Oracle products.
Vulnerable software: Debian, Avamar, NetWorker, Unisphere EMC, Fedora, AIX, IBM API Connect, IBM i, QRadar SIEM, Tivoli Storage Manager, WebSphere AS Liberty, WebSphere AS Traditional, McAfee Web Gateway, Java OpenJDK, openSUSE Leap, Java Oracle, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this announce: 2/4.
Number of vulnerabilities in this bulletin: 8.
Creation date: 21/10/2020.
Références of this computer vulnerability: 6379260, 6410564, 6410566, 6410876, 6411251, 6411255, 6415639, 6436783, 6442605, 6442991, CERTFR-2020-AVI-663, cpuoct2020, CVE-2020-14779, CVE-2020-14781, CVE-2020-14782, CVE-2020-14792, CVE-2020-14796, CVE-2020-14797, CVE-2020-14798, CVE-2020-14803, DLA-2412-1, DLA-2412-2, DSA-2020-278, DSA-2021-001, DSA-2021-063, DSA-4779-1, FEDORA-2020-421f817e5f, FEDORA-2020-81e511d0d8, FEDORA-2020-84137f197e, FEDORA-2020-a405eea76a, FEDORA-2020-d1b8d3f94a, FEDORA-2020-fdc79d8e5b, FEDORA-2020-febe36c3ac, openSUSE-SU-2020:1893-1, openSUSE-SU-2020:1984-1, openSUSE-SU-2020:1994-1, openSUSE-SU-2020:2048-1, openSUSE-SU-2020:2083-1, openSUSE-SU-2020:2170-1, RHSA-2020:4305-01, RHSA-2020:4306-01, RHSA-2020:4307-01, RHSA-2020:4316-01, RHSA-2020:4347-01, RHSA-2020:4348-01, RHSA-2020:4349-01, RHSA-2020:4350-01, RHSA-2020:4352-01, RHSA-2020:5585-01, RHSA-2020:5586-01, RHSA-2021:0530-01, RHSA-2021:0717-01, RHSA-2021:0736-01, SUSE-SU-2020:14587-1, SUSE-SU-2020:14588-1, SUSE-SU-2020:3159-1, SUSE-SU-2020:3191-1, SUSE-SU-2020:3310-1, SUSE-SU-2020:3359-1, SUSE-SU-2020:3460-1, SUSE-SU-2020:3591-1, SUSE-SU-2020:3932-1, SUSE-SU-2021:0019-1, SUSE-SU-2021:0032-1, SUSE-SU-2021:0512-1, SUSE-SU-2021:0652-1, SUSE-SU-2021:14634-1, SUSE-SU-2021:14640-1, USN-4607-1, VIGILANCE-VUL-33649.

Description of the vulnerability 

Several vulnerabilities were announced in Oracle products.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer weakness note impacts software or systems such as Debian, Avamar, NetWorker, Unisphere EMC, Fedora, AIX, IBM API Connect, IBM i, QRadar SIEM, Tivoli Storage Manager, WebSphere AS Liberty, WebSphere AS Traditional, McAfee Web Gateway, Java OpenJDK, openSUSE Leap, Java Oracle, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this security bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 8 vulnerabilities.

An attacker with a expert ability can exploit this weakness announce.

Solutions for this threat 

Oracle Java, OpenJDK: version 15.0.1.
The version 15.0.1 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  https://www.oracle.com/java/technologies/javase/15u-relnotes.html
  http://openjdk.java.net/install/

OpenJDK: version 13.0.5.
The version 13.0.5 is fixed:
  https://wiki.openjdk.java.net/display/JDKUpdates/JDK+13u
  http://openjdk.java.net/install/

Oracle Java, OpenJDK: version 11.0.9.
The version 11.0.9 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  https://www.oracle.com/java/technologies/javase/11u-relnotes.html
  http://openjdk.java.net/install/

Oracle Java, OpenJDK: version 8u271.
The version 8u271 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  http://www.oracle.com/technetwork/java/javase/documentation/8u-relnotes-2225394.html
  http://openjdk.java.net/install/

Oracle Java, OpenJDK: version 7u281.
The version 7u281 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  http://www.oracle.com/technetwork/java/javase/documentation/javase7supportreleasenotes-1601161.html
  http://openjdk.java.net/install/

AIX: patch for Java.
A patch is indicated in information sources.

Debian 10: new openjdk-11 packages.
New packages are available:
  Debian 10: openjdk-11 11.0.9+11-1~deb10u1

Debian 9: new openjdk-8 packages.
New packages are available:
  Debian 9: openjdk-8 8u275-b01-1~deb9u1

Dell EMC Avamar/NetWorker: solution for Multiple Components.
The solution is indicated in information sources.

Dell EMC Unisphere PowerMax: fixed versions for Third-Party Component.
Fixed versions are indicated in information sources.

Dell Unisphere for PowerMax: version 9.2.1.6.
The version 9.2.1.6 is fixed:
  https://www.dell.com/support/home/fr-fr

Fedora 31-32: new java-11-openjdk packages.
New packages are available:
  Fedora 31: java-11-openjdk 11.0.9.11-0.fc31
  Fedora 32: java-11-openjdk 11.0.9.11-0.fc32

Fedora 31-32: new java-1.8.0-openjdk packages.
New packages are available:
  Fedora 31: java-1.8.0-openjdk 1.8.0.272.b10-0.fc31
  Fedora 32: java-1.8.0-openjdk 1.8.0.272.b10-0.fc32

Fedora 31: new java-latest-openjdk packages.
New packages are available:
  Fedora 31: java-latest-openjdk 15.0.1.9-1.rolling.fc31

Fedora 32-33: new java-latest-openjdk packages.
New packages are available:
  Fedora 32: java-latest-openjdk 15.0.1.9-1.rolling.fc32
  Fedora 33: java-latest-openjdk 15.0.1.9-1.rolling.fc33

IBM API Connect: fixed versions for Java.
Fixed versions are indicated in information sources.

IBM API Connect: patch for Java CVE-2020-14782.
A patch is indicated in information sources.

IBM i: patch for Java.
A patch is indicated in information sources.

IBM i: solution for Java.
The solution is indicated in information sources.

IBM QRadar SIEM: patch for Java (13/04/2021).
A patch is indicated in information sources.

IBM Spectrum Protect: patch for Java.
A patch is indicated in information sources.

IBM Spectrum Protect Plus: fixed versions for Linux/Java.
Fixed versions are indicated in information sources.

McAfee Web Gateway: version 8.2.15.
The version 8.2.15 is fixed:
  https://www.mcafee.com/

McAfee Web Gateway: version 9.2.6.
The version 9.2.6 is fixed:
  https://www.mcafee.com/

openSUSE Leap 15.1: new java-1_8_0-openjdk packages.
New packages are available:
  openSUSE Leap 15.1: java-1_8_0-openjdk 1.8.0.275-lp151.2.18.1

openSUSE Leap 15.2: new java-1_8_0-openj9 packages.
New packages are available:
  openSUSE Leap 15.2: java-1_8_0-openj9 1.8.0.272-lp152.3.3.1

openSUSE Leap 15.2: new java-1_8_0-openjdk packages.
New packages are available:
  openSUSE Leap 15.2: java-1_8_0-openjdk 1.8.0.275-lp152.2.6.2

openSUSE Leap 15: new java-11-openjdk packages.
New packages are available:
  openSUSE Leap 15.1: java-11-openjdk 11.0.9.0-lp151.3.22.1
  openSUSE Leap 15.2: java-11-openjdk 11.0.9.0-lp152.2.6.2

RHEL 7.9: new java-11-openjdk packages.
New packages are available:
  RHEL 7.9: java-11-openjdk 11.0.9.11-0.el7_9

RHEL 7: new java-1.7.1-ibm packages.
New packages are available:
  RHEL 7.0-7.9: java-1.7.1-ibm 1.7.1.4.75-1jpp.1.el7

RHEL 7: new java-1.8.0-ibm packages (04/03/2021).
New packages are available:
  RHEL 7.0-7.9: java-1.8.0-ibm 1.8.0.6.25-1jpp.1.el7

RHEL 7: new java-1.8.0-ibm packages (16/12/2020).
New packages are available:
  RHEL 7.0-7.9: java-1.8.0-ibm 1.8.0.6.20-1jpp.1.el7

RHEL 8.0: new java-11-openjdk packages.
New packages are available:
  RHEL 8.0: java-11-openjdk 11.0.9.11-0.el8_0

RHEL 8.1: new java-11-openjdk packages.
New packages are available:
  RHEL 8.1: java-11-openjdk 11.0.9.11-0.el8_1

RHEL 8.2: new java-11-openjdk packages.
New packages are available:
  RHEL 8.2: java-11-openjdk 11.0.9.11-0.el8_2

RHEL 8.3: new java-1.8.0-ibm packages (04/03/2021).
New packages are available:
  RHEL 8.3: java-1.8.0-ibm 1.8.0.6.25-2.el8_3

RHEL 8.3: new java-1.8.0-ibm packages (16/02/2021).
New packages are available:
  RHEL 8.3: java-1.8.0-ibm 1.8.0.6.20-1.el8_3

RHEL: new java-1.8.0-openjdk packages.
New packages are available:
  RHEL 6.10: java-1.8.0-openjdk 1.8.0.272.b10-0.el6_10
  RHEL 7.9: java-1.8.0-openjdk 1.8.0.272.b10-1.el7_9
  RHEL 8.0: java-1.8.0-openjdk 1.8.0.272.b10-0.el8_0
  RHEL 8.1: java-1.8.0-openjdk 1.8.0.272.b10-0.el8_1
  RHEL 8.2: java-1.8.0-openjdk 1.8.0.272.b10-1.el8_2

SUSE LE 11 SP3: new java-1_7_0-ibm packages (22/12/2020).
New packages are available:
  SUSE LE 11 SP3: java-1_7_0-ibm 1.7.0_sr10.75-65.57.1

SUSE LE 11 SP3: new java-1_7_0-ibm packages (24/02/2021).
New packages are available:
  SUSE LE 11 SP3: java-1_7_0-ibm 1.7.0_sr10.80-65.60.1

SUSE LE 11 SP4: new java-1_7_1-ibm packages (19/02/2021).
New packages are available:
  SUSE LE 11 SP4: java-1_7_1-ibm alsa-1.7.1_sr4.80-26.65.1

SUSE LE 11 SP4: new java-1_7_1-ibm packages (22/12/2020).
New packages are available:
  SUSE LE 11 SP4: java-1_7_1-ibm 1.7.1_sr4.75-26.62.1

SUSE LE 12: new java-1_8_0-openjdk packages.
New packages are available:
  SUSE LE 12 SP2: java-1_8_0-openjdk 1.8.0.272-27.48.1
  SUSE LE 12 SP3: java-1_8_0-openjdk 1.8.0.272-27.48.1
  SUSE LE 12 SP4: java-1_8_0-openjdk 1.8.0.272-27.48.1
  SUSE LE 12 SP5: java-1_8_0-openjdk 1.8.0.272-27.48.1

SUSE LE 12 SP2-5: new java-1_7_0-openjdk packages.
New packages are available:
  SUSE LE 12 SP2: java-1_7_0-openjdk 1.7.0.281-43.44.2
  SUSE LE 12 SP3: java-1_7_0-openjdk 1.7.0.281-43.44.2
  SUSE LE 12 SP4: java-1_7_0-openjdk 1.7.0.281-43.44.2
  SUSE LE 12 SP5: java-1_7_0-openjdk 1.7.0.281-43.44.2

SUSE LE 12 SP2-5: new java-1_7_1-ibm packages (05/01/2021).
New packages are available:
  SUSE LE 12 SP2: java-1_7_1-ibm 1.7.1_sr4.75-38.59.1
  SUSE LE 12 SP3: java-1_7_1-ibm 1.7.1_sr4.75-38.59.1
  SUSE LE 12 SP4: java-1_7_1-ibm 1.7.1_sr4.75-38.59.1
  SUSE LE 12 SP5: java-1_7_1-ibm 1.7.1_sr4.75-38.59.1

SUSE LE 12 SP2-5: new java-1_7_1-ibm packages (18/02/2021).
New packages are available:
  SUSE LE 12 SP2: java-1_7_1-ibm 1.7.1_sr4.80-38.62.1
  SUSE LE 12 SP3: java-1_7_1-ibm 1.7.1_sr4.80-38.62.1
  SUSE LE 12 SP4: java-1_7_1-ibm 1.7.1_sr4.80-38.62.1
  SUSE LE 12 SP5: java-1_7_1-ibm 1.7.1_sr4.80-38.62.1

SUSE LE 12 SP2-5: new java-1_8_0-ibm packages (01/03/2021).
New packages are available:
  SUSE LE 12 SP2: java-1_8_0-ibm 1.8.0_sr6.25-30.81.1
  SUSE LE 12 SP3: java-1_8_0-ibm 1.8.0_sr6.25-30.81.1
  SUSE LE 12 SP4: java-1_8_0-ibm 1.8.0_sr6.25-30.81.1
  SUSE LE 12 SP5: java-1_8_0-ibm 1.8.0_sr6.25-30.81.1

SUSE LE 12 SP2-5: new java-1_8_0-ibm packages (06/01/2021).
New packages are available:
  SUSE LE 12 SP2: java-1_8_0-ibm 1.8.0_sr6.20-30.78.1
  SUSE LE 12 SP3: java-1_8_0-ibm 1.8.0_sr6.20-30.78.1
  SUSE LE 12 SP4: java-1_8_0-ibm 1.8.0_sr6.20-30.78.1
  SUSE LE 12 SP5: java-1_8_0-ibm 1.8.0_sr6.20-30.78.1

SUSE LE 12 SP5: new java-11-openjdk packages.
New packages are available:
  SUSE LE 12 SP5: java-11-openjdk 11.0.9.0-3.15.1

SUSE LE 15 RTM-SP3: new java-1_8_0-ibm packages.
New packages are available:
  SUSE LE 15 RTM: java-1_8_0-ibm 1.8.0_sr6.20-3.47.1
  SUSE LE 15 SP1: java-1_8_0-ibm 1.8.0_sr6.20-3.47.1
  SUSE LE 15 SP2: java-1_8_0-ibm 1.8.0_sr6.20-3.47.1
  SUSE LE 15 SP3: java-1_8_0-ibm 1.8.0_sr6.20-3.47.1

SUSE LE 15 RTM-SP3: new java-1_8_0-openjdk packages.
New packages are available:
  SUSE LE 15 RTM: java-1_8_0-openjdk 1.8.0.275-3.45.1
  SUSE LE 15 SP1: java-1_8_0-openjdk 1.8.0.275-3.45.1
  SUSE LE 15 SP2: java-1_8_0-openjdk 1.8.0.275-3.45.1
  SUSE LE 15 SP3: java-1_8_0-openjdk 1.8.0.275-3.45.1

SUSE LE 15 SP1-2: new java-11-openjdk packages.
New packages are available:
  SUSE LE 15 SP1: java-11-openjdk 11.0.9.0-3.48.1
  SUSE LE 15 SP2: java-11-openjdk 11.0.9.0-3.48.1

Ubuntu: new openjdk packages.
New packages are available:
  Ubuntu 20.10: openjdk-11 11.0.9.1+1-0ubuntu1~20.10, openjdk-8 8u275-b01-0ubuntu1~20.10
  Ubuntu 20.04 LTS: openjdk-11 11.0.9.1+1-0ubuntu1~20.04, openjdk-8 8u275-b01-0ubuntu1~20.04
  Ubuntu 18.04 LTS: openjdk-11 11.0.9.1+1-0ubuntu1~18.04, openjdk-8 8u275-b01-0ubuntu1~18.04
  Ubuntu 16.04 LTS: openjdk-8 8u275-b01-0ubuntu1~16.04

WebSphere AS: patch for Java (08/12/2020).
A patch is indicated in information sources.

WebSphere AS: patch for Java (16/02/2021).
A patch is indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides applications vulnerabilities analysis. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.