The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Oracle Java: vulnerabilities of October 2019

Synthesis of the vulnerability 

Several vulnerabilities were announced in Oracle products.
Impacted systems: Debian, Avamar, NetWorker, Unisphere EMC, Fedora, AIX, IBM API Connect, Db2 UDB, IBM i, IRAD, Rational ClearCase, SPSS Statistics, Tivoli Storage Manager, Tivoli System Automation, WebSphere AS Liberty, WebSphere AS Traditional, WebSphere MQ, ePO, McAfee Web Gateway, SnapManager, Java OpenJDK, openSUSE Leap, Java Oracle, RHEL, RSA Authentication Manager, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 3/4.
Number of vulnerabilities in this bulletin: 18.
Creation date: 16/10/2019.
Références of this alert: 1126887, 1288366, 3013353, 3260187, 3511029, 4790613, 5695563, 5695611, 5695629, 5695653, 5695665, 5695851, 6116194, 6210349, 6221706, 6248711, 6250817, 6256634, 6330711, CERTFR-2019-AVI-508, cpuoct2019, CVE-2019-2933, CVE-2019-2945, CVE-2019-2949, CVE-2019-2958, CVE-2019-2962, CVE-2019-2964, CVE-2019-2973, CVE-2019-2975, CVE-2019-2977, CVE-2019-2978, CVE-2019-2981, CVE-2019-2983, CVE-2019-2987, CVE-2019-2988, CVE-2019-2989, CVE-2019-2992, CVE-2019-2996, CVE-2019-2999, DLA-2023-1, DSA-2019-168, DSA-2019-169, DSA-2019-186, DSA-2019-201, DSA-2020-003, DSA-2020-105, DSA-2020-198, DSA-4546-1, DSA-4548-1, FEDORA-2019-119312dbfc, FEDORA-2019-4bafcdb85f, FEDORA-2019-a87aba290f, FEDORA-2019-ba59b4b9f1, FEDORA-2019-c170ad0c6b, FEDORA-2019-d03db48dca, FEDORA-2019-d81be00640, FEDORA-2019-e8695f5e6c, FEDORA-2019-e87dd3ca51, FEDORA-2019-f36ac0db92, FG-VD-19-091, NTAP-20191017-0001, openSUSE-SU-2019:2557-1, openSUSE-SU-2019:2565-1, openSUSE-SU-2019:2687-1, RHSA-2019:3127-01, RHSA-2019:3128-01, RHSA-2019:3134-01, RHSA-2019:3135-01, RHSA-2019:3136-01, RHSA-2019:3157-01, RHSA-2019:3158-01, RHSA-2019:4109-01, RHSA-2019:4110-01, RHSA-2019:4113-01, RHSA-2019:4115-01, RHSA-2020:0046-01, RHSA-2020:2237-01, RHSA-2020:2239-01, RHSA-2020:2241-01, SB10315, SUSE-SU-2019:2998-1, SUSE-SU-2019:3083-1, SUSE-SU-2019:3084-1, SUSE-SU-2019:3238-1, SUSE-SU-2020:0001-1, SUSE-SU-2020:0024-1, SUSE-SU-2020:0051-1, SUSE-SU-2020:14263-1, SUSE-SU-2020:14265-1, SUSE-SU-2020:1684-1, SUSE-SU-2020:1685-1, USN-4223-1, VIGILANCE-VUL-30635.

Description of the vulnerability 

Several vulnerabilities were announced in Oracle products.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness bulletin impacts software or systems such as Debian, Avamar, NetWorker, Unisphere EMC, Fedora, AIX, IBM API Connect, Db2 UDB, IBM i, IRAD, Rational ClearCase, SPSS Statistics, Tivoli Storage Manager, Tivoli System Automation, WebSphere AS Liberty, WebSphere AS Traditional, WebSphere MQ, ePO, McAfee Web Gateway, SnapManager, Java OpenJDK, openSUSE Leap, Java Oracle, RHEL, RSA Authentication Manager, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer weakness is important.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 18 vulnerabilities.

An attacker with a expert ability can exploit this vulnerability announce.

Solutions for this threat 

Oracle Java: version 13.0.1.
The version 13.0.1 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  https://www.oracle.com/technetwork/java/javase/13u-relnotes-5461742.html

Oracle Java: version 11.0.5.
The version 11.0.5 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  https://www.oracle.com/technetwork/java/javase/11u-relnotes-5093844.html

Oracle Java: version 8u231.
The version 8u231 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  http://www.oracle.com/technetwork/java/javase/documentation/8u-relnotes-2225394.html

Oracle Java: version 7u241.
The version 7u241 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  http://www.oracle.com/technetwork/java/javase/documentation/javase7supportreleasenotes-1601161.html

OpenJDK: versions 7u241, 8u232, 11.0.5 and 13.0.1.
Versions 7u241, 8u232, 11.0.5 and 13.0.1 are fixed:
  https://openjdk.java.net/

AIX: patch for Java.
A patch is indicated in information sources.

Debian 10: new openjdk-11 packages.
New packages are available:
  Debian 10: openjdk-11 11_11.0.5+10-1~deb10u1

Debian 8: new openjdk-7 packages.
New packages are available:
  Debian 8: openjdk-7 7u241-2.6.20-1~deb8u1

Debian 9: new openjdk-8 packages.
New packages are available:
  Debian 9: openjdk-8 8u232-b09-1~deb9u1

Dell EMC Avamar/NetWorker: fixed versions for Multiple Components.
Fixed versions are indicated in information sources.

Dell EMC Avamar, NetWorker: solution.
The solution is indicated in information sources.

Dell EMC NetWorker Runtime Environment: version 8.0.3.
The version 8.0.3 is fixed:
  https://www.dell.com/support/

Dell EMC NetWorker Virtual Edition: patch for Java.
A patch is indicated in information sources.

EMC Unisphere for PowerMax: versions 9.0.2.16 and 9.1.0.9.
Versions 9.0.2.16 and 9.1.0.9 are fixed:
  https://www.dell.com/support/home/us/en/19/product-support/product/unisphere-powermax/drivers

Fedora: new java-11-openjdk packages.
New packages are available:
  Fedora 29: java-11-openjdk 11.0.5.10-0.fc29
  Fedora 30: java-11-openjdk 11.0.5.10-0.fc30

Fedora: new java-1.8.0-openjdk-aarch32 packages.
New packages are available:
  Fedora 29: java-1.8.0-openjdk-aarch32 1.8.0.232.b09-1.fc29
  Fedora 30: java-1.8.0-openjdk-aarch32 1.8.0.232.b09-1.fc30
  Fedora 31: java-1.8.0-openjdk-aarch32 1.8.0.232.b09-1.fc31

Fedora: new java-1.8.0-openjdk packages.
New packages are available:
  Fedora 29: java-1.8.0-openjdk 1.8.0.232.b09-0.fc29
  Fedora 30: java-1.8.0-openjdk 1.8.0.232.b09-0.fc30

Fedora: new java-latest-openjdk packages.
New packages are available:
  Fedora 29: java-latest-openjdk 13.0.1.9-2.rolling.fc29
  Fedora 30: java-latest-openjdk 13.0.1.9-2.rolling.fc30
  Fedora 31: java-latest-openjdk 13.0.1.9-2.rolling.fc31

IBM API Connect: patch for Java.
A patch is indicated in information sources.

IBM Db2: patch for Java.
A patch is indicated in information sources.

IBM i: patch for IBM Java SDK.
A patch is indicated in information sources.

IBM i: patch for Java CVE-2019-2949.
A patch is indicated in information sources.

IBM MQ: fixed versions for Java.
The following versions are fixed:
  IBM MQ 9.1 LTS: 9.1.0.5
  IBM MQ CD: 9.1.5
  IBM MQ 9.0 LTS: 9.0.0.9
  IBM MQ 8.0: 8.0.0.14

IBM Rational Application Developer for WebSphere: patch for Java.
A patch is indicated in information sources.

IBM Rational ClearCase: patch for Java.
A patch is indicated in information sources.

IBM Spectrum Protect: fixed versions.
Fixed versions are indicated in information sources.

IBM Spectrum Protect Server: patch for Java.
A patch is available:
  https://www.ibm.com/support/pages/node/6028024
  http://www.ibm.com/support/pages/node/6229034

IBM Spectrum Protect Snapshot for VMware: patch for Java.
A patch is indicated in information sources.

IBM SPSS Statistics: fixed versions for Java.
The following versions are fixed:
  SPSS Statistics 26.0: 26 FP001-IF001
  SPSS Statistics 25.0: 25 FP002-IF007
  SPSS Statistics 24.0: 24 FP002-IF020
  SPSS Statistics 23.0: 23 FP003-IF018

IBM Tivoli System Automation Application Manager: patch for Java.
A patch is indicated in information sources.

IBM Tivoli System Automation Application Manager: solution for Java.
The solution is indicated in information sources.

IBM Tivoli System Automation for Multiplatforms: patch for Java (20/07/2020).
A patch is indicated in information sources.

IBM Tivoli System Automation for Multiplatforms: patch for Java (28/02/2020).
A patch is indicated in information sources.

McAfee ePolicy Orchestrator: patch for Java.
A patch is available:
  For ePO 5.9.1: EPO-HF87900_591.zip (https://www.mcafee.com/us/downloads/downloads.aspx)

McAfee ePolicy Orchestrator: version 5.10.0 Update 7.
The version 5.10.0 Update 7 is fixed:
  https://www.mcafee.com/us/downloads/downloads.aspx

McAfee Web Gateway: version 7.8.2.16.
The version 7.8.2.16 is fixed:
  https://www.mcafee.com/enterprise/en-us/downloads/my-products.html

McAfee Web Gateway: version 9.0.
The version 9.0 is fixed:
  https://www.mcafee.com/enterprise/en-us/downloads/my-products.html

openSUSE Leap 15.1: new java-1_8_0-openjdk packages.
New packages are available:
  openSUSE Leap 15.1: java-1_8_0-openjdk 1.8.0.232-lp151.2.6.1

openSUSE Leap 15: new java-11-openjdk packages.
New packages are available:
  openSUSE Leap 15.0: java-11-openjdk 11.0.5.0-lp150.2.28.1
  openSUSE Leap 15.1: java-11-openjdk 11.0.5.0-lp151.3.9.2

RHEL 6.10: new java-1.8.0-ibm packages.
New packages are available:
  RHEL 6.10: java-1.8.0-ibm 1.8.0.6.0-1jpp.1.el6_10

RHEL 6.10: new java-1.8.0-openjdk packages.
New packages are available:
  RHEL 6: java-1.8.0-openjdk 1.8.0.232.b09-1.el6_10

RHEL 6, 7: new java-1.8.0-ibm packages.
New packages are available:
  RHEL 6.10: java-1.8.0-ibm 1.8.0.6.10-1jpp.1.el6_10
  RHEL 7.0-7.8: java-1.8.0-ibm 1.8.0.6.10-1jpp.1.el7

RHEL 7.7: new java-11-openjdk packages.
New packages are available:
  RHEL 7: java-11-openjdk 11.0.5.10-0.el7_7

RHEL 7.7: new java-1.8.0-openjdk packages.
New packages are available:
  RHEL 7: java-1.8.0-openjdk 1.8.0.232.b09-0.el7_7

RHEL 7: new java-1.8.0-ibm packages.
New packages are available:
  RHEL 7.0-7.7: java-1.8.0-ibm 1.8.0.6.0-1jpp.1.el7

RHEL 8.0: new java-11-openjdk packages.
New packages are available:
  RHEL 8: java-11-openjdk 11.0.5.10-0.el8_0

RHEL 8.0: new java-1.8.0-openjdk packages.
New packages are available:
  RHEL 8: java-1.8.0-openjdk 1.8.0.232.b09-0.el8_0

RHEL 8.1: new java-1.8.0-ibm packages.
New packages are available:
  RHEL 8.1: java-1.8.0-ibm 1.8.0.6.0-3.el8_1

RHEL 8.2: new java-1.8.0-ibm packages (21/05/2020).
New packages are available:
  RHEL 8.2: java-1.8.0-ibm 1.8.0.6.10-1.el8_2

RHEL: new java-1.7.0-openjdk packages.
New packages are available:
  RHEL 6: java-1.7.0-openjdk 1.7.0.241-2.6.20.0.el6_10
  RHEL 7: java-1.7.0-openjdk 1.7.0.241-2.6.20.0.el7_7

RHEL: new java-1.7.1-ibm packages.
New packages are available:
  RHEL 6.10: java-1.7.1-ibm 1.7.1.4.55-1jpp.1.el6_10
  RHEL 7.0-7.7: java-1.7.1-ibm 1.7.1.4.55-1jpp.1.el7

RSA Authentication Manager: version 8.4 P8.
The version 8.4 P8 is fixed:
  https://www.dell.com/

SnapManager: solution for Java.
The solution is indicated in information sources.

SUSE LE 11 SP3: new java-1_7_0-ibm packages.
New packages are available:
  SUSE LE 11 SP3: java-1_7_0-ibm 1.7.0_sr10.55-65.45.1

SUSE LE 11 SP4: new java-1_7_1-ibm packages.
New packages are available:
  SUSE LE 11 SP4: java-1_7_1-ibm 1.7.1_sr4.55-26.47.1

SUSE LE 12: new java-1_7_0-openjdk packages.
New packages are available:
  SUSE LE 12 SP1: java-1_7_0-openjdk 1.7.0.241-43.30.1
  SUSE LE 12 SP2: java-1_7_0-openjdk 1.7.0.241-43.30.1
  SUSE LE 12 SP3: java-1_7_0-openjdk 1.7.0.241-43.30.1
  SUSE LE 12 SP4: java-1_7_0-openjdk 1.7.0.241-43.30.1
  SUSE LE 12 SP5: java-1_7_0-openjdk 1.7.0.241-43.30.1

SUSE LE 12: new java-1_7_1-ibm packages.
New packages are available:
  SUSE LE 12 SP1: java-1_7_1-ibm 1.7.1_sr4.55-38.44.1
  SUSE LE 12 SP2: java-1_7_1-ibm 1.7.1_sr4.55-38.44.1
  SUSE LE 12 SP3: java-1_7_1-ibm 1.7.1_sr4.55-38.44.1
  SUSE LE 12 SP4: java-1_7_1-ibm 1.7.1_sr4.55-38.44.1
  SUSE LE 12 SP5: java-1_7_1-ibm 1.7.1_sr4.55-38.44.1

SUSE LE 12: new java-1_8_0-ibm packages (08/01/2020).
New packages are available:
  SUSE LE 12 SP1: java-1_8_0-ibm 1.8.0_sr6.0-30.60.1
  SUSE LE 12 SP2: java-1_8_0-ibm 1.8.0_sr6.0-30.60.1
  SUSE LE 12 SP3: java-1_8_0-ibm 1.8.0_sr6.0-30.60.1
  SUSE LE 12 SP4: java-1_8_0-ibm 1.8.0_sr6.0-30.60.1
  SUSE LE 12 SP5: java-1_8_0-ibm 1.8.0_sr6.0-30.60.1

SUSE LE 12: new java-1_8_0-ibm packages (19/06/2020).
New packages are available:
  SUSE LE 12 SP2: java-1_8_0-ibm 1.8.0_sr6.10-30.69.1
  SUSE LE 12 SP3: java-1_8_0-ibm 1.8.0_sr6.10-30.69.1
  SUSE LE 12 SP4: java-1_8_0-ibm 1.8.0_sr6.10-30.69.1
  SUSE LE 12 SP5: java-1_8_0-ibm 1.8.0_sr6.10-30.69.1

SUSE LE 12 SP5: new java-11-openjdk packages.
New packages are available:
  SUSE LE 12 SP5: java-11-openjdk 11.0.5.0-3.3.3

SUSE LE 15: new java-11-openjdk packages.
New packages are available:
  SUSE LE 15 RTM: java-11-openjdk 11.0.5.0-3.36.1
  SUSE LE 15 SP1: java-11-openjdk 11.0.5.0-3.36.1

SUSE LE 15: new java-1_8_0-ibm packages (02/01/2020).
New packages are available:
  SUSE LE 15 RTM: java-1_8_0-ibm 1.8.0_sr6.0-3.30.1
  SUSE LE 15 SP1: java-1_8_0-ibm 1.8.0_sr6.0-3.30.1

SUSE LE 15: new java-1_8_0-ibm packages (19/06/2020).
New packages are available:
  SUSE LE 15 RTM: java-1_8_0-ibm 1.8.0_sr6.10-3.38.1
  SUSE LE 15 SP1: java-1_8_0-ibm 1.8.0_sr6.10-3.38.1
  SUSE LE 15 SP2: java-1_8_0-ibm 1.8.0_sr6.10-3.38.1

SUSE LE 15: new java-1_8_0-openjdk packages.
New packages are available:
  SUSE LE 15 RTM: java-1_8_0-openjdk 1.8.0.232-3.27.1
  SUSE LE 15 SP1: java-1_8_0-openjdk 1.8.0.232-3.27.1

Ubuntu: new openjdk-jdk packages.
New packages are available:
  Ubuntu 19.10: openjdk-11-jdk 11.0.5+10-0ubuntu1.1
  Ubuntu 19.04: openjdk-11-jdk 11.0.5+10-0ubuntu1.1~19.04
  Ubuntu 18.04 LTS: openjdk-11-jdk 11.0.5+10-0ubuntu1.1~18.04
  Ubuntu 16.04 LTS: openjdk-8-jdk 8u232-b09-0ubuntu1~16.04.1

WebSphere AS: patch for IBM Java.
A patch is indicated in information sources.

WebSphere AS: solution for Java.
The solution is indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an application vulnerability workaround. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.