The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Oracle MySQL: vulnerabilities of January 2019

Synthesis of the vulnerability 

Several vulnerabilities were announced in Oracle products.
Vulnerable software: Debian, Fedora, MariaDB ~ precise, MySQL Community, MySQL Enterprise, openSUSE Leap, Solaris, Percona Server, XtraBackup, Puppet, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this announce: 3/4.
Number of vulnerabilities in this bulletin: 26.
Creation date: 16/01/2019.
Références of this computer vulnerability: bulletinapr2019, CERTFR-2019-AVI-025, cpujan2019, CVE-2019-2420, CVE-2019-2434, CVE-2019-2435, CVE-2019-2436, CVE-2019-2455, CVE-2019-2481, CVE-2019-2482, CVE-2019-2486, CVE-2019-2494, CVE-2019-2495, CVE-2019-2502, CVE-2019-2503, CVE-2019-2507, CVE-2019-2510, CVE-2019-2513, CVE-2019-2528, CVE-2019-2529, CVE-2019-2530, CVE-2019-2531, CVE-2019-2532, CVE-2019-2533, CVE-2019-2534, CVE-2019-2535, CVE-2019-2536, CVE-2019-2537, CVE-2019-2539, DLA-1655-1, FEDORA-2019-21b76d179e, openSUSE-SU-2019:0138-1, openSUSE-SU-2019:0327-1, openSUSE-SU-2020:0409-1, openSUSE-SU-2020:0430-1, RHSA-2019:1258-01, RHSA-2019:2327-01, RHSA-2019:2484-01, RHSA-2019:2511-01, RHSA-2019:3708-01, SSA:2019-032-01, SUSE-SU-2019:0555-1, SUSE-SU-2019:0609-1, SUSE-SU-2019:2048-1, SUSE-SU-2019:2118-1, USN-3867-1, VIGILANCE-VUL-28291.

Description of the vulnerability 

Several vulnerabilities were announced in Oracle products.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security vulnerability impacts software or systems such as Debian, Fedora, MariaDB ~ precise, MySQL Community, MySQL Enterprise, openSUSE Leap, Solaris, Percona Server, XtraBackup, Puppet, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer weakness bulletin is important.

The trust level is of type confirmed by the editor, with an origin of intranet client.

This bulletin is about 26 vulnerabilities.

An attacker with a expert ability can exploit this security note.

Solutions for this threat 

Oracle MySQL: version 8.0.14.
The version 8.0.14 is fixed:
  https://support.oracle.com/rs?type=doc&id=2487644.1
  https://www.mysql.com/fr/

Oracle MySQL: version 5.7.25.
The version 5.7.25 is fixed:
  https://support.oracle.com/rs?type=doc&id=2487644.1
  https://www.mysql.com/fr/

Oracle MySQL: version 5.6.43.
The version 5.6.43 is fixed:
  https://support.oracle.com/rs?type=doc&id=2487644.1
  https://www.mysql.com/fr/

Debian 8: new mariadb-10.0 packages.
New packages are available:
  Debian 8: mariadb-10.0 10.0.38-0+deb8u1

Fedora 28: new community-mysql packages.
New packages are available:
  Fedora 28: community-mysql 5.7.25-1.fc28

MariaDB: version 10.0.38.
The version 10.0.38 is fixed:
  https://mariadb.com/downloads/

MariaDB: version 10.1.38.
The version 10.1.38 is fixed:
  https://mariadb.com/downloads/

MariaDB: version 10.2.22.
The version 10.2.22 is fixed:
  https://mariadb.com/downloads/

MariaDB: version 10.3.13.
The version 10.3.13 is fixed:
  https://downloads.mariadb.org/mariadb/10.3.13

MariaDB: version 5.5.63.
The version 5.5.63 is fixed:
  https://mariadb.com/downloads/

openSUSE Leap 15.0: new mariadb packages.
New packages are available:
  openSUSE Leap 15.0: mariadb 10.2.22-lp150.2.9.1

openSUSE Leap 15.1: new python-mysql-connector-python packages.
New packages are available:
  openSUSE Leap 15.1: python2-mysql-connector-python 8.0.19-lp151.3.3.1, python3-mysql-connector-python 8.0.19-lp151.3.3.1

openSUSE Leap 42.3: new mysql-community-server packages.
New packages are available:
  openSUSE Leap 42.3: mysql-community-server 5.6.43-45.1

Oracle Solaris: patch for third party software of April 2019 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

Percona Server for MySQL: version 5.6.43-84.3.
The version 5.6.43-84.3 is fixed:
  https://www.percona.com/

Percona Server for MySQL: version 5.7.25-28.
The version 5.7.25-28 is fixed:
  https://www.percona.com/

Puppet Enterprise: fixed versions.
Fixed versions are indicated in information sources.

RHEL 7: new mariadb packages (06/08/2019).
New packages are available:
  RHEL 7: mariadb 5.5.64-1.el7

RHEL 7: new rh-mysql80-mysql packages.
New packages are available:
  RHEL 7: rh-mysql80-mysql 8.0.17-1.el7

RHEL 8: new mariadb-10.3 module.
The following module is updated:
  RHEL 8 Module: mariadb:10.3

RHEL 8: new mysql-8.0 module.
The following module is updated:
  RHEL 8 Module: mysql:8.0

RHEL: new mariadb102 packages.
New packages are available:
  RHEL 6: rh-mariadb102-mariadb 10.2.22-1.el6
  RHEL 7: rh-mariadb102-mariadb 10.2.22-1.el7
  RHEL 7.5: rh-mariadb102-mariadb 10.2.22-1.el7
  RHEL 7.6: rh-mariadb102-mariadb 10.2.22-1.el7

Slackware: new mariadb packages.
New packages are available:
  Slackware 14.1: mariadb 5.5.63-*-1_slack14.1
  Slackware 14.2: mariadb 10.0.38-*-1_slack14.2

SUSE LE 12 SP1/2: new mariadb packages.
New packages are available:
  SUSE LE 12 SP1: mariadb 10.0.38-29.27.3
  SUSE LE 12 SP2: mariadb 10.0.38-29.27.3

SUSE LE 12 SP4: new mariadb-100 packages.
New packages are available:
  SUSE LE 12 SP4: mariadb-100 10.0.38-2.6.2

SUSE LE 12 SP4: new mariadb packages.
New packages are available:
  SUSE LE 12 SP4: mariadb 10.2.22-3.14.1

SUSE LE 15: new mariadb packages.
New packages are available:
  SUSE LE 15 RTM: mariadb 10.2.22-3.14.1

SUSE LE 15 SP1: new python-mysql-connector-python packages.
New packages are available:
  SUSE LE 15 SP1: python2-mysql-connector-python 8.0.19-bp151.4.3.1, python3-mysql-connector-python 8.0.19-bp151.4.3.1

Ubuntu: new mysql-server-5.7 packages.
New packages are available:
  Ubuntu 18.10: mysql-server-5.7 5.7.25-0ubuntu0.18.10.2
  Ubuntu 18.04 LTS: mysql-server-5.7 5.7.25-0ubuntu0.18.04.2
  Ubuntu 16.04 LTS: mysql-server-5.7 5.7.25-0ubuntu0.16.04.2

Wind River Linux: version 10.17.41.19.
The version 10.17.41.19 is fixed.

Wind River Linux: version 10.18.44.12.
The version 10.18.44.12 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides cybersecurity bulletins. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.