The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of PHP: multiple vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of PHP.
Impacted systems: Debian, Fedora, HP-UX, openSUSE, Solaris, PHP, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 3/4.
Number of vulnerabilities in this bulletin: 3.
Creation date: 23/01/2015.
Revisions dates: 26/01/2015, 04/02/2015, 05/02/2015.
Références of this alert: 68710, 68735, 68799, bulletinjul2015, c04686230, CVE-2014-9652, CVE-2015-0231, CVE-2015-0232, DSA-3195-1, FEDORA-2015-1058, FEDORA-2015-1101, HPSBUX03337, MDVSA-2015:079, MDVSA-2015:080, openSUSE-SU-2015:0325-1, openSUSE-SU-2015:0440-1, RHSA-2015:1053-01, RHSA-2015:1066-01, RHSA-2015:1135-01, RHSA-2015:1218-01, SSA:2015-111-10, SSRT102066, SUSE-SU-2015:0365-1, SUSE-SU-2015:0424-1, SUSE-SU-2015:0436-1, SUSE-SU-2016:1638-1, USN-2501-1, VIGILANCE-VUL-16037.

Description of the vulnerability 

Several vulnerabilities were announced in PHP.

An attacker can force the usage of a freed memory area in unserialize(), in order to trigger a denial of service, and possibly to execute code. [severity:3/4; 68710, CVE-2015-0231]

An attacker can force the usage of a freed memory area in exif.c, in order to trigger a denial of service, and possibly to execute code. [severity:2/4; 68799, CVE-2015-0232]

An attacker can force Fine Free file (libmagic) to analyze a malicious Pascal file, in order to trigger a denial of service (VIGILANCE-VUL-16117). [severity:1/4; 68735, CVE-2014-9652]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security weakness impacts software or systems such as Debian, Fedora, HP-UX, openSUSE, Solaris, PHP, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat bulletin is important.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 3 vulnerabilities.

An attacker with a expert ability can exploit this threat.

Solutions for this threat 

PHP: version 5.6.5.
The version 5.6.5 is fixed:
  http://php.net/downloads

PHP: version 5.5.21.
The version 5.5.21 is fixed:
  http://php.net/downloads

PHP: version 5.4.37.
The version 5.4.37 is fixed:
  http://php.net/downloads

Debian: new php5 packages (18/03/2015).
New packages are available:
  Debian 7: php5 5.4.38-0+deb7u1

Fedora: new php packages (06/02/2015).
New packages are available:
  Fedora 20: php 5.5.21-1.fc20
  Fedora 21: php 5.6.5-1.fc21

HP-UX Apache Web Server: version 4.05.
The version 4.05 is fixed:
  http://software.hp.com/

Mandriva BS1: new php packages.
New packages are available:
  Mandriva BS1: php 5.5.23-1.mbs1

Mandriva BS2: new php packages.
New packages are available:
  Mandriva BS2: php 5.5.23-1.mbs2

openSUSE: new php5 packages (06/03/2015).
New packages are available:
  openSUSE 13.1: apache2-mod_php5 5.4.20-42.1, php5 5.4.20-42.1
  openSUSE 13.2: apache2-mod_php5 5.6.1-12.1, php5 5.6.1-12.1

openSUSE: new php5 packages (19/02/2015).
New packages are available:
  openSUSE 13.1: php5 5.4.20-38.1
  openSUSE 13.2: php5 5.6.1-8.1

RHEL 6.6: new php packages.
New packages are available:
  RHEL 6: php 5.3.3-46.el6_6

RHEL 7.1: new php packages.
New packages are available:
  RHEL 7: php 5.4.16-36.el7_1

RHEL: new php54 packages.
New packages are available:
  RHEL 6: php54 2.0-1.el6
  RHEL 7: php54 2.0-1.el7

RHEL: new php55 packages.
New packages are available:
  RHEL 6: php55 2.0-1.el6
  RHEL 7: php55 2.0-1.el7

Slackware: new php packages.
New packages are available:
  Slackware 14.0: php 5.4.40-*-1_slack14.0
  Slackware 14.1: php 5.4.40-*-1_slack14.1

Solaris: patch for Third Party (07/2015).
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 11: new php53 packages.
New packages are available:
  SUSE LE 11: apache2-mod_php53 5.3.17-0.35.2, php53 5.3.17-0.35.2

SUSE LE 11 SP2: new php53 packages (21/06/2016).
New packages are available:
  SUSE LE 11 SP2: apache2-mod_php53 5.3.17-47.1, php53 5.3.17-47.1

SUSE LE 12: new php5 packages.
New packages are available:
  SUSE LE 12: php5 5.5.14-11.3

Ubuntu: new php5 packages.
New packages are available:
  Ubuntu 14.10: php5 5.5.12+dfsg-2ubuntu4.2
  Ubuntu 14.04 LTS: php5 5.5.9+dfsg-1ubuntu4.6
  Ubuntu 12.04 LTS: php5 5.3.10-1ubuntu3.16
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides system vulnerability bulletins. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.