The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Pallets Werkzeug: privilege escalation via PIN Randomness

Synthesis of the vulnerability 

An attacker can bypass restrictions via PIN Randomness of Pallets Werkzeug, in order to escalate his privileges.
Impacted systems: openSUSE Leap, SLES.
Severity of this alert: 2/4.
Creation date: 06/09/2019.
Références of this alert: CVE-2019-14806, openSUSE-SU-2019:2118-1, openSUSE-SU-2019:2145-1, SUSE-SU-2019:2308-1, SUSE-SU-2019:2365-1, SUSE-SU-2019:2365-2, VIGILANCE-VUL-30257.

Description of the vulnerability 

An attacker can bypass restrictions via PIN Randomness of Pallets Werkzeug, in order to escalate his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat impacts software or systems such as openSUSE Leap, SLES.

Our Vigil@nce team determined that the severity of this computer threat is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this cybersecurity bulletin.

Solutions for this threat 

openSUSE Leap 15: new python-Werkzeug packages.
New packages are available:
  openSUSE Leap 15.0: python-Werkzeug 0.12.2-lp150.2.3.1
  openSUSE Leap 15.1: python-Werkzeug doc-0.14.1-lp151.2.3.1

SUSE LE 15 RTM: new python-Werkzeug packages.
New packages are available:
  SUSE LE 15 RTM: python-Werkzeug 0.12.2-3.3.1

SUSE LE 15 SP1: new python-Werkzeug packages.
New packages are available:
  SUSE LE 15 SP1: python-Werkzeug 0.14.1-6.3.1, python2-Werkzeug 0.14.1-6.3.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a system vulnerability announce. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.