The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Perl Archive-Tar: directory traversal via Symlink

Synthesis of the vulnerability 

An attacker can traverse directories via Symlink of Perl Archive::Tar, in order to create a file outside the service root path.
Impacted systems: Mac OS X, Debian, VNX Operating Environment, VNX Series, Fedora, Data ONTAP 7-Mode, OpenBSD, openSUSE Leap, Oracle DB, Solaris, Perl Module ~ not comprehensive, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 2/4.
Creation date: 08/06/2018.
Références of this alert: 125523, bulletinjan2019, cpujul2020, CVE-2018-12015, DSA-2020-030, DSA-2020-289, DSA-4226-1, FEDORA-2018-10ae521efa, FEDORA-2018-4e088b6d7c, HT209600, NTAP-20180926-0001, NTAP-20180926-0002, NTAP-20180926-0003, NTAP-20180926-0004, NTAP-20180926-0005, NTAP-20180927-0001, openSUSE-SU-2018:2010-1, openSUSE-SU-2018:2011-1, RHSA-2019:2097-01, SUSE-SU-2018:1972-1, SUSE-SU-2018:1977-1, SUSE-SU-2018:1992-1, USN-3684-1, USN-3684-2, VIGILANCE-VUL-26351.

Description of the vulnerability 

An attacker can traverse directories via Symlink of Perl Archive::Tar, in order to create a file outside the service root path.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity announce impacts software or systems such as Mac OS X, Debian, VNX Operating Environment, VNX Series, Fedora, Data ONTAP 7-Mode, OpenBSD, openSUSE Leap, Oracle DB, Solaris, Perl Module ~ not comprehensive, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat alert is medium.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this computer weakness alert.

Solutions for this threat 

Perl Archive-Tar: version 2.28.
The version 2.28 is fixed:
  https://metacpan.org/release/Archive-Tar

Perl Archive-Tar: patch for Symlink.
A patch is indicated in information sources.

Apple macOS: versions 10.12.6-2019-002, 10.13.6-2019-002 and 10.14.4.
Versions 10.12.6-2019-002, 10.13.6-2019-002 and 10.14.4 are fixed:
  https://support.apple.com/

Debian: new perl packages.
New packages are available:
  Debian 8: perl 5.20.2-3+deb8u11
  Debian 9: perl 5.24.1-3+deb9u4

Dell EMC VNXe3200: version 3.1.11.10003441.
The version 3.1.11.10003441 is fixed:
  https://www.dell.com/support/

Fedora: new perl-Archive-Tar packages.
New packages are available:
  Fedora 27: perl-Archive-Tar 2.28-1.fc27
  Fedora 28: perl-Archive-Tar 2.28-1.fc28

NetApp Data ONTAP Edge: end of life.
The end of life is indicated in information sources.

OpenBSD: patch for Perl Archive-Tar.
A patch is available:
  https://ftp.openbsd.org/pub/OpenBSD/patches/6.2/common/016_perl.patch.sig
  https://ftp.openbsd.org/pub/OpenBSD/patches/6.3/common/011_perl.patch.sig

openSUSE Leap: new perl packages.
New packages are available:
  openSUSE Leap 42.3: perl 5.18.2-15.2
  openSUSE Leap 15.0: perl 5.26.1-lp150.6.3.1

Oracle Database: CPU of July 2020.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2664876.1

Oracle Solaris: patch for third party software of January 2019 v2.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7: new perl-Archive-Tar packages.
New packages are available:
  RHEL 7: perl-Archive-Tar 1.92-3.el7

SUSE LE 11: new perl packages.
New packages are available:
  SUSE LE 11 SP3: perl 5.10.0-64.81.13.1
  SUSE LE 11 SP4: perl 5.10.0-64.81.13.1

SUSE LE 12: new perl packages.
New packages are available:
  SUSE LE 12 RTM: perl 5.18.2-12.14.1
  SUSE LE 12 SP1: perl 5.18.2-12.14.1
  SUSE LE 12 SP2: perl 5.18.2-12.14.1
  SUSE LE 12 SP3: perl 5.18.2-12.14.1

SUSE LE 15: new perl packages.
New packages are available:
  SUSE LE 15 RTM: perl 5.26.1-7.3.1

Ubuntu: new perl packages.
New packages are available:
  Ubuntu 18.04 LTS: perl 5.26.1-6ubuntu0.1
  Ubuntu 17.10: perl 5.26.0-8ubuntu1.2
  Ubuntu 16.04 LTS: perl 5.22.1-9ubuntu0.5
  Ubuntu 14.04 LTS: perl 5.18.2-2ubuntu1.6
  Ubuntu 12.04 ESM: perl 5.14.2-6ubuntu2.8

VNXe1600: fixed versions for Third-Party Component.
Fixed versions are indicated in information sources.
This bulletin fixes more than 100 vulnerabilities, but only the 100 recent vulnerabilities were associated to this bulletin.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides applications vulnerabilities alerts. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.