The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Podman: information disclosure via Varlink API / Docker-compatible REST API

Synthesis of the vulnerability 

An attacker can bypass access restrictions to data via Varlink API / Docker-compatible REST API of Podman, in order to obtain sensitive information.
Vulnerable software: Fedora, openSUSE Leap, RHEL, SLES.
Severity of this announce: 1/4.
Creation date: 02/10/2020.
Références of this computer vulnerability: CVE-2020-14370, FEDORA-2020-3a4b8fca5e, FEDORA-2020-76fcd0ba34, openSUSE-SU-2020:2039-1, openSUSE-SU-2020:2063-1, RHSA-2020:5056-01, RHSA-2021:0531-01, SUSE-SU-2020:3378-1, VIGILANCE-VUL-33469.

Description of the vulnerability 

An attacker can bypass access restrictions to data via Varlink API / Docker-compatible REST API of Podman, in order to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat impacts software or systems such as Fedora, openSUSE Leap, RHEL, SLES.

Our Vigil@nce team determined that the severity of this computer threat is low.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this cybersecurity bulletin.

Solutions for this threat 

Fedora 31: new crun packages.
New packages are available:
  Fedora 31: crun 0.15-5.fc31

Fedora 31: new podman packages.
New packages are available:
  Fedora 31: podman 2.1.1-3.fc31

Fedora 32: new crun packages.
New packages are available:
  Fedora 32: crun 0.15-5.fc32

Fedora 32: new podman packages.
New packages are available:
  Fedora 32: podman 2.1.1-7.fc32

openSUSE Leap 15.1: new podman packages.
New packages are available:
  openSUSE Leap 15.1: podman 2.1.1-lp151.3.25.1

openSUSE Leap 15.2: new podman packages.
New packages are available:
  openSUSE Leap 15.2: podman 2.1.1-lp152.4.6.1

RHEL 7.9: new podman packages.
New packages are available:
  RHEL 7.9: podman 1.6.4-26.el7_9

RHEL 8: new container-tools-rhel8 module.
The following module is updated:
  RHEL 8 Module: container-tools:rhel8

SUSE LE 15 SP1-2: new podman packages.
New packages are available:
  SUSE LE 15 SP1: podman 2.1.1-4.28.1
  SUSE LE 15 SP2: podman 2.1.1-4.28.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a network vulnerability patch. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.