The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of PostgreSQL: buffer overflow via Password Change

Synthesis of the vulnerability 

An attacker can trigger a buffer overflow via Password Change of PostgreSQL, in order to trigger a denial of service, and possibly to run code.
Impacted products: openSUSE Leap, PostgreSQL, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this bulletin: 2/4.
Creation date: 20/06/2019.
Références of this threat: CVE-2019-10164, openSUSE-SU-2019:1773-1, RHSA-2020:0980-01, RHSA-2020:3669-01, SUSE-SU-2019:1783-1, SUSE-SU-2019:1783-2, SUSE-SU-2019:1810-1, USN-4027-1, VIGILANCE-VUL-29583.

Description of the vulnerability 

An attacker can trigger a buffer overflow via Password Change of PostgreSQL, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer weakness announce impacts software or systems such as openSUSE Leap, PostgreSQL, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this security alert is medium.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this vulnerability.

Solutions for this threat 

PostgreSQL: version 11.4.
The version 11.4 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 10.9.
The version 10.9 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 9.6.14.
The version 9.6.14 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 9.5.18.
The version 9.5.18 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 9.4.23.
The version 9.4.23 is fixed:
  https://www.postgresql.org/download/

Cloud Foundry: fixed versions for PostgreSQL.
Fixed versions are indicated in information sources.

openSUSE Leap: new postgresql10 packages.
New packages are available:
  openSUSE Leap 15.0: postgresql10 10.9-lp150.3.10.1
  openSUSE Leap 15.1: postgresql10 10.9-lp151.2.3.1

Pivotal Cloud Foundry: fixed versions for PostgreSQL.
Fixed versions are indicated in information sources.

RHEL 7: new rh-postgresql10 packages.
New packages are available:
  RHEL 7.0-7.7: rh-postgresql10 postgresql-10.12-2.el7

RHEL 8: new postgresql-10 module.
The following module is updated:
  RHEL 8 Module: postgresql:10

SUSE LE 12: new postgresql10 packages.
New packages are available:
  SUSE LE 12 RTM: postgresql10 10.9-1.12.2
  SUSE LE 12 SP1: postgresql10 10.9-1.12.2
  SUSE LE 12 SP2: postgresql10 10.9-1.12.2
  SUSE LE 12 SP3: postgresql10 10.9-1.12.2
  SUSE LE 12 SP4: postgresql10 10.9-1.12.2

SUSE LE 12 SP3: new postgresql10 packages.
New packages are available:
  SUSE LE 12 SP3: postgresql10 10.9-1.12.2

SUSE LE 15 RTM: new postgresql10 packages.
New packages are available:
  SUSE LE 15 RTM: postgresql10 10.9-4.13.2

Ubuntu: new postgresql packages.
New packages are available:
  Ubuntu 19.04: postgresql-11 11.4-0ubuntu0.19.04.1
  Ubuntu 18.10: postgresql-10 10.9-0ubuntu0.18.10.1
  Ubuntu 18.04 LTS: postgresql-10 10.9-0ubuntu0.18.04.1

Wind River Linux: version 10.18.44.9.
The version 10.18.44.9 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computer vulnerability bulletins. The Vigil@nce vulnerability database contains several thousand vulnerabilities.