The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of PostgreSQL: code execution via CREATE EXTENSION

Synthesis of the vulnerability 

An attacker can use a vulnerability via CREATE EXTENSION of PostgreSQL, in order to run code.
Impacted software: Debian, openSUSE Leap, PostgreSQL, RHEL, SLES, Ubuntu.
Severity of this computer vulnerability: 2/4.
Creation date: 13/08/2020.
Références of this announce: CERTFR-2020-AVI-510, CVE-2020-14350, DLA-2331-1, openSUSE-SU-2020:1227-1, openSUSE-SU-2020:1228-1, openSUSE-SU-2020:1243-1, openSUSE-SU-2020:1244-1, openSUSE-SU-2020:1312-1, openSUSE-SU-2020:1326-1, RHSA-2020:3669-01, RHSA-2020:4295-01, SUSE-SU-2020:2264-1, SUSE-SU-2020:2265-1, SUSE-SU-2020:2271-1, SUSE-SU-2020:2355-1, USN-4472-1, VIGILANCE-VUL-33076.

Description of the vulnerability 

An attacker can use a vulnerability via CREATE EXTENSION of PostgreSQL, in order to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat impacts software or systems such as Debian, openSUSE Leap, PostgreSQL, RHEL, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability alert is medium.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this cybersecurity weakness.

Solutions for this threat 

PostgreSQL: version 12.4.
The version 12.4 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 11.9.
The version 11.9 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 10.14.
The version 10.14 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 9.6.19.
The version 9.6.19 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 9.5.23.
The version 9.5.23 is fixed:
  https://www.postgresql.org/download/

Debian 9: new posgresql-9.6 packages.
New packages are available:
  Debian 9: posgresql-9.6 9.6.19-0+deb9u1

openSUSE Leap 15.1: new postgresql10 packages.
New packages are available:
  openSUSE Leap 15.1: postgresql10 10.14-lp151.2.18.1

openSUSE Leap 15.1: new postgresql packages.
New packages are available:
  openSUSE Leap 15.1: postgresql96 9.6.19-lp151.3.3.1, postgresql10 10.13-lp151.2.14.1, postgresql12 12.3-lp151.2.1, postgresql 12.0.1-lp151.6.9.1

openSUSE Leap 15.2: new postgresql10 packages.
New packages are available:
  openSUSE Leap 15.2: postgresql10 10.14-lp152.2.6.2

openSUSE Leap 15.2: new postgresql packages.
New packages are available:
  openSUSE Leap 15.2: postgresql96 9.6.19-lp152.2.3.1, postgresql10 10.13-lp152.2.3.1, postgresql12 12.3-lp152.3.4.1

openSUSE Leap 15: new postgresql12 packages.
New packages are available:
  openSUSE Leap 15.1: postgresql12 12.4-lp151.6.1
  openSUSE Leap 15.2: postgresql12 12.4-lp152.3.7.1

RHEL 7: new rh-postgresql96-postgresql packages.
New packages are available:
  RHEL 7.0-7.9: rh-postgresql96-postgresql 9.6.19-1.el7

RHEL 8: new postgresql-10 module.
The following module is updated:
  RHEL 8 Module: postgresql:10

SUSE LE 15 RTM: new postgresql10 packages.
New packages are available:
  SUSE LE 15 RTM: postgresql10 10.14-4.25.1

SUSE LE 15 SP1-2: new postgresql10 packages.
New packages are available:
  SUSE LE 15 SP1: postgresql10 10.14-8.19.1
  SUSE LE 15 SP2: postgresql10 10.14-8.19.1

SUSE LE 15 SP1: new postgresql12 packages.
New packages are available:
  SUSE LE 15 SP1: postgresql12 12.4-3.11.1

SUSE LE 15 SP2: new postgresql12 packages.
New packages are available:
  SUSE LE 15 SP2: postgresql12 12.4-8.6.1

Ubuntu: new postgresql packages.
New packages are available:
  Ubuntu 20.04 LTS: postgresql-12 12.4-0ubuntu0.20.04.1
  Ubuntu 18.04 LTS: postgresql-10 10.14-0ubuntu0.18.04.1
  Ubuntu 16.04 LTS: postgresql-9.5 9.5.23-0ubuntu0.16.04.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a network vulnerability database. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.