The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of PostgreSQL: four vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of PostgreSQL.
Impacted software: Debian, openSUSE Leap, PostgreSQL, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this computer vulnerability: 2/4.
Number of vulnerabilities in this bulletin: 4.
Creation date: 08/08/2019.
Références of this announce: CVE-2019-10208, CVE-2019-10209, CVE-2019-10210, CVE-2019-10211, DLA-1874-1, DSA-4492-1, DSA-4493-1, openSUSE-SU-2019:2062-1, openSUSE-SU-2020:1227-1, RHSA-2020:3669-01, SUSE-SU-2019:2158-1, SUSE-SU-2019:2159-1, SUSE-SU-2019:2228-1, SUSE-SU-2019:2707-1, USN-4090-1, VIGILANCE-VUL-29986.

Description of the vulnerability 

An attacker can use several vulnerabilities of PostgreSQL.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity threat impacts software or systems such as Debian, openSUSE Leap, PostgreSQL, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat note is medium.

The trust level is of type confirmed by the editor, with an origin of user account.

This bulletin is about 4 vulnerabilities.

An attacker with a expert ability can exploit this security threat.

Solutions for this threat 

PostgreSQL: version 11.5.
The version 11.5 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 10.10.
The version 10.10 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 9.6.15.
The version 9.6.15 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 9.5.19.
The version 9.5.19 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 9.4.24.
The version 9.4.24 is fixed:
  https://www.postgresql.org/download/

Debian 10: new postgresql-11 packages.
New packages are available:
  Debian 10: postgresql-11 11.5-1+deb10u1

Debian 8: new postgresql-9.4 packages.
New packages are available:
  Debian 8: postgresql-9.4 9.4.24-0+deb8u1

Debian 9: new postgresql-9.6 packages.
New packages are available:
  Debian 9: postgresql-9.6 9.6.15-0+deb9u1

openSUSE Leap 15.1: new postgresql packages.
New packages are available:
  openSUSE Leap 15.1: postgresql96 9.6.19-lp151.3.3.1, postgresql10 10.13-lp151.2.14.1, postgresql12 12.3-lp151.2.1, postgresql 12.0.1-lp151.6.9.1

openSUSE Leap 15: new postgresql10 packages.
New packages are available:
  openSUSE Leap 15.0: postgresql10 10.10-lp150.3.13.1
  openSUSE Leap 15.1: postgresql10 10.10-lp151.2.6.1

RHEL 8: new postgresql-10 module.
The following module is updated:
  RHEL 8 Module: postgresql:10

SUSE LE 12: new postgresql96 packages.
New packages are available:
  SUSE LE 12 SP1: postgresql96 9.6.15-3.29.1
  SUSE LE 12 SP2: postgresql96 9.6.15-3.29.1
  SUSE LE 12 SP3: postgresql96 9.6.15-3.29.1

SUSE LE 12 SP1/2: new postgresql94 packages.
New packages are available:
  SUSE LE 12 SP1: postgresql94 9.4.24-21.25.1
  SUSE LE 12 SP2: postgresql94 9.4.24-21.25.1

SUSE LE 15 RTM: new postgresql10 packages.
New packages are available:
  SUSE LE 15 RTM: postgresql10 10.10-4.16.1

SUSE LE 15 SP1: new postgresql10 packages.
New packages are available:
  SUSE LE 15 SP1: postgresql10 10.10-8.6.1

Ubuntu: new postgresql packages.
New packages are available:
  Ubuntu 19.04: postgresql-11 11.5-0ubuntu0.19.04.1
  Ubuntu 18.04 LTS: postgresql-10 10.10-0ubuntu0.18.04.1
  Ubuntu 16.04 LTS: postgresql-9.5 9.5.19-0ubuntu0.16.04.1

Wind River Linux: version 10.17.41.19.
The version 10.17.41.19 is fixed.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a networks vulnerabilities watch. The technology watch team tracks security threats targeting the computer system.