The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of PostgreSQL: information disclosure via Partition Constraint

Synthesis of the vulnerability 

An attacker can bypass access restrictions to data via Partition Constraint of PostgreSQL, in order to obtain sensitive information.
Impacted products: Fedora, openSUSE Leap, PostgreSQL, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this bulletin: 2/4.
Creation date: 11/02/2021.
Références of this threat: CERTFR-2021-AVI-117, CVE-2021-3393, FEDORA-2021-3286ac2acc, FEDORA-2021-3db6876545, openSUSE-SU-2021:0423-1, RHSA-2021:2372-01, RHSA-2021:2389-01, RHSA-2021:2394-01, SUSE-SU-2021:0543-1, SUSE-SU-2021:0544-1, SUSE-SU-2021:0545-1, SUSE-SU-2021:0695-1, SUSE-SU-2021:1783-1, USN-4735-1, VIGILANCE-VUL-34569.

Description of the vulnerability 

An attacker can bypass access restrictions to data via Partition Constraint of PostgreSQL, in order to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat impacts software or systems such as Fedora, openSUSE Leap, PostgreSQL, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat is medium.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this cybersecurity bulletin.

Solutions for this threat 

PostgreSQL: version 13.2.
The version 13.2 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 12.6.
The version 12.6 is fixed:
  https://www.postgresql.org/download/

PostgreSQL: version 11.11.
The version 11.11 is fixed:
  https://www.postgresql.org/download/

Fedora 32-33: new libpq packages.
New packages are available:
  Fedora 32: libpq 12.6-1.fc32
  Fedora 33: libpq 12.6-1.fc33

Fedora 32-33: new postgresql packages.
New packages are available:
  Fedora 32: postgresql 12.6-1.fc32
  Fedora 33: postgresql 12.6-1.fc33

openSUSE Leap 15.2: new postgresql12 packages.
New packages are available:
  openSUSE Leap 15.2: postgresql12 12.6-lp152.3.16.1

RHEL 7: new rh-postgresql12-postgresql packages.
New packages are available:
  RHEL 7.0-7.9: rh-postgresql12-postgresql 12.7-1.el7

RHEL 8.2: new postgresql-12 module.
The following module is updated:
  RHEL 8.2 Module: postgresql:12

RHEL 8: new postgresql-12 module.
The following module is updated:
  RHEL 8 Module: postgresql:12

SUSE LE 12 SP5: new postgresql12 packages.
New packages are available:
  SUSE LE 12 SP5: postgresql12 12.7-3.15.3

SUSE LE 12 SP5: new postgresql13 packages.
New packages are available:
  SUSE LE 12 SP5: postgresql13 13.2-3.6.1

SUSE LE 15 SP1: new postgresql12 packages.
New packages are available:
  SUSE LE 15 SP1: postgresql12 12.6-3.21.4

SUSE LE 15 SP2: new postgresql12 packages.
New packages are available:
  SUSE LE 15 SP2: postgresql12 12.6-8.16.1

SUSE LE 15 SP2: new postgresql13 packages.
New packages are available:
  SUSE LE 15 SP2: postgresql13 13.2-5.6.1

Ubuntu: new postgresql-12 packages.
New packages are available:
  Ubuntu 20.10: postgresql-12 12.6-0ubuntu0.20.10.1
  Ubuntu 20.04 LTS: postgresql-12 12.6-0ubuntu0.20.04.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides networks vulnerabilities announces. The technology watch team tracks security threats targeting the computer system.