The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of ProFTPD: read-write access via mod_copy Limit Bypass

Synthesis of the vulnerability 

An attacker can bypass access restrictions via mod_copy Limit Bypass of ProFTPD, in order to read or alter data.
Vulnerable products: Debian, Fedora, openSUSE Leap, ProFTPD, SIMATIC, SLES.
Severity of this weakness: 3/4.
Creation date: 22/07/2019.
Références of this bulletin: CVE-2019-12815, DLA-1873-1, DSA-4491-1, FEDORA-2019-e9187610c3, openSUSE-SU-2019:1836-1, openSUSE-SU-2019:1870-1, openSUSE-SU-2020:0031-1, SSA-940889, VIGILANCE-VUL-29844.

Description of the vulnerability 

An attacker can bypass access restrictions via mod_copy Limit Bypass of ProFTPD, in order to read or alter data.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity note impacts software or systems such as Debian, Fedora, openSUSE Leap, ProFTPD, SIMATIC, SLES.

Our Vigil@nce team determined that the severity of this computer weakness announce is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this cybersecurity vulnerability.

Solutions for this threat 

ProFTPD: patch for mod_copy Limit Bypass.
A patch is indicated in information sources.

Debian 8: new proftpd-dfsg packages.
New packages are available:
  Debian 8: proftpd-dfsg 1.3.5e+r1.3.5-2+deb8u3

Debian 9: new proftpd-dfsg packages.
New packages are available:
  Debian 9: proftpd-dfsg 1.3.5b-4+deb9u1
  Debian 10: proftpd-dfsg 1.3.6-4+deb10u1

Fedora 30: new proftpd packages.
New packages are available:
  Fedora 30: proftpd 1.3.6-21.fc30

openSUSE Leap 15.1: new proftpd packages.
New packages are available:
  openSUSE Leap 15.1: proftpd 1.3.6b-lp151.3.6.1
  SUSE LE 15 RTM: proftpd 1.3.6b-bp150.3.6.1
  SUSE LE 15 SP1: proftpd 1.3.6b-bp151.4.6.2

openSUSE Leap 15: new proftpd packages.
New packages are available:
  openSUSE Leap 15.0: proftpd 1.3.5e-lp150.2.3.1
  openSUSE Leap 15.1: proftpd 1.3.5e-lp151.3.3.1
  SUSE LE 15 RTM-SP1: proftpd 1.3.5e-bp150.3.3.1

Siemens SIMATIC: solution for ProFTPD.
The solution is indicated in information sources.

SUSE LE 15 SP1: new proftpd packages.
New packages are available:
  SUSE LE 15 SP1: proftpd 1.3.5e-bp151.4.3.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a software vulnerability announce. The Vigil@nce vulnerability database contains several thousand vulnerabilities.