The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Python Pygments: overload via SML File

Synthesis of the vulnerability 

An attacker can trigger an overload via SML File of Python Pygments, in order to trigger a denial of service.
Impacted products: Debian, SLES, Ubuntu.
Severity of this bulletin: 2/4.
Creation date: 12/03/2021.
Références of this threat: CVE-2021-20270, DLA-2590-1, DLA-2648-1, DLA-2648-2, DSA-4870-1, DSA-4889-1, SUSE-SU-2021:1500-1, USN-4885-1, VIGILANCE-VUL-34839.

Description of the vulnerability 

An attacker can trigger an overload via SML File of Python Pygments, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability alert impacts software or systems such as Debian, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat alert is medium.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this security vulnerability.

Solutions for this threat 

Debian 10: new mediawiki packages.
New packages are available:
  Debian 10: mediawiki 1:1.31.14-1~deb10u1

Debian 10: new pygments packages.
New packages are available:
  Debian 10: pygments 2.3.1+dfsg-1+deb10u1

Debian 9: new mediawiki packages.
New packages are available:
  Debian 9: mediawiki 1:1.27.7-1~deb9u9

Debian 9: new pygments packages.
New packages are available:
  Debian 9: pygments 2.2.0+dfsg-1+deb9u1

SUSE LE 15: new python-Pygments packages.
New packages are available:
  SUSE LE 15 SP3: python2-Pygments-2.2.0-4.6.1
  SUSE LE 15 SP2: python2-Pygments-2.2.0-4.6.1
  SUSE LE 15 RTM: python3-Pygments-2.2.0-4.6.1

Ubuntu: new python-pygments packages.
New packages are available:
  Ubuntu 20.10: python3-pygments 2.3.1+dfsg-4ubuntu0.1
  Ubuntu 20.04 LTS: python-pygments 2.3.1+dfsg-1ubuntu2.1, python3-pygments 2.3.1+dfsg-1ubuntu2.1
  Ubuntu 18.04 LTS: python-pygments 2.2.0+dfsg-1ubuntu0.1, python3-pygments 2.2.0+dfsg-1ubuntu0.1
  Ubuntu 16.04 LTS: python-pygments 2.1+dfsg-1ubuntu0.1, python3-pygments 2.1+dfsg-1ubuntu0.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability announces. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.