The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Python urllib3: two vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of Python urllib3.
Impacted products: Fedora, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this bulletin: 1/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 24/04/2019.
Références of this threat: bulletinjul2019, CVE-2018-20060, CVE-2019-11324, FEDORA-2019-8560719e80, FEDORA-2019-a6c56f9756, openSUSE-SU-2019:2131-1, openSUSE-SU-2019:2133-1, RHSA-2019:2272-01, RHSA-2019:3335-01, RHSA-2019:3590-01, RHSA-2020:0850-01, RHSA-2020:0851-01, SUSE-SU-2019:2331-1, SUSE-SU-2019:2332-1, SUSE-SU-2019:2370-1, USN-3990-1, VIGILANCE-VUL-29115.

Description of the vulnerability 

An attacker can use several vulnerabilities of Python urllib3.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability note impacts software or systems such as Fedora, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability announce is low.

The trust level is of type confirmed by the editor, with an origin of internet server.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity announce.

Solutions for this threat 

elasticsearch-curator: version 5.7.6.
The version 5.7.6 is fixed:
  https://pypi.org/project/elasticsearch-curator/5.7.6/

Fedora: new python-urllib3 packages.
New packages are available:
  Fedora 29: python-urllib3 1.24.2-1.fc29
  Fedora 28: python-urllib3 1.24.2-1.fc28

openSUSE Leap: new python-urllib3 packages.
New packages are available:
  openSUSE Leap 15.0: python2-urllib3 1.22-lp150.5.3.1, python3-urllib3 1.22-lp150.5.3.1
  openSUSE Leap 15.1: python2-urllib3 1.24-lp151.2.3.1, python3-urllib3 1.24-lp151.2.3.1

Oracle Solaris: patch for third party software of July 2019 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7.7: new python-pip packages.
New packages are available:
  RHEL 7.7: python-pip 9.0.3-7.el7_7

RHEL 7.7: new python-virtualenv packages.
New packages are available:
  RHEL 7.7: python-virtualenv 15.1.0-4.el7_7

RHEL 7: new python-urllib3 packages.
New packages are available:
  RHEL 7: python-urllib3 1.10.2-7.el7

RHEL 8: new python27-2.7 module.
The following module is updated:
  RHEL 8 Module: python27:2.7

RHEL 8: new python-urllib3 packages.
New packages are available:
  RHEL 8: python-urllib3 1.24.2-2.el8

SUSE LE 12: new python-urllib3 packages.
New packages are available:
  SUSE LE 12 RTM-SP5: python-urllib3 1.22-3.14.1

SUSE LE 15 RTM: new python-urllib3 packages.
New packages are available:
  SUSE LE 15 RTM: python-urllib3 1.22-6.4.1

SUSE LE 15 SP1: new python-urllib3 packages.
New packages are available:
  SUSE LE 15 SP1: python-urllib3 1.24-9.4.1

Ubuntu: new urllib3 packages.
New packages are available:
  Ubuntu 19.04: python-urllib3 1.24.1-1ubuntu0.1, python3-urllib3 1.24.1-1ubuntu0.1
  Ubuntu 18.10: python-urllib3 1.22-1ubuntu0.18.10.1, python3-urllib3 1.22-1ubuntu0.18.10.1
  Ubuntu 18.04 LTS: python-urllib3 1.22-1ubuntu0.18.04.1, python3-urllib3 1.22-1ubuntu0.18.04.1
  Ubuntu 16.04 LTS: python-urllib3 1.13.1-2ubuntu0.16.04.3, python3-urllib3 1.13.1-2ubuntu0.16.04.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a cybersecurity database. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.