The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of QEMU: denial of service via vga_draw_line

Synthesis of the vulnerability 

An attacker, inside a guest system, can generate a fatal error via vga_draw_line() of QEMU, in order to trigger a denial of service on the host system.
Vulnerable systems: Debian, Fedora, Junos Space, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this threat: 1/4.
Creation date: 31/08/2017.
Références of this weakness: CVE-2017-13672, DSA-3991-1, FEDORA-2017-5bcddc1984, FEDORA-2017-9149114fba, FEDORA-2017-d4709b0d8b, JSA10917, openSUSE-SU-2017:2938-1, openSUSE-SU-2017:2941-1, openSUSE-SU-2019:1074-1, RHSA-2018:0816-01, RHSA-2018:2162-01, SUSE-SU-2017:2924-1, SUSE-SU-2017:2936-1, SUSE-SU-2017:2946-1, SUSE-SU-2017:2963-1, SUSE-SU-2017:2969-1, SUSE-SU-2017:3084-1, SUSE-SU-2017:3236-1, SUSE-SU-2017:3239-1, SUSE-SU-2017:3242-1, SUSE-SU-2019:0489-1, SUSE-SU-2019:0582-1, SUSE-SU-2019:0825-1, SUSE-SU-2019:0827-1, SUSE-SU-2019:13921-1, USN-3575-1, USN-3575-2, VIGILANCE-VUL-23648.

Description of the vulnerability 

An attacker, inside a guest system, can generate a fatal error via vga_draw_line() of QEMU, in order to trigger a denial of service on the host system.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity vulnerability impacts software or systems such as Debian, Fedora, Junos Space, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this vulnerability is low.

The trust level is of type confirmed by the editor, with an origin of privileged account.

An attacker with a expert ability can exploit this weakness alert.

Solutions for this threat 

QEMU: patch for vga_draw_line.
A patch is indicated in information sources.

Debian 9: new qemu packages (04/10/2017).
New packages are available:
  Debian 9: qemu 1:2.8+dfsg-6+deb9u3

Fedora 25/26: new xen packages.
New packages are available:
  Fedora 25: xen 4.7.3-7.fc25
  Fedora 26: xen 4.8.2-4.fc26

Fedora 26: new qemu packages.
New packages are available:
  Fedora 26: qemu 2.9.1-2.fc26

Junos Space: version 18.3R1.
The version 18.3R1 is fixed.

openSUSE Leap 42.2: new qemu packages.
New packages are available:
  openSUSE Leap 42.2: qemu 2.6.2-31.9.1

openSUSE Leap 42.3: new qemu packages (07/11/2017).
New packages are available:
  openSUSE Leap 42.3: qemu 2.9.1-35.1

openSUSE Leap 42.3: new qemu packages (29/03/2019).
New packages are available:
  openSUSE Leap 42.3: qemu 2.9.1-56.1

RHEL 6.10: new qemu-kvm packages (11/07/2018).
New packages are available:
  RHEL 6: qemu-kvm 0.12.1.2-2.506.el6_10.1

RHEL 7: new qemu-kvm packages.
New packages are available:
  RHEL 7: qemu-kvm 1.5.3-156.el7

SUSE LE 11 SP3: new kvm packages.
New packages are available:
  SUSE LE 11 SP3: kvm 1.4.2-53.11.1

SUSE LE 11 SP4: new kvm packages.
New packages are available:
  SUSE LE 11 SP4: kvm 1.4.2-60.3.1

SUSE LE 11 SP4: new xen packages (03/01/2019).
New packages are available:
  SUSE LE 11 SP4: xen 4.4.4_38-61.40.1

SUSE LE 11 SP4: new xen packages (08/12/2017).
New packages are available:
  SUSE LE 11 SP4: xen 4.4.4_26-61.17.1

SUSE LE 12: new qemu packages.
New packages are available:
  SUSE LE 12 SP2: qemu 2.6.2-41.49.1

SUSE LE 12 RTM: new qemu packages.
New packages are available:
  SUSE LE 12 RTM: qemu 2.0.2-48.34.3

SUSE LE 12 RTM: new xen packages (01/04/2019).
New packages are available:
  SUSE LE 12 RTM: xen 4.4.4_40-22.77.1

SUSE LE 12 RTM: new xen packages (08/12/2017).
New packages are available:
  SUSE LE 12 RTM: xen 4.4.4_26-22.59.3

SUSE LE 12 SP1: new qemu packages (08/11/2017).
New packages are available:
  SUSE LE 12 SP1: qemu 2.3.1-33.3.3

SUSE LE 12 SP1: new xen packages (01/04/2019).
New packages are available:
  SUSE LE 12 SP1: xen 4.5.5_28-22.58.1

SUSE LE 12 SP1: new xen packages (08/12/2017).
New packages are available:
  SUSE LE 12 SP1: xen 4.5.5_20-22.36.3

SUSE LE 12 SP2: new qemu packages.
New packages are available:
  SUSE LE 12 SP2: qemu 1.0.0-41.22.2

SUSE LE 12 SP3: new qemu packages (03/11/2017).
New packages are available:
  SUSE LE 12 SP3: qemu 2.9.1-6.6.3

SUSE LE 12 SP3: new qemu packages (12/03/2019).
New packages are available:
  SUSE LE 12 SP3: qemu 2.9.1-6.28.1

Ubuntu: new qemu-system packages.
New packages are available:
  Ubuntu 17.10: qemu-system 1:2.10+dfsg-0ubuntu3.5
  Ubuntu 16.04 LTS: qemu 1:2.5+dfsg-5ubuntu10.24
  Ubuntu 14.04 LTS: qemu 2.0.0+dfsg-2ubuntu1.40
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a systems vulnerabilities patch. The technology watch team tracks security threats targeting the computer system.