The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of QEMU: memory corruption via Cirrus CLGD 54xx VGA Emulator

Synthesis of the vulnerability 

An attacker, inside a guest system, can generate a memory corruption via Cirrus CLGD 54xx VGA Emulator of QEMU, in order to trigger a denial of service, and possibly to run code on the host system.
Impacted products: XenServer, Debian, Fedora, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this bulletin: 2/4.
Creation date: 21/04/2017.
Références of this threat: CERTFR-2017-AVI-444, CTX230138, CVE-2017-7980, DLA-1035-1, DLA-1497-1, DLA-939-1, FEDORA-2017-f941184db1, openSUSE-SU-2017:1872-1, RHSA-2017:1206-01, RHSA-2017:1430-01, SUSE-SU-2017:1145-1, SUSE-SU-2017:1146-1, SUSE-SU-2017:1147-1, SUSE-SU-2017:1148-1, SUSE-SU-2017:1774-1, SUSE-SU-2017:2946-1, SUSE-SU-2017:2963-1, SUSE-SU-2017:2969-1, SUSE-SU-2017:3084-1, USN-3289-1, VIGILANCE-VUL-22533.

Description of the vulnerability 

An attacker, inside a guest system, can generate a memory corruption via Cirrus CLGD 54xx VGA Emulator of QEMU, in order to trigger a denial of service, and possibly to run code on the host system.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat announce impacts software or systems such as XenServer, Debian, Fedora, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability is medium.

The trust level is of type confirmed by the editor, with an origin of privileged shell.

An attacker with a expert ability can exploit this cybersecurity alert.

Solutions for this threat 

QEMU: patch for Cirrus CLGD 54xx VGA Emulator.
A patch is indicated in information sources.

Citrix XenServer: fixed versions.
Fixed versions are indicated in information sources.

Debian 7: new qemu-kvm packages.
New packages are available:
  Debian 7: qemu-kvm 1.1.2+dfsg-6+deb7u21

Debian 7: new qemu packages.
New packages are available:
  Debian 7: qemu 1.1.2+dfsg-6+deb7u22

Debian 8: new qemu packages.
New packages are available:
  Debian 8: qemu 1:2.1+dfsg-12+deb8u7

Fedora 25: new qemu packages.
New packages are available:
  Fedora 25: qemu 2.7.1-7.fc25

openSUSE Leap 42.2: new qemu packages (17/07/2017).
New packages are available:
  openSUSE Leap 42.2: qemu 2.6.2-31.3.3

RHEL 6.9: new qemu-kvm packages.
New packages are available:
  RHEL 6: qemu-kvm 0.12.1.2-2.503.el6_9.3

RHEL: new qemu-kvm packages.
New packages are available:
  RHEL 7: qemu-kvm 1.5.3-126.el7_3.9

SUSE LE 11 SP3: new kvm packages.
New packages are available:
  SUSE LE 11 SP3: kvm 1.4.2-53.11.1

SUSE LE 11 SP3: new xen packages.
New packages are available:
  SUSE LE 11 SP3: xen 4.2.5_21-41.1

SUSE LE 11 SP4: new kvm packages.
New packages are available:
  SUSE LE 11 SP4: kvm 1.4.2-60.3.1

SUSE LE 11 SP4: new xen packages.
New packages are available:
  SUSE LE 11 SP4: xen 4.4.4_18-57.1

SUSE LE 12 RTM: new qemu packages.
New packages are available:
  SUSE LE 12 RTM: qemu 2.0.2-48.34.3

SUSE LE 12 RTM: new xen packages.
New packages are available:
  SUSE LE 12 RTM: xen 4.4.4_18-22.39.1

SUSE LE 12 SP1: new qemu packages (08/11/2017).
New packages are available:
  SUSE LE 12 SP1: qemu 2.3.1-33.3.3

SUSE LE 12 SP1: new xen packages.
New packages are available:
  SUSE LE 12 SP1: xen 4.5.5_10-22.14.1

SUSE LE 12 SP2: new qemu packages (05/07/2017).
New packages are available:
  SUSE LE 12 SP2: qemu 2.6.2-41.16.1

Ubuntu: new qemu-system packages.
New packages are available:
  Ubuntu 17.04: qemu-system 1:2.8+dfsg-3ubuntu2.2
  Ubuntu 16.10: qemu-system 1:2.6.1+dfsg-0ubuntu5.5
  Ubuntu 16.04 LTS: qemu-system 1:2.5+dfsg-5ubuntu10.14
  Ubuntu 14.04 LTS: qemu-system 2.0.0+dfsg-2ubuntu1.34
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability analysis. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.