The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of QEMU: out-of-bounds memory reading via PVSCSI_CMD_SETUP_RINGS

Synthesis of the vulnerability 

An attacker, in a guest system, can force a read at an invalid address via PVSCSI_CMD_SETUP_RINGS of QEMU, in order to trigger a denial of service, or to obtain sensitive information on the host system.
Impacted systems: Debian, openSUSE Leap, QEMU, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 1/4.
Creation date: 06/09/2016.
Références of this alert: CVE-2016-7155, DLA-1599-1, openSUSE-SU-2016:2642-1, SUSE-SU-2016:2589-1, USN-3125-1, VIGILANCE-VUL-20525.

Description of the vulnerability 

An attacker, in a guest system, can force a read at an invalid address via PVSCSI_CMD_SETUP_RINGS of QEMU, in order to trigger a denial of service, or to obtain sensitive information on the host system.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security weakness impacts software or systems such as Debian, openSUSE Leap, QEMU, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat bulletin is low.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this threat.

Solutions for this threat 

QEMU: patch for PVSCSI_CMD_SETUP_RINGS.
A patch is indicated in information sources.

Debian 8: new qemu packages.
New packages are available:
  Debian 8: qemu 1:2.1+dfsg-12+deb8u8

openSUSE Leap 42.1: new qemu packages.
New packages are available:
  openSUSE Leap 42.1: qemu 2.3.1-19.3

SUSE LE 12 SP1: new qemu packages (24/10/2016).
New packages are available:
  SUSE LE 12 SP1: qemu 2.3.1-21.1

Ubuntu: new qemu packages (10/11/2016).
New packages are available:
  Ubuntu 12.04 LTS: qemu 1.0+noroms-0ubuntu14.31
  Ubuntu 14.04 LTS: qemu 2.0.0+dfsg-2ubuntu1.30
  Ubuntu 16.04 LTS: qemu 1:2.5+dfsg-5ubuntu10.6
  Ubuntu 16.10: qemu 1:2.6.1+dfsg-0ubuntu5.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides applications vulnerabilities bulletins. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.