The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of QEMU: out-of-bounds memory reading via SLiRP ARP/NCSI Packets

Synthesis of the vulnerability 

An attacker, inside a guest system, can force a read at an invalid address via SLiRP ARP/NCSI Packets of QEMU, in order to trigger a denial of service, or to obtain sensitive information on the host system.
Impacted products: Debian, openSUSE Leap, QEMU, SUSE Linux Enterprise Desktop, SLES.
Severity of this bulletin: 1/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 27/11/2020.
Références of this threat: CVE-2020-29129, CVE-2020-29130, DLA-2560-1, openSUSE-SU-2021:0600-1, SUSE-SU-2020:14578-1, SUSE-SU-2020:3880-1, SUSE-SU-2020:3913-1, SUSE-SU-2020:3914-1, SUSE-SU-2020:3945-1, SUSE-SU-2021:1240-1, SUSE-SU-2021:1241-1, SUSE-SU-2021:1242-1, SUSE-SU-2021:1243-1, SUSE-SU-2021:1244-1, SUSE-SU-2021:1245-1, SUSE-SU-2021:1305-1, SUSE-SU-2021:14704-1, SUSE-SU-2021:14706-1, VIGILANCE-VUL-33987.

Description of the vulnerability 

An attacker, inside a guest system, can force a read at an invalid address via SLiRP ARP/NCSI Packets of QEMU, in order to trigger a denial of service, or to obtain sensitive information on the host system.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability announce impacts software or systems such as Debian, openSUSE Leap, QEMU, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this cybersecurity threat is low.

The trust level is of type confirmed by the editor, with an origin of privileged shell.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this computer threat bulletin.

Solutions for this threat 

QEMU: patch for SLiRP ARP/NCSI Packets.
A patch is indicated in information sources.

Debian 9: new qemu packages.
New packages are available:
  Debian 9: qemu 1:2.8+dfsg-6+deb9u13

openSUSE Leap 15.2: new qemu packages.
New packages are available:
  openSUSE Leap 15.2: qemu 4.2.1-lp152.9.12.1

SUSE LE 11 SP3: new kvm packages.
New packages are available:
  SUSE LE 11 SP3: kvm 1.4.2-53.38.1

SUSE LE 11 SP4: new kvm packages.
New packages are available:
  SUSE LE 11 SP4: kvm 1.4.2-60.34.1

SUSE LE 11 SP4: new xen packages.
New packages are available:
  SUSE LE 11 SP4: xen 4.4.4_48-61.61.1

SUSE LE 12 SP2: new qemu packages.
New packages are available:
  SUSE LE 12 SP2: qemu 2.6.2-41.62.1

SUSE LE 12 SP2: new xen packages.
New packages are available:
  SUSE LE 12 SP2: xen 4.7.6_14-43.73.1

SUSE LE 12 SP3: new qemu packages.
New packages are available:
  SUSE LE 12 SP3: qemu 2.9.1-6.47.1

SUSE LE 12 SP3: new xen packages.
New packages are available:
  SUSE LE 12 SP3: xen 4.9.4_16-3.80.1

SUSE LE 12 SP4: new qemu packages.
New packages are available:
  SUSE LE 12 SP4: qemu 2.11.2-5.29.1

SUSE LE 12 SP4: new xen packages.
New packages are available:
  SUSE LE 12 SP4: xen 4.11.4_16-2.48.1

SUSE LE 12 SP5: new qemu packages.
New packages are available:
  SUSE LE 12 SP5: qemu 3.1.1.1-48.2

SUSE LE 12 SP5: new xen packages.
New packages are available:
  SUSE LE 12 SP5: xen 4.12.4_06-3.36.1

SUSE LE 15 RTM: new qemu packages.
New packages are available:
  SUSE LE 15 RTM: qemu 2.11.2-9.43.1

SUSE LE 15 SP1: new qemu packages.
New packages are available:
  SUSE LE 15 SP1: qemu 3.1.1.1-9.24.3

SUSE LE 15 SP2: new qemu packages.
New packages are available:
  SUSE LE 15 SP2: qemu 4.2.1-11.16.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer vulnerability database. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.