The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of QuickTime: multiple vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of QuickTime.
Vulnerable systems: QuickTime.
Severity of this threat: 3/4.
Number of vulnerabilities in this bulletin: 10.
Creation date: 26/02/2014.
Références of this weakness: APPLE-SA-2014-02-25-3, BID-65784, BID-65786, BID-65787, CERTFR-2014-AVI-090, CVE-2013-1032, CVE-2014-1243, CVE-2014-1244, CVE-2014-1245, CVE-2014-1246, CVE-2014-1247, CVE-2014-1248, CVE-2014-1249, CVE-2014-1250, CVE-2014-1251, VIGILANCE-VUL-14312, ZDI-14-044, ZDI-14-045, ZDI-14-046, ZDI-14-047, ZDI-14-048, ZDI-14-049.

Description of the vulnerability 

Several vulnerabilities were announced in QuickTime.

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; BID-65784, CVE-2014-1243, ZDI-14-044]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; BID-65786, CVE-2014-1244, ZDI-14-045]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; CVE-2013-1032]

An attacker can generate a buffer overflow in stsz, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; CVE-2014-1245, ZDI-14-047]

An attacker can generate a buffer overflow in ftab, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; CVE-2014-1246, ZDI-14-048]

An attacker can generate a buffer overflow in dref, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; CVE-2014-1247, ZDI-14-046]

An attacker can generate a buffer overflow in ldat, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; CVE-2014-1248]

An attacker can generate a buffer overflow in PSD, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; CVE-2014-1249]

An attacker can generate a buffer overflow in ttfo, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; CVE-2014-1250]

An attacker can generate a buffer overflow in clef, in order to trigger a denial of service, and possibly to execute code. [severity:3/4; BID-65787, CVE-2014-1251, ZDI-14-049]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity note impacts software or systems such as QuickTime.

Our Vigil@nce team determined that the severity of this computer weakness announce is important.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 10 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity vulnerability.

Solutions for this threat 

QuickTime: version 7.7.5.
The version 7.7.5 is fixed:
  http://support.apple.com/downloads/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability bulletins. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.