The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of RubyGems: code execution via YAML Gem Specification

Synthesis of the vulnerability 

An attacker can use a vulnerability via YAML Gem Specification of RubyGems, in order to run code.
Vulnerable products: Debian, Fedora, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this weakness: 3/4.
Creation date: 13/11/2017.
Références of this bulletin: CVE-2017-0903, DLA-1421-1, DSA-4031-1, FEDORA-2018-0db545e976, FEDORA-2018-75e780a7c2, RHSA-2017:3485-01, RHSA-2018:0378-01, RHSA-2018:0583-01, RHSA-2018:0585-01, SUSE-SU-2020:1570-1, USN-3553-1, USN-3685-1, USN-3685-2, VIGILANCE-VUL-24414.

Description of the vulnerability 

An attacker can use a vulnerability via YAML Gem Specification of RubyGems, in order to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat alert impacts software or systems such as Debian, Fedora, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this weakness announce is important.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this computer weakness bulletin.

Solutions for this threat 

Debian 8: new ruby2.1 packages (16/07/2018).
New packages are available:
  Debian 8: ruby2.1 2.1.5-2+deb8u4

Debian 9: new ruby2.3 packages.
New packages are available:
  Debian 9: ruby2.3 2.3.3-1+deb9u2

Fedora: new ruby packages.
New packages are available:
  Fedora 27: ruby 2.4.3-86.fc27
  Fedora 26: ruby 2.4.3-86.fc26

RHEL 7.4: new ruby packages.
New packages are available:
  RHEL 7: ruby 2.0.0.648-33.el7_4

RHEL: new rh-ruby22-ruby packages.
New packages are available:
  RHEL 6: rh-ruby22-ruby 2.2.9-19.el6
  RHEL 7: rh-ruby22-ruby 2.2.9-19.el7

RHEL: new rh-ruby23-ruby packages.
New packages are available:
  RHEL 6: rh-ruby23-ruby 2.3.6-67.el6
  RHEL 7: rh-ruby23-ruby 2.3.6-67.el7

RHEL: new rh-ruby24-ruby packages.
New packages are available:
  RHEL 6: rh-ruby24-ruby 2.4.2-86.el6
  RHEL 7: rh-ruby24-ruby 2.4.2-86.el7

SUSE LE 12: new ruby2.1 packages.
New packages are available:
  SUSE LE 12 SP2: ruby2.1 2.1.9-19.3.2
  SUSE LE 12 SP3: ruby2.1 2.1.9-19.3.2
  SUSE LE 12 SP4: ruby2.1 2.1.9-19.3.2
  SUSE LE 12 SP5: ruby2.1 2.1.9-19.3.2

Ubuntu: new Ruby packages.
New packages are available:
  Ubuntu 17.10: ruby2.3 2.3.3-1ubuntu1.3
  Ubuntu 16.04 LTS: ruby2.3 2.3.1-2~16.04.6

Ubuntu: new ruby packages (14/06/2018).
New packages are available:
  Ubuntu 17.10: ruby2.3 2.3.3-1ubuntu1.6
  Ubuntu 16.04 LTS: ruby2.3 2.3.1-2~16.04.10
  Ubuntu 14.04 LTS: ruby1.9.1 1.9.3.484-2ubuntu1.12, ruby1.9.3 1.9.3.484-2ubuntu1.12, ruby2.0 2.0.0.484-1ubuntu2.13+esm1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an application vulnerability patch. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.