The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of RubyGems: multiple vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of RubyGems.
Vulnerable software: Debian, Fedora, McAfee Web Gateway, openSUSE Leap, RHEL, SLES, Ubuntu.
Severity of this announce: 2/4.
Number of vulnerabilities in this bulletin: 7.
Creation date: 05/03/2018.
Références of this computer vulnerability: CVE-2018-1000073, CVE-2018-1000074, CVE-2018-1000075, CVE-2018-1000076, CVE-2018-1000077, CVE-2018-1000078, CVE-2018-1000079, DLA-1336-1, DLA-1337-1, DLA-1352-1, DLA-1358-1, DLA-1421-1, DLA-1480-1, DLA-1796-1, DSA-4219-1, DSA-4259-1, FEDORA-2018-1fffa787e7, FEDORA-2018-40ed78700c, openSUSE-SU-2019:1771-1, RHSA-2018:3729-01, RHSA-2018:3730-01, RHSA-2018:3731-01, RHSA-2019:2028-01, RHSA-2020:0542-01, RHSA-2020:0591-01, RHSA-2020:0663-01, RHSA-2020:1963-01, RHSA-2020:2212-01, RHSA-2020:2288-01, SUSE-SU-2019:1804-1, USN-3621-1, USN-3621-2, USN-3685-1, VIGILANCE-VUL-25429.

Description of the vulnerability 

An attacker can use several vulnerabilities of RubyGems.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness announce impacts software or systems such as Debian, Fedora, McAfee Web Gateway, openSUSE Leap, RHEL, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this vulnerability alert is medium.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 7 vulnerabilities.

An attacker with a expert ability can exploit this computer threat announce.

Solutions for this threat 

Debian 7: new jruby packages (03/04/2018).
New packages are available:
  Debian 7: jruby 1.5.6-5+deb7u1

Debian 7: new jruby packages (18/04/2018).
New packages are available:
  Debian 7: jruby 1.5.6-5+deb7u2

Debian 7: new ruby1.9.1 packages.
New packages are available:
  Debian 7: ruby1.9.1 1.9.3.194-8.1+deb7u8

Debian 7: new rubygems packages.
New packages are available:
  Debian 7: rubygems 1.8.24-1+deb7u2

Debian 8: new jruby packages.
New packages are available:
  Debian 8: jruby 1.5.6-9+deb8u1

Debian 8: new ruby2.1 packages (16/07/2018).
New packages are available:
  Debian 8: ruby2.1 2.1.5-2+deb8u4

Debian 8: new ruby2.1 packages (28/08/2018).
New packages are available:
  Debian 8: ruby2.1 2.1.5-2+deb8u5

Debian 9: new jruby packages.
New packages are available:
  Debian 9: jruby 1.7.26-1+deb9u1

Debian 9: new ruby2.3 packages.
New packages are available:
  Debian 9: ruby2.3 2.3.3-1+deb9u3

Fedora: new ruby packages.
New packages are available:
  Fedora 26: ruby 2.4.3-87.fc26
  Fedora 27: ruby 2.4.3-87.fc27

McAfee Web Gateway: version 8.2.2.
The version 8.2.2 is fixed:
  https://www.mcafee.com/enterprise/en-us/downloads/my-products.html

McAfee Web Gateway: version 9.0.
The version 9.0 is fixed:
  https://www.mcafee.com/enterprise/en-us/downloads/my-products.html

openSUSE Leap: new ruby2.5 packages.
New packages are available:
  openSUSE Leap 15.0: ruby2.5 2.5.5-lp150.3.3.1
  openSUSE Leap 15.1: ruby2.5 2.5.5-lp151.4.3.1

RHEL 7.4: new ruby packages.
New packages are available:
  RHEL 7.4: ruby 2.0.0.648-36.el7_4

RHEL 7.5: new ruby packages.
New packages are available:
  RHEL 7.5: ruby 2.0.0.648-36.el7_5

RHEL 7.6: new ruby packages.
New packages are available:
  RHEL 7.6: ruby 2.0.0.648-37.el7_6

RHEL 7: new ruby packages.
New packages are available:
  RHEL 7: ruby 2.0.0.648-36.el7

RHEL: new rh-ruby2x-ruby packages.
New packages are available:
  RHEL 6: rh-ruby23-ruby 2.3.8-69.el6, rh-ruby24-ruby 2.4.5-91.el6
  RHEL 7: rh-ruby25-ruby 2.5.3-6.el7

SUSE LE 15: new ruby2.5 packages.
New packages are available:
  SUSE LE 15 RTM: ruby2.5 2.5.5-4.3.1
  SUSE LE 15 SP1: ruby2.5 2.5.5-4.3.1

Ubuntu: new ruby packages (06/04/2018).
New packages are available:
  Ubuntu 17.10: libruby2.3 2.3.3-1ubuntu1.4, ruby2.3 2.3.3-1ubuntu1.4
  Ubuntu 16.04 LTS: libruby2.3 2.3.1-2~16.04.7, ruby2.3 2.3.1-2~16.04.7
  Ubuntu 14.04 LTS: libruby1.9.1 1.9.3.484-2ubuntu1.10, libruby2.0 2.0.0.484-1ubuntu2.8, ruby1.9.1 1.9.3.484-2ubuntu1.10, ruby1.9.3 1.9.3.484-2ubuntu1.10, ruby2.0 2.0.0.484-1ubuntu2.8

Ubuntu: new ruby packages (14/06/2018).
New packages are available:
  Ubuntu 17.10: ruby2.3 2.3.3-1ubuntu1.6
  Ubuntu 16.04 LTS: ruby2.3 2.3.1-2~16.04.10
  Ubuntu 14.04 LTS: ruby1.9.1 1.9.3.484-2ubuntu1.12, ruby1.9.3 1.9.3.484-2ubuntu1.12, ruby2.0 2.0.0.484-1ubuntu2.10
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a systems vulnerabilities watch. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.