The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of RubyGems: six vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of RubyGems.
Vulnerable systems: Debian, Fedora, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this threat: 2/4.
Number of vulnerabilities in this bulletin: 6.
Creation date: 29/03/2019.
Références of this weakness: bulletinjul2019, CVE-2019-8320, CVE-2019-8321, CVE-2019-8322, CVE-2019-8323, CVE-2019-8324, CVE-2019-8325, DLA-1735-1, DLA-1796-1, DSA-4433-1, FEDORA-2019-a155364f3c, openSUSE-SU-2019:1771-1, RHSA-2019:1235-01, RHSA-2019:1972-01, RHSA-2020:2769-01, SUSE-SU-2019:1804-1, SUSE-SU-2020:1570-1, USN-3945-1, VIGILANCE-VUL-28892.

Description of the vulnerability 

An attacker can use several vulnerabilities of RubyGems.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness alert impacts software or systems such as Debian, Fedora, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability note is medium.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 6 vulnerabilities.

An attacker with a expert ability can exploit this security bulletin.

Solutions for this threat 

Debian 8: new jruby packages.
New packages are available:
  Debian 8: jruby 1.5.6-9+deb8u1

Debian 8: new ruby2.1 packages.
New packages are available:
  Debian 8: ruby2.1 2.1.5-2+deb8u7

Debian 9: new ruby2.3 packages.
New packages are available:
  Debian 9: ruby2.3 2.3.3-1+deb9u6

Fedora: new ruby packages.
New packages are available:
  Fedora 29: ruby 2.5.5-101.fc29

openSUSE Leap: new ruby2.5 packages.
New packages are available:
  openSUSE Leap 15.0: ruby2.5 2.5.5-lp150.3.3.1
  openSUSE Leap 15.1: ruby2.5 2.5.5-lp151.4.3.1

Oracle Solaris: patch for third party software of July 2019 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7.4: new ruby packages.
New packages are available:
  RHEL 7.4: ruby 2.0.0.648-37.el7_4

RHEL 7.6: new ruby packages.
New packages are available:
  RHEL 7: ruby 2.0.0.648-35.el7_6

RHEL 8: new ruby packages.
New packages are available:
  RHEL 8: ruby 2.5.3-104.module+el8.0.0+3250+4b7d6d43

SUSE LE 12: new ruby2.1 packages.
New packages are available:
  SUSE LE 12 SP2: ruby2.1 2.1.9-19.3.2
  SUSE LE 12 SP3: ruby2.1 2.1.9-19.3.2
  SUSE LE 12 SP4: ruby2.1 2.1.9-19.3.2
  SUSE LE 12 SP5: ruby2.1 2.1.9-19.3.2

SUSE LE 15: new ruby2.5 packages.
New packages are available:
  SUSE LE 15 RTM: ruby2.5 2.5.5-4.3.1
  SUSE LE 15 SP1: ruby2.5 2.5.5-4.3.1

Ubuntu: new ruby packages.
New packages are available:
  Ubuntu 18.10: ruby2.5 2.5.1-5ubuntu4.3
  Ubuntu 18.04 LTS: ruby2.5 2.5.1-1ubuntu1.2
  Ubuntu 16.04 LTS: ruby2.3 2.3.1-2~16.04.12
  Ubuntu 14.04 LTS: ruby1.9.1 1.9.3.484-2ubuntu1.14, ruby1.9.3 1.9.3.484-2ubuntu1.14, ruby2.0 2.0.0.484-1ubuntu2.13
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a systems vulnerabilities workaround. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.