The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of SPICE: buffer overflow via QUIC Decoding Code

Synthesis of the vulnerability 

An attacker can trigger a buffer overflow via QUIC Decoding Code of SPICE, in order to trigger a denial of service, and possibly to run code.
Vulnerable software: Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this announce: 2/4.
Creation date: 06/10/2020.
Références of this computer vulnerability: CVE-2020-14355, DLA-2427-1, DLA-2428-1, DSA-4771-1, openSUSE-SU-2020:1802-1, openSUSE-SU-2020:1803-1, RHSA-2020:4184-01, RHSA-2020:4185-01, RHSA-2020:4186-01, RHSA-2020:4187-01, SUSE-SU-2020:3070-1, SUSE-SU-2020:3071-1, SUSE-SU-2020:3084-1, SUSE-SU-2020:3085-1, SUSE-SU-2021:14744-1, SUSE-SU-2021:1901-1, SUSE-SU-2021:1902-1, SUSE-SU-2021:1905-1, SUSE-SU-2021:1911-1, SUSE-SU-2021:1928-1, SUSE-SU-2021:1956-1, USN-4572-1, USN-4572-2, VIGILANCE-VUL-33493.

Description of the vulnerability 

An attacker can trigger a buffer overflow via QUIC Decoding Code of SPICE, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat note impacts software or systems such as Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this cybersecurity note is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this vulnerability note.

Solutions for this threat 

Debian 10: new spice packages.
New packages are available:
  Debian 10: spice 0.14.0-1.3+deb10u1

Debian 9: new spice-gtk packages.
New packages are available:
  Debian 9: spice-gtk 0.33-3.3+deb9u2

Debian 9: new spice packages.
New packages are available:
  Debian 9: spice 0.12.8-2.1+deb9u4

openSUSE Leap 15.2: new spice-gtk packages.
New packages are available:
  openSUSE Leap 15.2: spice-gtk 0.37-lp152.2.3.1

openSUSE Leap 15.2: new spice packages.
New packages are available:
  openSUSE Leap 15.2: spice 0.14.2-lp152.2.3.1

RHEL 7, 8: new spice packages.
New packages are available:
  RHEL 7.9: spice 0.14.0-9.el7_9.1
  RHEL 8.1: spice 0.14.2-1.el8_1.1
  RHEL 8.2: spice 0.14.2-1.el8_2.1

RHEL 8.0: new spice packages.
New packages are available:
  RHEL 8.0: spice 0.14.0-7.el8_0.1

SUSE LE 11 SP4: new spice packages.
New packages are available:
  SUSE LE 11 SP4: spice 0.12.4-21.1

SUSE LE 12 SP2: new spice-gtk packages.
New packages are available:
  SUSE LE 12 SP2: spice-gtk 0.31-9.13.1

SUSE LE 12 SP2: new spice packages.
New packages are available:
  SUSE LE 12 SP2: spice 0.12.7-10.12.1

SUSE LE 12 SP3-5: new spice-gtk packages.
New packages are available:
  SUSE LE 12 SP3: spice-gtk 0.33-3.9.1
  SUSE LE 12 SP4: spice-gtk 0.33-3.9.1
  SUSE LE 12 SP5: spice-gtk 0.33-3.9.1

SUSE LE 12 SP3-5: new spice packages.
New packages are available:
  SUSE LE 12 SP3: spice 0.12.8-15.1
  SUSE LE 12 SP4: spice 0.12.8-15.1
  SUSE LE 12 SP5: spice 0.12.8-15.1

SUSE LE 15 RTM: new spice-gtk packages.
New packages are available:
  SUSE LE 15 RTM: spice-gtk 0.34-3.6.1

SUSE LE 15 RTM: new spice packages.
New packages are available:
  SUSE LE 15 RTM: spice 0.14.0-4.9.1

SUSE LE 15 SP1: new spice-gtk packages.
New packages are available:
  SUSE LE 15 SP1: spice-gtk 0.35-3.3.1

SUSE LE 15 SP1: new spice packages.
New packages are available:
  SUSE LE 15 SP1: spice 0.14.1-4.3.1

SUSE LE 15 SP2: new spice-gtk packages.
New packages are available:
  SUSE LE 15 SP2: spice-gtk 0.37-3.3.2

SUSE LE 15 SP2: new spice packages.
New packages are available:
  SUSE LE 15 SP2: spice 0.14.2-3.3.1

Ubuntu: new libspice-server1 packages.
New packages are available:
  Ubuntu 20.04 LTS: libspice-server1 0.14.2-4ubuntu3.1
  Ubuntu 18.04 LTS: libspice-server1 0.14.0-1ubuntu2.5
  Ubuntu 16.04 LTS: libspice-server1 0.12.6-4ubuntu0.5
  Ubuntu 14.04 ESM: libspice-server1 0.12.4-0nocelt2ubuntu1.8+esm1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides systems vulnerabilities announces. The Vigil@nce vulnerability database contains several thousand vulnerabilities.