The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of SQLite: read-write access via PRAGMA Integrity_check Comparison Operator

Synthesis of the vulnerability 

An attacker can bypass access restrictions via PRAGMA Integrity_check Comparison Operator of SQLite, in order to read or alter data.
Impacted systems: MySQL Community, MySQL Enterprise, Percona Server, SQLite.
Severity of this alert: 1/4.
Creation date: 10/12/2019.
Références of this alert: cpuapr2020, CVE-2019-19646, VIGILANCE-VUL-31103.

Description of the vulnerability 

An attacker can bypass access restrictions via PRAGMA Integrity_check Comparison Operator of SQLite, in order to read or alter data.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity announce impacts software or systems such as MySQL Community, MySQL Enterprise, Percona Server, SQLite.

Our Vigil@nce team determined that the severity of this threat alert is low.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this computer weakness alert.

Solutions for this threat 

SQLite: patch for PRAGMA Integrity_check Comparison Operator.
A patch is indicated in information sources.

Oracle MySQL: version 5.6.48.
The version 5.6.48 is fixed:
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL: version 5.7.30.
The version 5.7.30 is fixed:
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL: version 8.0.20.
The version 8.0.20 is fixed:
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Percona Server: version 5.6.48-88.0.
The version 5.6.48-88.0 is fixed.

Wind River Linux: version 10.17.41.19.
The version 10.17.41.19 is fixed.

Wind River Linux: version 10.19.45.3.
The version 10.19.45.3 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer vulnerability alert. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.