The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of SQLite: three vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of SQLite.
Vulnerable software: Debian, BIG-IP Hardware, TMOS, Fedora, Juniper EX-Series, Juniper J-Series, Junos OS, MX-Series, PTX-Series, QFX-Series, SRX-Series, Oracle Directory Services Plus, Oracle Fusion Middleware, Oracle Internet Directory, Solaris, Tuxedo, WebLogic, PHP, RHEL, Slackware, SQLite, Synology DS***, Synology RS***, Ubuntu.
Severity of this announce: 2/4.
Number of vulnerabilities in this bulletin: 3.
Creation date: 15/04/2015.
Références of this computer vulnerability: bulletinapr2016, CERTFR-2015-AVI-265, cpujul2018, CVE-2015-3414, CVE-2015-3415, CVE-2015-3416, DSA-3252-1, DSA-3252-2, FEDORA-2015-6324, FEDORA-2015-6349, JSA11055, MDVSA-2015:217, RHSA-2015:1634-01, RHSA-2015:1635-01, SOL16950, SSA:2015-198-02, USN-2698-1, VIGILANCE-VUL-16615.

Description of the vulnerability 

Several vulnerabilities were announced in SQLite.

An attacker can force a read at an invalid address in the parser of collation rules, in order to trigger a denial of service. [severity:1/4; CVE-2015-3414]

An attacker can force the usage of a freed memory area, in order to trigger a denial of service, and possibly to execute code. [severity:1/4; CVE-2015-3415]

An attacker can generate a buffer overflow in a use of printf, in order to trigger a denial of service, and possibly to execute code. [severity:2/4; CVE-2015-3416]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat bulletin impacts software or systems such as Debian, BIG-IP Hardware, TMOS, Fedora, Juniper EX-Series, Juniper J-Series, Junos OS, MX-Series, PTX-Series, QFX-Series, SRX-Series, Oracle Directory Services Plus, Oracle Fusion Middleware, Oracle Internet Directory, Solaris, Tuxedo, WebLogic, PHP, RHEL, Slackware, SQLite, Synology DS***, Synology RS***, Ubuntu.

Our Vigil@nce team determined that the severity of this security threat is medium.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 3 vulnerabilities.

An attacker with a expert ability can exploit this computer vulnerability alert.

Solutions for this threat 

SQLite: version 3.8.9.
The version 3.8.9 is fixed:
  https://www.sqlite.org/2015/sqlite-amalgamation-3080900.zip

Debian: new sqlite3 packages.
New packages are available:
  Debian 8: sqlite3 3.8.7.1-1+deb8u1
  Debian 7: sqlite3 3.7.13-1+deb7u2

F5 BIG-IP: solution for SQLite.
The solution is indicated in information sources.

Fedora: new spatialite-tools packages.
New packages are available:
  Fedora 20: spatialite-tools 4.1.1-12.fc20
  Fedora 21: spatialite-tools 4.2.0-10.fc21

Fedora: new sqlite packages.
New packages are available:
  Fedora 20: sqlite 3.8.9-1.fc20
  Fedora 21: sqlite 3.8.9-1.fc21

Junos OS: fixed versions for SQLite.
Fixed versions are indicated in information sources.

Mandriva: new sqlite3 packages.
New packages are available:
  Mandriva BS1: sqlite3 3.8.9-1.mbs1
  Mandriva BS2: sqlite3 3.8.9-1.mbs2

Oracle Fusion Middleware: CPU of July 2018.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2394520.1

PHP: version 5.4.42.
The version 5.4.42 is fixed:
  http://php.net/get/php-5.4.42.tar.bz2/from/a/mirror

PHP: version 5.5.26.
The version 5.5.26 is fixed:
  http://php.net/get/php-5.5.26.tar.bz2/from/a/mirror

PHP: version 5.6.10.
The version 5.6.10 is fixed:
  http://php.net/get/php-5.6.10.tar.bz2/from/a/mirror

RHEL: new sqlite packages.
New packages are available:
  RHEL 6: sqlite 3.6.20-1.el6_7.2
  RHEL 7: sqlite 3.7.17-6.el7_1.1

Slackware: new php packages (20/07/2015).
New packages are available:
  Slackware 14.0: php 5.4.43-*-1_slack14.0
  Slackware 14.1: php 5.4.43-*-1_slack14.1

Solaris: patch for Third Party software 04/2016.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

Synology DS214, RS214: version 5.2-5592.
The version 5.2-5592 is fixed.

Ubuntu: new libsqlite3-0 packages.
New packages are available:
  Ubuntu 15.04: libsqlite3-0 3.8.7.4-1ubuntu0.1
  Ubuntu 14.04 LTS: libsqlite3-0 3.8.2-1ubuntu2.1
  Ubuntu 12.04 LTS: libsqlite3-0 3.7.9-2ubuntu1.2
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a network vulnerability bulletin. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.