The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Samba: seven vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of Samba.
Vulnerable software: Debian, Fedora, HP-UX, openSUSE, openSUSE Leap, Solaris, RHEL, Samba, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this announce: 2/4.
Number of vulnerabilities in this bulletin: 7.
Creation date: 16/12/2015.
Références of this computer vulnerability: bulletinjan2016, c05115993, CERTFR-2015-AVI-545, CVE-2015-3223, CVE-2015-5252, CVE-2015-5296, CVE-2015-5299, CVE-2015-5330, CVE-2015-7540, CVE-2015-8467, DSA-3433-1, FEDORA-2015-0e0879cc8a, FEDORA-2015-af140eefbc, FEDORA-2015-b36076d32e, FEDORA-2015-b960ca78bf, HPSBUX03574, openSUSE-SU-2015:2354-1, openSUSE-SU-2015:2356-1, openSUSE-SU-2016:1064-1, openSUSE-SU-2016:1106-1, openSUSE-SU-2016:1107-1, openSUSE-SU-2016:1108-1, openSUSE-SU-2016:1440-1, RHSA-2016:0006-01, RHSA-2016:0009-01, RHSA-2016:0010-02, RHSA-2016:0011-01, SUSE-SU-2015:2304-1, SUSE-SU-2015:2305-1, SUSE-SU-2016:0032-1, SUSE-SU-2016:0164-1, SUSE-SU-2016:1105-1, USN-2855-1, USN-2855-2, USN-2856-1, VIGILANCE-VUL-18541.

Description of the vulnerability 

Several vulnerabilities were announced in Samba.

An attacker can create a memory leak in AD DC LDAP Server, in order to trigger a denial of service. [severity:2/4; CVE-2015-7540]

An attacker can generate an infinite loop in LDAP Server, in order to trigger a denial of service. [severity:2/4; CVE-2015-3223]

An attacker can use a symbolic link, in order to access to a file outside the shared directory. [severity:2/4; CVE-2015-5252]

An attacker can bypass security features in vfs_shadow_copy2, in order to escalate his privileges. [severity:2/4; CVE-2015-5299]

An attacker can act as a Man-in-the-Middle, in order to read or write data in the session. [severity:2/4; CVE-2015-5296]

An attacker can bypass security features in AD DC mode with a Windows DC, in order to escalate his privileges. [severity:2/4; CVE-2015-8467]

An attacker can read a memory fragment of LDAP Server, in order to obtain sensitive information. [severity:2/4; CVE-2015-5330]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability note impacts software or systems such as Debian, Fedora, HP-UX, openSUSE, openSUSE Leap, Solaris, RHEL, Samba, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this cybersecurity vulnerability is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

This bulletin is about 7 vulnerabilities.

An attacker with a expert ability can exploit this computer threat note.

Solutions for this threat 

Samba: version 4.3.3.
The version 4.3.3 is fixed:
  https://download.samba.org/pub/samba/stable/

Samba: version 4.2.7.
The version 4.2.7 is fixed:
  https://download.samba.org/pub/samba/stable/

Samba: version 4.1.22.
The version 4.1.22 is fixed:
  https://download.samba.org/pub/samba/stable/

Debian: new samba packages.
New packages are available:
  Debian 7: samba 2:3.6.6-6+deb7u6
  Debian 8: samba 2:4.1.17+dfsg-2+deb8u1

Fedora: new libldb packages.
New packages are available:
  Fedora 22: libldb 1.1.24-1.fc22
  Fedora 23: libldb 1.1.24-1.fc23

Fedora: new libtalloc packages.
New packages are available:
  Fedora 22: libtalloc 2.1.5-2.fc22
  Fedora 23: libtalloc 2.1.5-2.fc23

Fedora: new libtdb packages.
New packages are available:
  Fedora 22: libtdb 1.3.8-1.fc22
  Fedora 23: libtdb 1.3.8-1.fc23

Fedora: new libtevent packages.
New packages are available:
  Fedora 22: libtevent 0.9.26-1.fc22
  Fedora 23: libtevent 0.9.26-1.fc23

Fedora: new samba packages.
New packages are available:
  Fedora 22: samba 4.2.7-0.fc22
  Fedora 23: samba 4.3.3-0.fc23

HP-UX: CIFS-Server version A.03.02.06.
The version CIFS-Server A.03.02.06 is fixed:
  https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=B8725AA

openSUSE 11.4/13.1: new samba packages.
New packages are available:
  openSUSE 13.1: samba 4.2.4-3.54.2, apparmor 2.8.4-4.20.1
  openSUSE 11.4: samba 3.6.3-141.1

openSUSE 13.2: new samba packages.
New packages are available:
  openSUSE 13.2: samba 4.2.4-37.1

openSUSE: new samba packages.
New packages are available:
  openSUSE 13.1: samba 4.1.22-3.46.1
  openSUSE 13.2: samba 4.1.22-21.1
  openSUSE Leap 42.1: samba 4.2.4-9.2

RHEL 6.7: new samba4 packages.
New packages are available:
  RHEL 6: samba4 4.0.0-67.el6_7.rc4

RHEL: new libldb packages.
New packages are available:
  RHEL 6: libldb 1.1.13-3.el6_7.1
  RHEL 7: libldb 1.1.20-1.el7_2.2

RHEL: new samba packages.
New packages are available:
  RHEL 6: samba 3.6.23-24.el6_7
  RHEL 7: samba 4.2.3-11.el7_2

Solaris: patch for Third Party 03/2016.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 10 SP4: new samba packages.
New packages are available:
  SUSE LE 10 SP4: samba 3.0.36-0.13.32.1

SUSE LE: new samba packages.
New packages are available:
  SUSE LE 11 SP2: samba 3.6.3-45.2
  SUSE LE 11 SP3: samba 3.6.3-64.1
  SUSE LE 11 SP4: samba 3.6.3-64.1
  SUSE LE 12 RTM: samba 4.1.12-18.3.1
  SUSE LE 12 SP1: samba 4.2.4-6.1

Ubuntu: new ldb packages.
New packages are available:
  Ubuntu 15.10: libldb1 2:1.1.20-2ubuntu0.1
  Ubuntu 15.04: libldb1 1:1.1.18-1ubuntu0.1
  Ubuntu 14.04 LTS: libldb1 1:1.1.16-1ubuntu0.1
  Ubuntu 12.04 LTS: libldb1 1:1.1.4-1ubuntu0.1

Ubuntu: new samba packages.
New packages are available:
  Ubuntu 15.10: samba 2:4.1.17+dfsg-4ubuntu3.2
  Ubuntu 15.04: samba 2:4.1.13+dfsg-4ubuntu3.1
  Ubuntu 14.04 LTS: samba 2:4.1.6+dfsg-1ubuntu2.14.04.12
  Ubuntu 12.04 LTS: samba 2:3.6.3-2ubuntu2.14

Wind River Linux: solution (21/05/2019).
The solution is indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computers vulnerabilities bulletin. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.