The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Samba: two vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of Samba.
Vulnerable systems: Debian, Fedora, HP-UX, Db2 UDB, openSUSE, openSUSE Leap, RHEL, Samba, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this threat: 2/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 08/03/2016.
Références of this weakness: 1986595, c05121842, CERTFR-2016-AVI-084, CVE-2015-7560, CVE-2016-0771, DSA-3514-1, FEDORA-2016-cad77a4576, FEDORA-2016-ed1587f6ba, HPSBUX03596, openSUSE-SU-2016:0813-1, openSUSE-SU-2016:0877-1, openSUSE-SU-2016:1064-1, openSUSE-SU-2016:1106-1, openSUSE-SU-2016:1107-1, openSUSE-SU-2016:1108-1, openSUSE-SU-2016:1440-1, RHSA-2016:0448-01, RHSA-2016:0449-01, SSA:2016-068-02, SUSE-SU-2016:0814-1, SUSE-SU-2016:0816-1, SUSE-SU-2016:0837-1, SUSE-SU-2016:0905-1, USN-2922-1, VIGILANCE-VUL-19118.

Description of the vulnerability 

Several vulnerabilities were announced in Samba.

An attacker can create a symbolic link, in order to alter ACLs. [severity:2/4; CVE-2015-7560]

An attacker can force a read at an invalid address with a DNS TXT record sent to the internal DNS server in AC DC mode, in order to trigger a denial of service. [severity:2/4; CVE-2016-0771]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity threat impacts software or systems such as Debian, Fedora, HP-UX, Db2 UDB, openSUSE, openSUSE Leap, RHEL, Samba, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat note is medium.

The trust level is of type confirmed by the editor, with an origin of user account.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this security threat.

Solutions for this threat 

Samba: version 4.3.6.
The version 4.3.6 is fixed:
  https://download.samba.org/pub/samba/stable/

Samba: version 4.2.9.
The version 4.2.9 is fixed:
  https://download.samba.org/pub/samba/stable/

Samba: version 4.1.23.
The version 4.1.23 is fixed:
  https://download.samba.org/pub/samba/stable/

Debian: new samba packages.
New packages are available:
  Debian 7: samba 2:3.6.6-6+deb7u7
  Debian 8: samba 2:4.1.17+dfsg-2+deb8u2

Fedora: new samba packages.
New packages are available:
  Fedora 22: samba 4.2.9-0.fc22
  Fedora 23: samba 4.3.6-0.fc23

HP-UX: solution for CIFS Server.
The solution is indicated in information sources.

IBM DB2: solution.
The solution is indicated in information sources.

openSUSE 11.4/13.1: new samba packages.
New packages are available:
  openSUSE 13.1: samba 4.2.4-3.54.2, apparmor 2.8.4-4.20.1
  openSUSE 11.4: samba 3.6.3-141.1

openSUSE 13.2: new samba packages.
New packages are available:
  openSUSE 13.2: samba 4.2.4-37.1

openSUSE: new samba packages.
New packages are available:
  openSUSE 13.2: samba 4.1.23-31.1
  openSUSE Leap 42.1: samba 4.2.4-12.1

RHEL 6.7: new samba4 packages.
New packages are available:
  RHEL 6: samba4 4.0.0-68.el6_7.rc4

RHEL: new samba packages.
New packages are available:
  RHEL 6: samba 3.6.23-25.el6_7
  RHEL 7: samba 4.2.3-12.el7_2

Slackware: new samba packages.
New packages are available:
  Slackware 14.1: samba 4.1.23-*-1_slack14.1

SUSE LE: new samba packages.
New packages are available:
  SUSE LE 11 SP2: samba 3.6.3-48.2
  SUSE LE 11 SP4: samba 3.6.3-67.2
  SUSE LE 12 RTM: samba 4.1.12-18.8.1
  SUSE LE 12 SP1: samba 4.2.4-11.1

Ubuntu: new samba packages.
New packages are available:
  Ubuntu 15.10: samba 2:4.1.17+dfsg-4ubuntu3.3
  Ubuntu 14.04 LTS: samba 2:4.1.6+dfsg-1ubuntu2.14.04.13
  Ubuntu 12.04 LTS: samba 2:3.6.3-2ubuntu2.17
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a cybersecurity watch. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.