The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Simple DirectMedia Layer: multiple vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of Simple DirectMedia Layer.
Impacted systems: Debian, Fedora, openSUSE Leap, SLES, Ubuntu.
Severity of this alert: 2/4.
Number of vulnerabilities in this bulletin: 7.
Creation date: 23/07/2019.
Références of this alert: CVE-2019-12216, CVE-2019-12217, CVE-2019-12218, CVE-2019-12219, CVE-2019-12220, CVE-2019-12221, CVE-2019-12222, DLA-1861-1, DLA-1865-1, FEDORA-2019-a6bc0fb143, openSUSE-SU-2019:2070-1, openSUSE-SU-2019:2108-1, USN-4238-1, VIGILANCE-VUL-29855.

Description of the vulnerability 

An attacker can use several vulnerabilities of Simple DirectMedia Layer.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability impacts software or systems such as Debian, Fedora, openSUSE Leap, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this security announce is medium.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 7 vulnerabilities.

An attacker with a expert ability can exploit this computer vulnerability note.

Solutions for this threat 

Debian 8: new libsdl2-image packages.
New packages are available:
  Debian 8: libsdl2-image 2.0.0+dfsg-3+deb8u2

Debian 9: new sdl-image1.2 packages.
New packages are available:
  Debian 9: sdl-image1.2 1.2.12-5+deb9u2

Fedora 29: new SDL2_image packages.
New packages are available:
  Fedora 29: SDL2_image 2.0.5-2.fc29

openSUSE Leap 15: new SDL2_image packages.
New packages are available:
  openSUSE Leap 15.0: SDL2_image 2.0.5-lp150.9.1
  openSUSE Leap 15.1: SDL2_image 2.0.5-lp151.2.5.1

SUSE LE 15: new SDL2_image packages.
New packages are available:
  SUSE LE 15 RTM: SDL2_image 2_0-0-2.0.5-bp150.3.6.1
  SUSE LE 15 SP1: SDL2_image 2.0.5-bp151.4.3.1

Ubuntu: new libsdl-image1.2 packages.
New packages are available:
  Ubuntu 18.04 LTS: libsdl-image1.2 1.2.12-8ubuntu0.1
  Ubuntu 16.04 LTS: libsdl-image1.2 1.2.12-5+deb9u1ubuntu0.16.04.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability bulletins. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.