The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Slurm: privilege escalation via Message Aggregation

Synthesis of the vulnerability 

An attacker can bypass restrictions via Message Aggregation of Slurm, in order to escalate his privileges.
Impacted software: Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES.
Severity of this computer vulnerability: 2/4.
Creation date: 03/06/2020.
Références of this announce: CVE-2020-12693, FEDORA-2020-11d0cf302f, FEDORA-2020-e95ef17134, openSUSE-SU-2020:1421-1, openSUSE-SU-2020:1468-1, openSUSE-SU-2020:1969-1, SUSE-SU-2020:2598-1, SUSE-SU-2020:2599-1, SUSE-SU-2020:2600-1, SUSE-SU-2020:2601-1, SUSE-SU-2020:2602-1, SUSE-SU-2020:2607-1, VIGILANCE-VUL-32392.

Description of the vulnerability 

An attacker can bypass restrictions via Message Aggregation of Slurm, in order to escalate his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability impacts software or systems such as Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this weakness bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this weakness.

Solutions for this threat 

Fedora 31-32: new slurm packages.
New packages are available:
  Fedora 31: slurm 19.05.7-1.fc31
  Fedora 32: slurm 19.05.7-1.fc32

openSUSE Leap 15.1: new slurm_18_08 packages.
New packages are available:
  openSUSE Leap 15.1: slurm 18.08.9-lp151.2.1

openSUSE Leap 15.1: new slurm packages.
New packages are available:
  openSUSE Leap 15.1: slurm 18.08.9-lp151.2.10.1

openSUSE Leap 15.2: new slurm packages.
New packages are available:
  openSUSE Leap 15.2: slurm 18.08.9-lp152.2.1

SUSE LE 12: new slurm_18_08 packages.
New packages are available:
  SUSE LE 12 RTM-SP5: slurm_18_08 18.08.9-3.8.1

SUSE LE 12: new slurm_20_02 packages.
New packages are available:
  SUSE LE 12 RTM: slurm_20_02 20.02.3-3.5.1

SUSE LE 12: new slurm packages (11/09/2020).
New packages are available:
  SUSE LE 12 RTM-SP5: slurm 17.02.11-6.44.1

SUSE LE 15 RTM: new slurm_18_08 packages.
New packages are available:
  SUSE LE 15 RTM: slurm_18_08 18.08.9-1.8.2

SUSE LE 15 RTM-SP1: new slurm packages.
New packages are available:
  SUSE LE 15 RTM: slurm 17.11.13-6.31.1
  SUSE LE 15 SP1: slurm 18.08.9-3.13.2
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an applications vulnerabilities watch. The Vigil@nce vulnerability database contains several thousand vulnerabilities.