The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of TigerVNC: multiple vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of TigerVNC.
Vulnerable software: Debian, openSUSE Leap, Solaris, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (platform) ~ not comprehensive.
Severity of this announce: 2/4.
Number of vulnerabilities in this bulletin: 6.
Creation date: 23/12/2019.
Références of this computer vulnerability: CVE-2019-15690, CVE-2019-15691, CVE-2019-15692, CVE-2019-15693, CVE-2019-15694, CVE-2019-15695, DLA-2146-1, openSUSE-SU-2020:0087-1, openSUSE-SU-2020:0624-1, RHSA-2020:0913-01, RHSA-2020:0920-01, RHSA-2020:0921-01, RHSA-2020:1497-01, RHSA-2020:3875-01, SSA:2019-354-02, SUSE-SU-2020:0112-1, SUSE-SU-2020:0113-1, SUSE-SU-2020:0159-1, SUSE-SU-2020:0266-1, SUSE-SU-2020:1164-1, SUSE-SU-2020:1164-2, SUSE-SU-2020:1165-1, SUSE-SU-2020:14355-1, SUSE-SU-2020:1749-1, USN-4407-1, VIGILANCE-VUL-31231.

Description of the vulnerability 

An attacker can use several vulnerabilities of TigerVNC.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability alert impacts software or systems such as Debian, openSUSE Leap, Solaris, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (platform) ~ not comprehensive.

Our Vigil@nce team determined that the severity of this computer threat alert is medium.

The trust level is of type confirmed by the editor, with an origin of intranet server.

This bulletin is about 6 vulnerabilities.

An attacker with a expert ability can exploit this security vulnerability.

Solutions for this threat 

TigerVNC: version 1.10.1.
The version 1.10.1 is fixed:
  https://github.com/TigerVNC/tigervnc/releases/tag/v1.10.1

Debian 8: new libvncserver packages.
New packages are available:
  Debian 8: libvncserver 0.9.9+dfsg2-6.1+deb8u7

openSUSE Leap 15.1: new LibVNCServer packages.
New packages are available:
  openSUSE Leap 15.1: libvncclient0 0.9.10-lp151.7.3.1, libvncserver0 0.9.10-lp151.7.3.1

openSUSE Leap 15.1: new tigervnc packages.
New packages are available:
  openSUSE Leap 15.1: tigervnc 1.9.0-lp151.4.3.1

Oracle Solaris: patch for third party software of April 2020 v2.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7.7: new libvncserver packages.
New packages are available:
  RHEL 7.7: libvncserver 0.9.9-14.el7_7

RHEL 7.8: new tigervnc packages.
New packages are available:
  RHEL 7.0-7.8: tigervnc 1.8.0-21.el7

RHEL 8.0: new libvncserver packages.
New packages are available:
  RHEL 8.0: libvncserver 0.9.11-9.el8_0.2

RHEL 8.1: new libvncserver packages.
New packages are available:
  RHEL 8.1: libvncserver 0.9.11-9.el8_1.2

RHEL 8.1: new tigervnc packages.
New packages are available:
  RHEL 8.1: tigervnc 1.9.0-14.el8_1

Slackware: new tigervnc packages.
New packages are available:
  Slackware 14.2: tigervnc 1.10.1-*-1_slack14.2

SUSE LE 12 SP1: new tigervnc packages.
New packages are available:
  SUSE LE 12 SP1: tigervnc 1.4.3-25.11.1

SUSE LE 12 SP2/3: new tigervnc packages.
New packages are available:
  SUSE LE 12 SP2: tigervnc 1.6.0-18.28.1
  SUSE LE 12 SP3: tigervnc 1.6.0-18.28.1

SUSE LE 12 SP4-5: new tigervnc packages.
New packages are available:
  SUSE LE 12 SP4: tigervnc 1.6.0-22.14.1
  SUSE LE 12 SP5: tigervnc 1.6.0-22.14.1

SUSE LE 15: new tigervnc packages.
New packages are available:
  SUSE LE 15 RTM: tigervnc 1.8.0-13.11.1
  SUSE LE 15 SP1: tigervnc 1.9.0-19.3.1

SUSE LE 15 SP1: new LibVNCServer packages.
New packages are available:
  SUSE LE 15 SP1: LibVNCServer 0.9.10-4.14.1

SUSE LE: new LibVNCServer packages.
New packages are available:
  SUSE LE 15 SP2: libvncclient0 0.9.10-4.14.1, libvncserver0 0.9.10-4.14.1
  SUSE LE 15 SP1: libvncclient0 0.9.10-4.14.1, libvncserver0 0.9.10-4.14.1
  SUSE LE 12 SP5: libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 12 SP4: libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 12 SP3: libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 12 SP2: libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 12 SP1: libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 11 SP4: LibVNCServer 0.9.1-160.14.1

Ubuntu: new LibVNCServer packages.
New packages are available:
  Ubuntu 20.04 LTS: libvncclient1 0.9.12+dfsg-9ubuntu0.1, libvncserver1 0.9.12+dfsg-9ubuntu0.1
  Ubuntu 19.10: libvncclient1 0.9.11+dfsg-1.3ubuntu0.1, libvncserver1 0.9.11+dfsg-1.3ubuntu0.1
  Ubuntu 18.04 LTS: libvncclient1 0.9.11+dfsg-1ubuntu1.2, libvncserver1 0.9.11+dfsg-1ubuntu1.2
  Ubuntu 16.04 LTS: libvncclient1 0.9.10+dfsg-3ubuntu0.16.04.4, libvncserver1 0.9.10+dfsg-3ubuntu0.16.04.4

Wind River Linux: version 10.17.41.20.
The version 10.17.41.20 is fixed:
  https://support2.windriver.com/

Wind River Linux: version 10.19.45.4.
The version 10.19.45.4 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer vulnerability watch. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.