The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Vim: code execution via Source Commande Modeline

Synthesis of the vulnerability 

An attacker can use a vulnerability via Source Commande Modeline of Vim, in order to run code.
Impacted products: Debian, BIG-IP Hardware, TMOS, Fedora, Junos Space, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (platform) ~ not comprehensive.
Severity of this bulletin: 3/4.
Creation date: 11/06/2019.
Références of this threat: bulletinjul2019, CERTFR-2019-AVI-267, CVE-2019-12735, DLA-1871-1, DSA-4467-1, DSA-4467-2, DSA-4487-1, FEDORA-2019-d79f89346c, FEDORA-2019-dcd49378b8, JSA10993, K93144355, openSUSE-SU-2019:1551-1, openSUSE-SU-2019:1561-1, openSUSE-SU-2019:1562-1, openSUSE-SU-2019:1759-1, openSUSE-SU-2019:1997-1, RHBUG-1718308, RHSA-2019:1619-01, RHSA-2019:1774-01, RHSA-2019:1793-01, SUSE-SU-2019:14078-1, SUSE-SU-2019:1456-1, SUSE-SU-2019:1457-1, USN-4016-1, USN-4016-2, VIGILANCE-VUL-29493.

Description of the vulnerability 

An attacker can use a vulnerability via Source Commande Modeline of Vim, in order to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity alert impacts software or systems such as Debian, BIG-IP Hardware, TMOS, Fedora, Junos Space, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (platform) ~ not comprehensive.

Our Vigil@nce team determined that the severity of this weakness is important.

The trust level is of type confirmed by the editor, with an origin of document.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this security weakness.

Solutions for this threat 

Vim: version 8.1.1365.
The version 8.1.1365 is fixed:
  https://github.com/vim/vim/releases/tag/v8.1.1365

Vim: patch for Source Commande Modeline.
A patch is available:
  https://github.com/vim/vim/commit/53575521406739cf20bbe4e384d88e7dca11f040

Debian 8: new vim packages.
New packages are available:
  Debian 8: vim 2:7.4.488-7+deb8u4

Debian 9: new neovim packages.
New packages are available:
  Debian 9: neovim 0.1.7-4+deb9u1

Debian 9: new vim packages.
New packages are available:
  Debian 9: vim 8.0.0197-4+deb9u3

Fedora: new vim packages.
New packages are available:
  Fedora 29: vim 8.1.1471-1.fc29
  Fedora 30: vim 8.1.1471-1.fc30

Junos Space: version 19.4R1.
The version 19.4R1 is fixed:
  https://www.juniper.net/support/downloads/

openSUSE Leap: new neovim packages (14/06/2019).
New packages are available:
  openSUSE Leap 42.3: neovim 0.2.0-6.1
  openSUSE Leap 15.0: neovim 0.3.1-lp150.7.1
  openSUSE Leap 15.1: neovim 0.3.5-lp151.2.3.1

openSUSE Leap: new neovim packages (22/07/2019).
New packages are available:
  openSUSE Leap 15.0: neovim 0.3.7-lp150.13.1
  openSUSE Leap 15.1: neovim 0.3.7-lp151.2.7.1

openSUSE Leap: new vim packages.
New packages are available:
  openSUSE Leap 42.3: vim 7.4.326-13.4.1
  openSUSE Leap 15.0: vim 8.0.1568-lp150.4.3.1
  openSUSE Leap 15.1: vim 8.0.1568-lp151.5.3.1

Oracle Solaris: patch for third party software of July 2019 v2.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 6.10: new vim packages.
New packages are available:
  RHEL 6: vim 7.4.629-5.el6_10.2

RHEL 7.5: new vim packages.
New packages are available:
  RHEL 7: vim 7.4.160-4.el7_5.1

RHEL: new vim packages.
New packages are available:
  RHEL 7: vim 7.4.160-6.el7_6
  RHEL 8: vim 8.0.1763-11.el8_0

SUSE LE 15 SP1: new neovim packages.
New packages are available:
  SUSE LE 15 SP1: neovim 0.3.7-bp151.3.3.1

SUSE LE: new vim packages.
New packages are available:
  SUSE LE 11 SP3: vim 7.2-8.21.3.1
  SUSE LE 11 SP4: vim 7.2-8.21.3.1
  SUSE LE 12 RTM: vim 7.4.326-17.3.1
  SUSE LE 12 SP1: vim 7.4.326-17.3.1
  SUSE LE 12 SP2: vim 7.4.326-17.3.1
  SUSE LE 12 SP3: vim 7.4.326-17.3.1
  SUSE LE 12 SP4: vim 7.4.326-17.3.1
  SUSE LE 15 RTM: vim 8.0.1568-5.3.1
  SUSE LE 15 SP1: vim 8.0.1568-5.3.1

Ubuntu: new neovim packages.
New packages are available:
  Ubuntu 19.04: neovim 0.3.4-1ubuntu0.19.04.1
  Ubuntu 18.10: neovim 0.3.1-1ubuntu0.1

Ubuntu: new vim packages (12/06/2019).
New packages are available:
  Ubuntu 19.04: vim 2:8.1.0320-1ubuntu3.1
  Ubuntu 18.10: vim 2:8.0.1766-1ubuntu1.1
  Ubuntu 18.04 LTS: vim 2:8.0.1453-1ubuntu1.1
  Ubuntu 16.04 LTS: vim 2:7.4.1689-3ubuntu1.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides software vulnerability bulletins. The technology watch team tracks security threats targeting the computer system.