The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Wireshark: multiple vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of Wireshark.
Impacted products: Debian, Fedora, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Wireshark.
Severity of this bulletin: 2/4.
Number of vulnerabilities in this bulletin: 11.
Creation date: 19/07/2018.
Références of this threat: bulletinjul2018, CERTFR-2018-AVI-354, CVE-2018-14339, CVE-2018-14340, CVE-2018-14341, CVE-2018-14342, CVE-2018-14343, CVE-2018-14344, CVE-2018-14364, CVE-2018-14367, CVE-2018-14368, CVE-2018-14369, CVE-2018-14370, DLA-1451-1, FEDORA-2018-9ef52861b5, FEDORA-2018-d56c428f9e, openSUSE-SU-2018:2184-1, openSUSE-SU-2018:2188-1, openSUSE-SU-2020:0362-1, SUSE-SU-2018:2301-1, SUSE-SU-2018:2412-1, SUSE-SU-2018:2891-1, VIGILANCE-VUL-26799, wnpa-sec-2018-34, wnpa-sec-2018-35, wnpa-sec-2018-36, wnpa-sec-2018-37, wnpa-sec-2018-38, wnpa-sec-2018-39, wnpa-sec-2018-40, wnpa-sec-2018-41, wnpa-sec-2018-42, wnpa-sec-2018-43.

Description of the vulnerability 

An attacker can use several vulnerabilities of Wireshark.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer weakness alert impacts software or systems such as Debian, Fedora, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Wireshark.

Our Vigil@nce team determined that the severity of this weakness note is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

This bulletin is about 11 vulnerabilities.

An attacker with a expert ability can exploit this weakness bulletin.

Solutions for this threat 

Wireshark: version 2.6.2.
The version 2.6.2 is fixed:
  https://www.wireshark.org/download.html

Wireshark: version 2.4.8.
The version 2.4.8 is fixed:
  https://www.wireshark.org/download.html

Wireshark: version 2.2.16.
The version 2.2.16 is fixed:
  https://www.wireshark.org/download.html

Debian 8: new wireshark packages.
New packages are available:
  Debian 8: wireshark 1.12.1+g01b65bf-4+deb8u15

Fedora: new wireshark packages.
New packages are available:
  Fedora 27: wireshark 2.6.2-1.fc27
  Fedora 28: wireshark 2.6.2-1.fc28

openSUSE Leap 15.0: new wireshark packages.
New packages are available:
  openSUSE Leap 15.0: wireshark 2.4.8-lp150.2.6.1

openSUSE Leap 15.1: new wireshark packages.
New packages are available:
  openSUSE Leap 15.1: wireshark 3.2.2-lp151.2.9.1

openSUSE Leap 42.3: new wireshark packages (06/08/2018).
New packages are available:
  openSUSE Leap 42.3: wireshark 2.2.16-44.1

Oracle Solaris: patch for third party software of July 2018 v2.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 11 SP4: new wireshark packages.
New packages are available:
  SUSE LE 11 SP4: wireshark 2.2.16-40.28.1

SUSE LE 12: new wireshark packages.
New packages are available:
  SUSE LE 12 SP1: wireshark 2.4.9-48.29.1
  SUSE LE 12 RTM: wireshark 2.4.9-48.29.1
  SUSE LE 12 SP2: wireshark 2.4.9-48.29.1
  SUSE LE 12 SP3: wireshark 2.4.9-48.29.1

SUSE LE 15: new wireshark packages.
New packages are available:
  SUSE LE 15 RTM: wireshark 2.4.8-3.6.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a system vulnerability patch. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.