The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Xen, Linux: assertion error via Linux Mapping Error

Synthesis of the vulnerability 

An attacker, inside a guest system, can force an assertion error via Linux Mapping Error of Xen, in order to trigger a denial of service on the host system.
Vulnerable products: XenServer, Debian, Fedora, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this weakness: 2/4.
Creation date: 16/02/2021.
Références of this bulletin: CERTFR-2021-AVI-152, CERTFR-2021-AVI-185, CERTFR-2021-AVI-191, CERTFR-2021-AVI-264, CERTFR-2021-AVI-265, CERTFR-2021-AVI-278, CERTFR-2021-AVI-372, CTX296603, CVE-2021-26931, DLA-2586-1, DLA-2610-1, FEDORA-2021-7143aca8cb, FEDORA-2021-8d45d297c6, openSUSE-SU-2021:0393-1, SUSE-SU-2021:0735-1, SUSE-SU-2021:0736-1, SUSE-SU-2021:0737-1, SUSE-SU-2021:0738-1, SUSE-SU-2021:0740-1, SUSE-SU-2021:0741-1, SUSE-SU-2021:0743-1, SUSE-SU-2021:0744-1, SUSE-SU-2021:1175-1, SUSE-SU-2021:1176-1, SUSE-SU-2021:1210-1, USN-4904-1, USN-4909-1, USN-4946-1, USN-4949-1, VIGILANCE-VUL-34590, XSA-362.

Description of the vulnerability 

An attacker, inside a guest system, can force an assertion error via Linux Mapping Error of Xen, in order to trigger a denial of service on the host system.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness note impacts software or systems such as XenServer, Debian, Fedora, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat note is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this computer weakness.

Solutions for this threat 

Xen, Linux: patch for Linux Mapping Error.
A patch is available:
  http://xenbits.xen.org/xsa/xsa362-linux-1.patch
  http://xenbits.xen.org/xsa/xsa362-linux-2.patch
  http://xenbits.xen.org/xsa/xsa362-linux-3.patch

Citrix Hypervisor: patch.
A patch is available:
  Citrix Hypervisor 8.2 LTSR: CTX294145 - https://support.citrix.com/article/CTX294145
  Citrix Hypervisor 7.1 LTSR: CTX294143 - https://support.citrix.com/article/CTX294143
  Citrix Hypervisor 7.0: CTX294141 - https://support.citrix.com/article/CTX294141

Debian 9: new linux-4.19 packages.
New packages are available:
  Debian 9: linux-4.19 4.19.181-1~deb9u1

Debian 9: new linux packages.
New packages are available:
  Debian 9: linux 4.9.258-1

Fedora 32-33: new kernel packages.
New packages are available:
  Fedora 32: kernel 5.10.18-100.fc32
  Fedora 33: kernel 5.10.18-200.fc33

openSUSE Leap 15.2: new kernel packages.
New packages are available:
  openSUSE Leap 15.2: kernel 5.3.18-lp152.66.2

SUSE LE 12 SP2: new kernel packages.
New packages are available:
  SUSE LE 12 SP2: kernel 4.4.121-92.152.2

SUSE LE 12 SP3: new kernel packages.
New packages are available:
  SUSE LE 12 SP3: kernel 4.4.180-94.141.2

SUSE LE 12 SP4: new kernel packages.
New packages are available:
  SUSE LE 12 SP4: kernel 4.12.14-95.71.1

SUSE LE 12 SP5: new kernel-azure packages.
New packages are available:
  SUSE LE 12 SP5: kernel-azure 4.12.14-16.50.1

SUSE LE 12 SP5: new kernel packages (16/04/2021).
New packages are available:
  SUSE LE 12 SP5: kernel 4.12.14-122.66.2

SUSE LE 12 SP5: new kernel-rt packages.
New packages are available:
  SUSE LE 12 SP5: kernel-rt 4.12.14-10.37.1

SUSE LE 15 RTM: new kernel packages.
New packages are available:
  SUSE LE 15 RTM: kernel 4.12.14-150.69.1

SUSE LE 15 SP1: new kernel packages.
New packages are available:
  SUSE LE 15 SP1: kernel 4.12.14-197.86.1

SUSE LE 15 SP2: new kernel-azure packages.
New packages are available:
  SUSE LE 15 SP2: kernel-azure 5.3.18-18.38.1

SUSE LE 15 SP2: new kernel packages.
New packages are available:
  SUSE LE 15 SP2: kernel 5.3.18-24.52.1

SUSE LE 15 SP2: new kernel-rt packages.
New packages are available:
  SUSE LE 15 SP2: kernel-rt 5.3.18-28.1

Ubuntu: new linux-image-4.15.0 packages.
New packages are available, as indicated in information sources.

Ubuntu: new linux-image-4.4.0 packages (14/04/2021).
New packages are available:
  Ubuntu 14.04 ESM: linux-image-generic-lts-xenial 4.4.0.208.181
  Ubuntu 16.04 LTS: linux-image-generic 4.4.0.208.214

Ubuntu: new linux-image-5.4.0 packages.
New packages are available:
  Ubuntu 18.04 LTS: linux-image-generic-hwe-18.04 5.4.0.71.79~18.04.64
  Ubuntu 20.04 LTS: linux-image-generic 5.4.0.71.74

Ubuntu: new linux-image-5.8.0 packages.
New packages are available, as indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an applications vulnerabilities watch. The Vigil@nce vulnerability database contains several thousand vulnerabilities.