The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Xen: memory corruption via PCI Devices Deassignment

Synthesis of the vulnerability 

An attacker, inside a guest system, can trigger a memory corruption via PCI Devices Deassignment of Xen, in order to trigger a denial of service, and possibly to run code on the host system.
Impacted software: XenServer, Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Xen.
Severity of this computer vulnerability: 2/4.
Creation date: 31/10/2019.
Références of this announce: CERTFR-2019-AVI-541, CERTFR-2019-AVI-543, CTX263477, CVE-2019-18424, DSA-4602-1, FEDORA-2019-865bb16900, FEDORA-2019-cbb732f760, openSUSE-SU-2019:2506-1, SUSE-SU-2019:2960-1, SUSE-SU-2019:2961-1, SUSE-SU-2019:2962-1, SUSE-SU-2019:3297-1, SUSE-SU-2019:3310-1, SUSE-SU-2020:0334-1, SUSE-SU-2020:0388-1, SUSE-SU-2020:14444-1, VIGILANCE-VUL-30760, XSA-302.

Description of the vulnerability 

An attacker, inside a guest system, can trigger a memory corruption via PCI Devices Deassignment of Xen, in order to trigger a denial of service, and possibly to run code on the host system.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability bulletin impacts software or systems such as XenServer, Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Xen.

Our Vigil@nce team determined that the severity of this security note is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this cybersecurity note.

Solutions for this threat 

Xen: version 4.12.2.
The version 4.12.2 is fixed:
  http://xenbits.xen.org/gitweb/?p=xen.git;a=shortlog;h=refs/heads/stable-4.12
  https://xenproject.org/downloads/xen-project-archives/xen-project-4-12-series/xen-project-4-12-2/

Xen: version 4.11.3.
The version 4.11.3 is fixed:
  http://xenbits.xen.org/gitweb/?p=xen.git;a=shortlog;h=refs/heads/stable-4.11
  https://xenproject.org/downloads/xen-project-archives/xen-project-4-11-series/xen-project-4-11-3/

Xen: patch for PCI Devices Deassignment.
A patch is available:
  http://xenbits.xen.org/xsa/xsa302.meta
  http://xenbits.xen.org/xsa/xsa302-4.9/0001-IOMMU-add-missing-HVM-check.patch
  http://xenbits.xen.org/xsa/xsa302-4.9/0002-passthrough-quarantine-PCI-devices.patch
  http://xenbits.xen.org/xsa/xsa302-4.10/0001-IOMMU-add-missing-HVM-check.patch
  http://xenbits.xen.org/xsa/xsa302-4.10/0002-passthrough-quarantine-PCI-devices.patch
  http://xenbits.xen.org/xsa/xsa302-4.11/0001-IOMMU-add-missing-HVM-check.patch
  http://xenbits.xen.org/xsa/xsa302-4.11/0002-passthrough-quarantine-PCI-devices.patch
  http://xenbits.xen.org/xsa/xsa302-4.12/0001-IOMMU-add-missing-HVM-check.patch
  http://xenbits.xen.org/xsa/xsa302-4.12/0002-passthrough-quarantine-PCI-devices.patch
  http://xenbits.xen.org/xsa/xsa302/0001-passthrough-quarantine-PCI-devices.patch

Citrix Hypervisor, XenServer: patch.
A patch is available:
  Citrix Hypervisor 8.0
  CTX262555 - https://support.citrix.com/article/CTX262555
  CTX258428 - https://support.citrix.com/article/CTX258428
  Citrix XenServer 7.6
  CTX262554 - https://support.citrix.com/article/CTX262554
  CTX258425 - https://support.citrix.com/article/CTX258425
  Citrix XenServer 7.1 LTSR CU2
  CTX262553 - https://support.citrix.com/article/CTX262553
  CTX258424 - https://support.citrix.com/article/CTX258424
  Citrix XenServer 7.0
  CTX258417 - https://support.citrix.com/article/CTX258417
  CTX258423 - https://support.citrix.com/article/CTX258423

Debian 9/10: new xen packages.
New packages are available:
  Debian 9: xen 4.8.5.final+shim4.10.4-1+deb9u12
  Debian 10: xen 4.11.3+24-g14b62ab3e5-1~deb10u1

Fedora 29: new xen packages.
New packages are available:
  Fedora 29: xen 4.11.2-2.fc29

Fedora 30: new xen packages.
New packages are available:
  Fedora 30: xen 4.11.2-3.fc30

openSUSE Leap 15.0: new xen packages.
New packages are available:
  openSUSE Leap 15.0: xen 4.10.4_06-lp150.2.25.1

SUSE LE 12 SP1: new xen packages.
New packages are available:
  SUSE LE 12 SP1: xen 4.5.5_28-22.64.1

SUSE LE 12 SP2: new xen packages.
New packages are available:
  SUSE LE 12 SP2: xen 4.7.6_06-43.59.1

SUSE LE 12 SP3: new xen packages (16/12/2019).
New packages are available:
  SUSE LE 12 SP3: xen 4.9.4_06-3.59.1

SUSE LE 12 SP4: new xen packages (05/08/2020).
New packages are available:
  SUSE LE 11 SP4: xen 4.4.4_42-61.52.1

SUSE LE 12 SP4: new xen packages (13/11/2019).
New packages are available:
  SUSE LE 12 SP4: xen 4.11.2_04-2.17.1

SUSE LE 12 SP4: new xen packages (18/12/2019).
New packages are available:
  SUSE LE 12 SP4: xen 4.11.3_02-2.20.1

SUSE LE 15 RTM: new xen packages.
New packages are available:
  SUSE LE 15 RTM: xen 4.10.4_06-3.25.1

SUSE LE 15 SP1: new xen packages.
New packages are available:
  SUSE LE 15 SP1: xen 4.12.1_04-3.6.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer vulnerability watch. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.