The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of XnView Classic: memory corruption via JB2

Synthesis of the vulnerability 

An attacker can generate a memory corruption via JB2 of XnView Classic, in order to trigger a denial of service, and possibly to run code.
Vulnerable systems: XnView.
Severity of this threat: 2/4.
Number of vulnerabilities in this bulletin: 16.
Creation date: 12/09/2017.
Références of this weakness: CVE-2017-14270, CVE-2017-14271, CVE-2017-14272, CVE-2017-14273, CVE-2017-14274, CVE-2017-14275, CVE-2017-14276, CVE-2017-14277, CVE-2017-14278, CVE-2017-14279, CVE-2017-14280, CVE-2017-14281, CVE-2017-14282, CVE-2017-14283, CVE-2017-14284, CVE-2017-14285, VIGILANCE-VUL-23810.

Description of the vulnerability 

An attacker can generate a memory corruption via JB2 of XnView Classic, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness note impacts software or systems such as XnView.

Our Vigil@nce team determined that the severity of this threat note is medium.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 16 vulnerabilities.

An attacker with a expert ability can exploit this computer weakness.

Solutions for this threat 

Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides systems vulnerabilities bulletins. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.