The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of e2fsprogs: buffer overflow via e2fsck directory rehashing

Synthesis of the vulnerability 

An attacker can trigger a buffer overflow via e2fsck directory rehashing of e2fsprogs, in order to trigger a denial of service, and possibly to run code.
Impacted systems: Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 1/4.
Creation date: 21/01/2020.
Références of this alert: CVE-2019-5188, DLA-2156-1, FEDORA-2020-01ed02451f, FEDORA-2020-a724cc7926, openSUSE-SU-2020:0166-1, SUSE-SU-2020:0265-1, SUSE-SU-2020:0360-1, USN-4249-1, VIGILANCE-VUL-31379.

Description of the vulnerability 

An attacker can trigger a buffer overflow via e2fsck directory rehashing of e2fsprogs, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security note impacts software or systems such as Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat announce is low.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this computer weakness announce.

Solutions for this threat 

Debian 8: new e2fsprogs packages.
New packages are available:
  Debian 8: e2fsprogs 1.42.12-2+deb8u2

Fedora: new e2fsprogs packages.
New packages are available:
  Fedora 30: e2fsprogs 1.44.6-2.fc30
  Fedora 31: e2fsprogs 1.45.5-1.fc31

openSUSE Leap 15.1: new e2fsprogs packages.
New packages are available:
  openSUSE Leap 15.1: e2fsprogs 1.43.8-lp151.5.12.1

SUSE LE 12 SP4/5: new e2fsprogs packages.
New packages are available:
  SUSE LE 12 SP4: e2fsprogs 1.43.8-3.11.1
  SUSE LE 12 SP5: e2fsprogs 32bit-1.43.8-3.11.1

SUSE LE 15: new e2fsprogs packages.
New packages are available:
  SUSE LE 15 RTM: e2fsprogs 1.43.8-4.17.1
  SUSE LE 15 SP1: e2fsprogs 1.43.8-4.17.1

Ubuntu: new e2fsprogs packages.
New packages are available:
  Ubuntu 19.10: e2fsprogs 1.45.3-4ubuntu2.1
  Ubuntu 19.04: e2fsprogs 1.44.6-1ubuntu0.2
  Ubuntu 18.04 LTS: e2fsprogs 1.44.1-1ubuntu1.3
  Ubuntu 16.04 LTS: e2fsprogs 1.42.13-1ubuntu1.2
  Ubuntu 14.04 ESM: e2fsprogs 1.42.9-3ubuntu1.3+esm2
  Ubuntu 12.04 ESM: e2fsprogs 1.42-1ubuntu2.5
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an application vulnerability announce. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.