The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of glibc: privilege escalation via Setuid Stack

Synthesis of the vulnerability 

An attacker can bypass restrictions via Setuid Stack of glibc, in order to escalate his privileges.
Vulnerable software: Debian, VNX Operating Environment, VNX Series, BIG-IP Hardware, TMOS, Fedora, Junos Space, Kubernetes, McAfee Web Gateway, openSUSE Leap, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Ubuntu, Unix (platform) ~ not comprehensive.
Severity of this announce: 2/4.
Creation date: 20/06/2017.
Revision date: 29/06/2017.
Références of this computer vulnerability: CERTFR-2017-AVI-238, CERTFR-2017-AVI-365, CVE-2017-1000366, DLA-992-1, DSA-2019-197, DSA-3887-1, FEDORA-2017-698daef73c, FEDORA-2017-79414fefa1, FEDORA-2017-d80ab96e61, JSA10824, JSA10826, JSA10917, K20486351, openSUSE-SU-2017:1629-1, RHSA-2017:1479-01, RHSA-2017:1480-01, RHSA-2017:1481-01, SB10205, SSA:2017-181-01, SUSE-SU-2017:1611-1, SUSE-SU-2017:1614-1, SUSE-SU-2017:1619-1, SUSE-SU-2017:1621-1, Synology-SA-17:22, USN-3323-1, USN-3323-2, VIGILANCE-VUL-23005.

Description of the vulnerability 

An attacker can bypass restrictions via Setuid Stack of glibc, in order to escalate his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity bulletin impacts software or systems such as Debian, VNX Operating Environment, VNX Series, BIG-IP Hardware, TMOS, Fedora, Junos Space, Kubernetes, McAfee Web Gateway, openSUSE Leap, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Ubuntu, Unix (platform) ~ not comprehensive.

Our Vigil@nce team determined that the severity of this cybersecurity weakness is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this computer vulnerability bulletin.

Solutions for this threat 

Debian 7: new eglibc packages.
New packages are available:
  Debian 7: eglibc 2.13-38+deb7u12

Debian: new glibc packages.
New packages are available:
  Debian 8: glibc 2.19-18+deb8u10
  Debian 9: glibc 2.24-11+deb9u1

Dell EMC VNXe: version MR4 Service Pack 5.
The version MR4 Service Pack 5 is fixed:
  https://www.dell.com/support/

F5 BIG-IP: solution for Linux CVE-2017-1000366.
The solution is indicated in information sources.

Fedora: new glibc packages.
New packages are available:
  Fedora 24: glibc 2.23.1-12.fc24
  Fedora 25: glibc 2.24-8.fc25
  Fedora 26: glibc 2.25-6.fc26

Juniper Junos Space: solution.
The solution is indicated in information sources.

Junos Space: version 18.4R1.
The version 18.4R1 is fixed.

Kubernetes: version 1.5.8.
The version 1.5.8 is fixed:
  https://kubernetes.io/
  https://dl.k8s.io/v1.5.8/kubernetes.tar.gz

McAfee Web Gateway: versions 7.6.2.15 and 7.7.2.3.
Versions 7.6.2.15 and 7.7.2.3 are fixed:
  https://kc.mcafee.com/corporate/index?page=content&id=KB56057

openSUSE Leap 42.2: new glibc packages.
New packages are available:
  openSUSE Leap 42.2: glibc 2.22-4.9.1

RHEL: new glibc packages.
New packages are available:
  RHEL 5: glibc 2.5-107.el5_9.9
  RHEL 6: glibc 2.12-1.209.el6_9.2
  RHEL 7: glibc 2.17-157.el7_3.4

Slackware: new glibc packages.
New packages are available:
  Slackware 14.2: glibc 2.23-*-2_slack14.2

SUSE LE: new glibc packages.
New packages are available:
  SUSE LE 11 SP3: glibc 2.11.3-17.109.1
  SUSE LE 11 SP4: glibc 2.11.3-17.109.1
  SUSE LE 12 SP1: glibc 2.19-40.6.1
  SUSE LE 12 RTM: glibc 2.19-22.21.1
  SUSE LE 12 SP2: glibc 2.22-61.3

Ubuntu: new libc6 packages.
New packages are available:
  Ubuntu 17.04: libc6 2.24-9ubuntu2.2
  Ubuntu 16.10: libc6 2.24-3ubuntu2.2
  Ubuntu 16.04 LTS: libc6 2.23-0ubuntu9
  Ubuntu 14.04 LTS: libc6 2.19-0ubuntu6.13
  Ubuntu 12.04 ESM: libc6 2.15-0ubuntu10.20

Wind River Linux: patch for Stack Clash.
A patch is indicated in information sources.

Wind River Linux: solution of Mid-July 2017.
The solution is indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a system vulnerability note. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.