The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.

vulnerability bulletin CVE-2019-12795

gvfs: information disclosure via D-Bus Method

Synthesis of the vulnerability

An attacker can bypass access restrictions to data via D-Bus Method of gvfs, in order to obtain sensitive information.
Severity of this announce: 2/4.
Creation date: 20/06/2019.
Références of this computer vulnerability: bulletinoct2019, CVE-2019-12795, DLA-1827-1, FEDORA-2019-6ed5523cc0, FEDORA-2019-e6b02af8b8, openSUSE-SU-2019:1697-1, openSUSE-SU-2019:1699-1, RHSA-2019:3553-01, SUSE-SU-2019:1717-1, USN-4053-1, VIGILANCE-VUL-29575.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

An attacker can bypass access restrictions to data via D-Bus Method of gvfs, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

This security note impacts software or systems such as Debian, Fedora, openSUSE Leap, Solaris, RHEL, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat announce is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this computer weakness announce.

Solutions for this threat

Debian 8: new gvfs packages.
New packages are available:
  Debian 8: gvfs 1.22.2-1+deb8u1

Fedora: new gvfs packages.
New packages are available:
  Fedora 29: gvfs 1.38.3-1.fc29
  Fedora 30: gvfs 1.40.2-1.fc30

openSUSE Leap: new gvfs packages.
New packages are available:
  openSUSE Leap 15.0: gvfs 1.34.2.1-lp150.3.10.1
  openSUSE Leap 15.1: gvfs 1.34.2.1-lp151.6.3.1

Oracle Solaris: patch for third party software of October 2019 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 8: new gnome module.
The following module is updated:
  RHEL 8 Module: gnome

SUSE LE 15: new gvfs packages.
New packages are available:
  SUSE LE 15 RTM: gvfs 1.34.2.1-4.13.1
  SUSE LE 15 SP1: gvfs 1.34.2.1-4.13.1

Ubuntu: new gvfs packages.
New packages are available:
  Ubuntu 19.04: gvfs 1.40.1-1ubuntu0.1
  Ubuntu 18.10: gvfs 1.38.1-0ubuntu1.3.2
  Ubuntu 18.04 LTS: gvfs 1.36.1-0ubuntu1.3.3
  Ubuntu 16.04 LTS: gvfs 1.28.2-1ubuntu1~16.04.3
Full Vigil@nce bulletin... (Free trial)

Computer vulnerabilities tracking service

Vigil@nce provides system vulnerability alerts. Each administrator can customize the list of products for which he wants to receive vulnerability alerts. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.