The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of hostapd: denial of service via adress spoofing

Synthesis of the vulnerability 

An attacker can disconnect Wi-Fi devices with adress spoofing, in order to trigger a denial of service.
Impacted software: Debian, Fedora, Android OS, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this computer vulnerability: 1/4.
Creation date: 17/09/2019.
Références of this announce: CVE-2019-16275, DLA-1922-1, DSA-4538-1, FEDORA-2019-0e0b28001d, FEDORA-2019-2265b5ae86, FEDORA-2019-2bdcccee3c, FEDORA-2019-65509aac53, FEDORA-2019-740834c559, openSUSE-SU-2020:2053-1, openSUSE-SU-2020:2059-1, SUSE-SU-2020:3380-1, SUSE-SU-2020:3424-1, USN-4136-1, VIGILANCE-VUL-30340.

Description of the vulnerability 

An attacker can disconnect Wi-Fi devices with adress spoofing, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat bulletin impacts software or systems such as Debian, Fedora, Android OS, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat bulletin is low.

The trust level is of type confirmed by the editor, with an origin of LAN.

An attacker with a expert ability can exploit this computer threat.

Solutions for this threat 

Debian 10: new wpa packages.
New packages are available:
  Debian 10: wpa 2:2.7+git20190128+0c1e29f-6+deb10u1

Debian 8: new wpa packages.
New packages are available:
  Debian 8: wpa 2.3-1+deb8u9

Fedora: new hostapd packages.
New packages are available:
  Fedora 30: hostapd 2.9-2.fc30
  Fedora 31: hostapd 2.9-2.fc31

Fedora: new wpa_supplicant packages.
New packages are available:
  Fedora 29: wpa_supplicant 2.7-2.fc29
  Fedora 30: wpa_supplicant 2.8-3.fc30
  Fedora 31: wpa_supplicant 2.9-2.fc31

Google Android/Pixel: patch for June 2020.
A patch is indicated in information sources.

openSUSE Leap 15.1: new wpa_supplicant packages.
New packages are available:
  openSUSE Leap 15.1: wpa_supplicant 2.9-lp151.5.10.1

openSUSE Leap 15.2: new wpa_supplicant packages.
New packages are available:
  openSUSE Leap 15.2: wpa_supplicant 2.9-lp152.8.3.1

SUSE LE 12 SP5: new wpa_supplicant packages.
New packages are available:
  SUSE LE 12 SP5: wpa_supplicant 2.9-23.3.1

SUSE LE 15 RTM-SP2: new wpa_supplicant packages.
New packages are available:
  SUSE LE 15 RTM: wpa_supplicant 2.9-4.20.1
  SUSE LE 15 SP1: wpa_supplicant 2.9-4.20.1
  SUSE LE 15 SP2: wpa_supplicant 2.9-4.20.1

Ubuntu: new wpasupplicant packages.
New packages are available:
  Ubuntu 19.04: hostapd 2:2.6-21ubuntu3.3, wpasupplicant 2:2.6-21ubuntu3.3
  Ubuntu 18.04 LTS: hostapd 2:2.6-15ubuntu2.5, wpasupplicant 2:2.6-15ubuntu2.5
  Ubuntu 16.04 LTS: hostapd 1:2.4-0ubuntu6.6, wpasupplicant 2.4-0ubuntu6.6
  Ubuntu 14.04 ESM: hostapd 1:2.1-0ubuntu1.7+esm2, wpasupplicant 2.1-0ubuntu1.7+esm2
  Ubuntu 12.04 ESM: wpasupplicant 0.7.3-6ubuntu2.5
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a software vulnerabilities note. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.