The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of ipmitool: buffer overflow via lib/ipmi_fru.c

Synthesis of the vulnerability 

An attacker can trigger a buffer overflow via lib/ipmi_fru.c of ipmitool, in order to trigger a denial of service, and possibly to run code.
Impacted products: Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.
Severity of this bulletin: 2/4.
Creation date: 10/02/2020.
Références of this threat: CVE-2020-5208, DLA-2098-1, openSUSE-SU-2020:0247-1, RHSA-2020:0979-01, RHSA-2020:0981-01, RHSA-2020:0984-01, RHSA-2020:1331-01, RHSA-2020:1486-01, RHSA-2020:2213-01, RHSA-2020:2276-01, RHSA-2020:2284-01, RHSA-2020:2286-01, SUSE-SU-2020:0405-1, SUSE-SU-2020:0617-1, SUSE-SU-2020:0630-1, SUSE-SU-2020:14313-1, VIGILANCE-VUL-31563.

Description of the vulnerability 

An attacker can trigger a buffer overflow via lib/ipmi_fru.c of ipmitool, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer weakness announce impacts software or systems such as Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this security alert is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this vulnerability.

Solutions for this threat 

Debian 8: new ipmitool packages.
New packages are available:
  Debian 8: ipmitool 1.8.14-4+deb8u1

openSUSE Leap 15.1: new ipmitool packages.
New packages are available:
  openSUSE Leap 15.1: ipmitool 1.8.18-lp151.4.3.1

RHEL 6.10: new ipmitool packages.
New packages are available:
  RHEL 6.10: ipmitool 1.8.15-3.el6_10

RHEL 7.2-7.6: new ipmitool packages.
New packages are available:
  RHEL 7.2: ipmitool 1.8.13-10.el7_2
  RHEL 7.3: ipmitool 1.8.15-8.el7_3
  RHEL 7.4: ipmitool 1.8.18-6.el7_4
  RHEL 7.5: ipmitool 1.8.18-9.el7_5
  RHEL 7.6: ipmitool 1.8.18-9.el7_6

RHEL 7.7: new ipmitool packages.
New packages are available:
  RHEL 7.7: ipmitool 1.8.18-9.el7_7

RHEL 8.0: new ipmitool packages.
New packages are available:
  RHEL 8.0: ipmitool 1.8.18-12.el8_0

RHEL 8.1: new ipmitool packages.
New packages are available:
  RHEL 8.1: ipmitool 1.8.18-12.el8_1

SUSE LE 11: new ipmitool packages.
New packages are available:
  SUSE LE 11 SP4: ipmitool 1.8.15-0.30.3.1

SUSE LE 12: new ipmitool packages.
New packages are available:
  SUSE LE 12 SP5: ipmitool 1.8.18-5.9.1
  SUSE LE 12 SP4: ipmitool 1.8.18-5.9.1
  SUSE LE 12 SP3: ipmitool 1.8.18-5.9.1

SUSE LE 15: new ipmitool packages.
New packages are available:
  SUSE LE 15 SP1: ipmitool 1.8.18-7.3.1
  SUSE LE 15 RTM: ipmitool 1.8.18-4.3.1

Wind River Linux: version 10.17.41.20.
The version 10.17.41.20 is fixed:
  https://support2.windriver.com/

Wind River Linux: version 10.18.44.16.
The version 10.18.44.16 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a cybersecurity announce. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.