The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of irssi: denial of service via Timestamp

Synthesis of the vulnerability 

An attacker can generate a fatal error via Timestamp of irssi, in order to trigger a denial of service.
Impacted systems: Debian, Fedora, openSUSE Leap, Solaris, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 2/4.
Creation date: 10/07/2017.
Références of this alert: bulletinjan2018, CVE-2017-10965, DLA-1089-1, DSA-4016-1, FEDORA-2017-114e1abf9d, FEDORA-2017-90ad72e684, openSUSE-SU-2017:1823-1, openSUSE-SU-2017:1824-1, SSA:2017-190-01, USN-3465-1, VIGILANCE-VUL-23171.

Description of the vulnerability 

An attacker can generate a fatal error via Timestamp of irssi, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat bulletin impacts software or systems such as Debian, Fedora, openSUSE Leap, Solaris, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this security threat is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this computer vulnerability alert.

Solutions for this threat 

Debian 7: new irssi packages.
New packages are available:
  Debian 7: irssi 0.8.15-5+deb7u3

Debian 8/9: new irssi packages.
New packages are available:
  Debian 8: irssi 0.8.17-1+deb8u5
  Debian 9: irssi 1.0.2-1+deb9u3

Fedora: new irssi packages.
New packages are available:
  Fedora 25: irssi 1.0.4-1.fc25
  Fedora 26: irssi 1.0.4-1.fc26

openSUSE Leap 42.2: new irssi packages.
New packages are available:
  openSUSE Leap 42.2: irssi 1.0.4-14.10.1

Oracle Solaris: patch for third party software of January 2018 v3.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

Slackware: new irssi packages.
New packages are available:
  Slackware 14.0: irssi 1.0.4-*-1_slack14.0
  Slackware 14.1: irssi 1.0.4-*-1_slack14.1
  Slackware 14.2: irssi 1.0.4-*-1_slack14.2

SUSE LE 12: new irssi packages.
New packages are available:
  SUSE LE 12 RTM-SP2: irssi 1.0.4-28.1

Ubuntu: new irssi packages.
New packages are available:
  Ubuntu 17.10: irssi 1.0.4-1ubuntu2.1
  Ubuntu 17.04: irssi 0.8.20-2ubuntu2.2
  Ubuntu 16.04 LTS: irssi 0.8.19-1ubuntu1.5
  Ubuntu 14.04 LTS: irssi 0.8.15-5ubuntu3.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an applications vulnerabilities note. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.